iTunes verlängert die Dauer von Songs...

TGY

Mitglied
Mitglied seit
12.04.2004
Beiträge
1.106
• Welche(s) Format(e ) betrifft der Fehler? (mp3, wav, m4a … ?) Soweit ich sagen kann nur mp3
Beide deiner hochgeladenen Dateien haben zwar in den ID3Tags mehrere Private Frames, die ich löschen würde, doch dieses Mal sind die blöden ID3Tags wohl nicht die Ursache.
Wenn man die Cover beider Dateien löscht und sie vergleicht, gibts 2 markante Unterschiede: 2 Bytes ungefähr am Anfang der Datei, die m.W.n. auch die ausgelesene Längenangabe beeinflussen, und in der Tat 1018.1 kilobytes an duplizierten Daten. Die wirst du vermutlich auf einfache Art und Weise nicht sauber löschen können.
Also anscheinend hab nur ich das Problem
Hab zum Testen mal einige mp3-Dateien mit nur den notwendigen ID3v2-Tags (ohne ID3v1-Tags) erstellt. Bei jeder Bearbeitung des Covers (auch einfaches Löschen eines Covers) verlängert sich die angezeigte Laufzeit in iTunes.
Ist vermutlich ein iTunes-Bug.
Ist bei mir auch so, allerdings kommen die Daten von CDs...
Hab einige alte AACs neu als ALAC importiert (nach CD-Rip mit XLD). Wenn ich die alten AACs dann nachher lösche, kommt es oft vor, dass iTunes beide Versionen (AAC und ALAC) löscht. Workaround i.M.: Ich benenne das alte Album um.
 
  • Gefällt mir
Reaktionen: Macs Pain

Veritas

Mitglied
Mitglied seit
26.11.2007
Beiträge
19.394
Hab einige alte AACs neu als ALAC importiert (nach CD-Rip mit XLD). Wenn ich die alten AACs dann nachher lösche, kommt es oft vor, dass iTunes beide Versionen (AAC und ALAC) löscht. Workaround i.M.: Ich benenne das alte Album um.
Bei 34.000 Liedern ist das etwas mühselig ;) Ich teste erstmal Swinsian für den Sync und zum Musikhören bin ich schon umgestiegen.
 

daimon

Mitglied
Mitglied seit
23.06.2010
Beiträge
436
Hab zum Testen mal einige mp3-Dateien mit nur den notwendigen ID3v2-Tags (ohne ID3v1-Tags) erstellt. Bei jeder Bearbeitung des Covers (auch einfaches Löschen eines Covers) verlängert sich die angezeigte Laufzeit in iTunes.
Mit dem aktuellen iTunes 12.9? Dann kann ich nur hoffen, dass möglichst viele User Apple mit reproduzierbaren Bug-Reports bombardieren und das außerdem weiter in die Öffenlichkeit tragen.
Problematisch ist: Wer nur mittels iTunes hört, bemerkt ja gar nicht, dass seine Dateien kaputt sind.
Ich kann mich leider nicht beteiligen; hab kein Mojave, und daher noch iTunes 12.8.

Und bitte diesen Thread nicht für andere Bugs kapern - danke.
 
  • Gefällt mir
Reaktionen: dg2rbf und Macs Pain

Veritas

Mitglied
Mitglied seit
26.11.2007
Beiträge
19.394
Mit dem aktuellen iTunes 12.9? Dann kann ich nur hoffen, dass möglichst viele User Apple mit reproduzierbaren Bug-Reports bombardieren und das außerdem weiter in die Öffenlichkeit tragen.
Problematisch ist: Wer nur mittels iTunes hört, bemerkt ja gar nicht, dass seine Dateien kaputt sind.
Ich kann mich leider nicht beteiligen; hab kein Mojave, und daher noch iTunes 12.8.

Und bitte diesen Thread nicht für andere Bugs kapern - danke.
Wie gesagt, roon spielt die Tracks korrekt ab.
 

daimon

Mitglied
Mitglied seit
23.06.2010
Beiträge
436
Alle Apple-Apps tun das ebenso. Das ändert aber nichts daran, dass die Dateien kaputt sind.
 

daimon

Mitglied
Mitglied seit
23.06.2010
Beiträge
436
Schon klar. Aber mein Satz ist trotzdem nicht falsch.
 

Isegrim242

Mitglied
Mitglied seit
21.07.2005
Beiträge
3.285
Hab’s hier auch mal ausprobiert – selbes Ergebnis (10.14.4 / iTunes 12.9.4.94).
:clap: Ganz großes Kino… :faint:
 
  • Gefällt mir
Reaktionen: Macs Pain

vanyedoom

Mitglied
Mitglied seit
18.01.2019
Beiträge
25
Betrifft dieses sonderbare Problem nur die iTunes-Version unter Mojave?
 

daimon

Mitglied
Mitglied seit
23.06.2010
Beiträge
436
Anscheinend ja. Mit dem aktuellsten iTunes 12.8 kann ich es jedenfalls nicht reproduzieren.
 

Isegrim242

Mitglied
Mitglied seit
21.07.2005
Beiträge
3.285
Hmm…bei meinem Kollegen (auch unter 10.14.4 / iTunes 12.9.4.94) bekomme ich das nicht reproduziert. :kopfkratz:
Er hat nen 27" iMac (~2015). Bei mir auf nem 2018er mini tritt es wie gesagt auch auf.
 

daimon

Mitglied
Mitglied seit
23.06.2010
Beiträge
436
Welches Dateisystem hat denn jeweils die Platte, auf der die Tracks liegen? Auch unter Mojave kann man ja externe Platten mit HFS+ anschließen. Kann es sein, dass der Bug nur mit APFS auftritt?
 

Isegrim242

Mitglied
Mitglied seit
21.07.2005
Beiträge
3.285
Bei mir liegt die Library liegen alle Dateien auf ’nem externen HFS+ Volume – bei ihm auf der internen APFS.
 
Zuletzt bearbeitet:

Macs Pain

Mitglied
Thread Starter
Mitglied seit
26.06.2003
Beiträge
6.401
Bei mir liegt alles intern auf dem Fusion Drive.
 

Bozol

Mitglied
Mitglied seit
16.07.2003
Beiträge
2.342
Hi Macs Pain,

wie ging das Ganze damals aus?

Auch ich habe nun das Problem das am Songende ca. 15 Sekunden angehängt wurden. In den Songsinfos steht ein falscher Endzeitpunkt, bei manchen Songs funktioniert die Abspielzähler-Funktion nicht mehr, es betrifft nur eine Playlist mit ca. 1500 Aufnahmen und diese Songs haben alle in Music/Infos den gleichen Dateiveränderungszeitpunkt.

Es sind komischerweise nicht alle Songs der Playlist betroffen, mir fällt aber keine Lösung ein um die betroffenen Songs aussortieren zu können. Dummerweise kann ich die Songs nicht neu rippen da es sich ausschließlich um Online-Radio Mitschnitte handelt.

Konntest Du das Problem lösen? Oder hat vielleicht jemand anders eine Idee?

LG
Fred
 

Schiffversenker

Mitglied
Mitglied seit
25.06.2012
Beiträge
10.779
Welches System, welche iTunes-Version, oder bei welchen anderen Programmen mit welcher Version hast du mal getestet mit gleichem Ergebnis?
Auch im Finder, über Quicklook?

Du schreibt, daß du das Problem "nun" hast - seit wann?
Eine Systemaktualisierung? Rechnerwechsel? Irgendeine Neuinstallation, eine Erweiterung, die irgendwas mit Audio zu tun hat?

Hast du in iTunes bei dieser Wiedergabeliste mal alle denkbaren Angaben eingeblendet, um zu schauen, worin sich die betroffenen von den nicht betroffenen Tracks unterscheiden? Vielleicht konstante Bitrate gegen VBR, vielleicht unterschiedliche Bitraten? Unterschiedliche Dauer? Vielleicht von verschiedenen Programmen mitgeschnitten?

Anderer Ansatz: Kopiere mal einige der betroffenen Tracks in die iTunes-Mediathek eines neu angelegten Benutzers und schau, was da passiert. Gibt es da kein Problem, würde das bedeuten, daß die Ursache irgendwo in deinem Benutzeraccount steckt.
 

Macs Pain

Mitglied
Thread Starter
Mitglied seit
26.06.2003
Beiträge
6.401
Hi Macs Pain,

wie ging das Ganze damals aus?

Auch ich habe nun das Problem das am Songende ca. 15 Sekunden angehängt wurden. In den Songsinfos steht ein falscher Endzeitpunkt, bei manchen Songs funktioniert die Abspielzähler-Funktion nicht mehr, es betrifft nur eine Playlist mit ca. 1500 Aufnahmen und diese Songs haben alle in Music/Infos den gleichen Dateiveränderungszeitpunkt.

Es sind komischerweise nicht alle Songs der Playlist betroffen, mir fällt aber keine Lösung ein um die betroffenen Songs aussortieren zu können. Dummerweise kann ich die Songs nicht neu rippen da es sich ausschließlich um Online-Radio Mitschnitte handelt.

Konntest Du das Problem lösen? Oder hat vielleicht jemand anders eine Idee?

LG
Fred
Naja, alle Songs wo ich das Problem festgestellt hatte, hab ich mit Time Machine zurück geholt und tunlichst nichts mehr daran geändert, werder Cover noch sonst was.
Meine Sorge ist jetzt, daß es noch mehr Songs betrifft, aber meine Time Machine-Platte ist in der Zwischenzeit abgeraucht...
 

Bozol

Mitglied
Mitglied seit
16.07.2003
Beiträge
2.342
Welches System, welche iTunes-Version, oder bei welchen anderen Programmen mit welcher Version hast du mal getestet mit gleichem Ergebnis?
Auch im Finder, über Quicklook?
Catalina 10.15.5, Musik 1.0.5.14, Gegenprobe gemacht mit Quicklook, IINA, Fidelia, Audacity, alle zeigen die falsche Länge und spielen sie auch ab.
Du schreibt, daß du das Problem "nun" hast - seit wann?
Kann ich nicht genau sagen, mir fiel es vor ein paar Wochen zum ersten Mal beim Musik hören im Auto auf
Eine Systemaktualisierung? Rechnerwechsel? Irgendeine Neuinstallation, eine Erweiterung, die irgendwas mit Audio zu tun hat?
Nur das normale OS Update, habe seit letzten Herbst ein neues Logicboard, keine Neuinstallation, keine Erweiterung
Hast du in iTunes bei dieser Wiedergabeliste mal alle denkbaren Angaben eingeblendet, um zu schauen, worin sich die betroffenen von den nicht betroffenen Tracks unterscheiden? Vielleicht konstante Bitrate gegen VBR, vielleicht unterschiedliche Bitraten? Unterschiedliche Dauer? Vielleicht von verschiedenen Programmen mitgeschnitten?
Alle Angaben eingeblendet und kontrolliert, nur CBR, 90% mit 192kbps, 90% mit XStreamripper mitgeschnitten, seit Catalina mit Streamripper.
Soviel ich mittlerweile heraus bekommen habe wurden bei den Songs immer ca. 16 Sekunden angehängt. Mein Problem ist dass ich bei den defekten Songs keinen gemeinsamen Nenner finde um sie alle sicher zu identifizieren.
Macs Pain schrieb:
Naja, alle Songs wo ich das Problem festgestellt hatte, hab ich mit Time Machine zurück geholt
Das geht bei mir leider nicht mehr, ich musste Anfang des Jahres meine ™ neu aufsetzen.

Was mir aber, nachdem ich den Thread nochmals gelesen habe, nicht ganz klar ist: sind die Songs jetzt durch die "Nachspielzeit" physisch verändert worden (Dateigröße) oder ist nur ein Flag innerhalb der Datei, dass die Länge des Songs angibt, falsch gesetzt?