Ständig temporäre Dateien. Lösung?

MacMini2k18

Neues Mitglied
Thread Starter
Registriert
07.11.2018
Beiträge
31
Hallo,

vielleicht bin ich einfach nur zu doof, aber ich habe auf dem Mac Mini sowie auf dem MacBook Air (brauche beides beruflich) folgendes Problem:

Ich arbeite sehr viel mit Numbers und vor allem aber mit PDFs. Sobald ich eine PDF, die per Mail kam, öffne, speichert er die automatisch.
Zu Beginn hatte ich nach einem Arbeitstag den kompletten Schreibtisch voll mit Dateien, die ich zum Teil nur einmal kurz angeschaut habe.

Wie kann ich das verhindern? Er soll keine Dateien speichern, wenn ich es nicht möchte. Ich habe mittlerweile einen TEMP-Ordner angelegt, in dem nach einer Arbeitswoche mehrere Hundert Dateien, Bilder, PDFs, Tabellen etc drin sind.

Bitte um Abhilfe!

Vielen Dank im Vorraus!
 

csomm004

unregistriert
Registriert
01.07.2021
Beiträge
246
Dazu wäre erstmal Sinnvoll zu wissen welcher Mac ? M1 oder Intel. Welches Emailprogramm ? Bei mir öffnet sich eine PDF einfach nur in der Vorschau App und speichert sich nirgends automatisch hin. ( AppleMail, Big Sur,M1)
 

walfreiheit

Aktives Mitglied
Registriert
06.06.2004
Beiträge
34.577
Dazu wäre erstmal Sinnvoll zu wissen welcher Mac ? M1 oder Intel. Welches Emailprogramm ? Bei mir öffnet sich eine PDF einfach nur in der Vorschau App und speichert sich nirgends automatisch hin. ( AppleMail, Big Sur,M1)
Bei mir auch nicht. Irgendwie nicht ganz normal das Verhalten.
 

MacMini2k18

Neues Mitglied
Thread Starter
Registriert
07.11.2018
Beiträge
31
Hallo!

Ich arbeite mit Firefox und Thunderbird. Mac mini (2018) mit dem i3. (Hauptarbeitsplatz=

PDFs öffne ich mit dem Adobe Acrobat Reader.

Soeben auch wieder. Mail kam an, Kundenrechnung per PDF nur geöffnet mit dem Adobe und siehe da, er hat die wieder in dem temporären Ordner abgelegt, obwohl ich nur geöffnet habe.
 

gishmo

Aktives Mitglied
Registriert
16.03.2004
Beiträge
1.160
Ich vermute, dass dein Download-Ordner auf deinen Desktop zeigt. Dass ein PDF aus einer E-Mail erst geladen um dann angezeigt zu werden, ist eingentlich normal.
 

MacMini2k18

Neues Mitglied
Thread Starter
Registriert
07.11.2018
Beiträge
31
Hallo,
ich klicke nicht auf "Speichern unter" sondern auf "Öffnen mit..."
Dann schaue ich mir die PDF an, danach schliesse ich sie ohne irgendwas zu speichern und trotzdem legt der eine Datei an, die er auch nicht mehr von alleine löscht nach dem schliessen.
Bei Windoof kenne ich das so nicht... Daher meine Frage wie ich das hier geändert bekomme.
 

hutzi20

Aktives Mitglied
Registriert
08.08.2013
Beiträge
1.460
Das ist ein Bug von Thunderbird unter macOS. So habe ich es zu mindestens beim schnellen googeln gelesen. Problem besteht wohl seit längerem.
Thunderbird ist wohl manchmal zu dusselig die Daten in den Temp Ordner zu packen und speichert sie dann auf dem Desktop.
 

Schiffversenker

Aktives Mitglied
Registriert
25.06.2012
Beiträge
12.658
Thunderbird ist wohl manchmal zu dusselig die Daten in den Temp Ordner zu packen und speichert sie dann auf dem Desktop.
Das Problem des TE ist aber nicht der Speicherort sondern daß überhaupt gespeichert wird.

Können wir davon ausgehen, daß der TE bereits geschaut hat, ob es da eine Einstellmöglichkeit in Thunderbird besteht?
 

hutzi20

Aktives Mitglied
Registriert
08.08.2013
Beiträge
1.460
Das Problem des TE ist aber nicht der Speicherort sondern daß überhaupt gespeichert wird.
Irgendwo muss Thunderbird die PDFs ja speichern um sie anzuzeigen.

Die normale Mail App lädt die Anhänge direkt runter unter speichert sie unter /Users/xxxx/Library/Containers/com.apple.mail/Data/Library/Mail Downloads/91642A54-0CAC-4D8A-B391-A492AF593BA0/

Von dort wird die PDF dann geöffnet.

Thunderbird hingegen lädt den Anhang nicht sofort herunter. Erst wenn man den Anhang öffnet wird die Datei über IMAP heruntergeladen und muss dementsprechend irgendwo abgelegt werden um sie dann zu öffnen. Normalerweise geht es direkt in den Temp Ordner und wird danach wieder gelöscht. Der Bug besteht allerdings darin dass der Temp Ordner nicht gefunden wird und Thunderbird es dann auf dem Desktop speichert und nicht wieder löscht.

Das hat nichts damit zu tun ob der User es abspeichern will oder nicht.
 

MacMini2k18

Neues Mitglied
Thread Starter
Registriert
07.11.2018
Beiträge
31
Hallo,
danke für eure Beiträge.
Ja, ich habe schon nachgeschaut, da gibts keine derartigen Einstellmöglichkeiten. Man kann nur den Speicherort auswählen, habe dafür einen extra TEMP Ordner angelegt, damit er mir nicht den Schreibtisch vermüllt.

Exakt. Das Problem ist, dass er grundsätzlich speichert, obwohl er nur öffnen soll. Habe vorhin mal das alte Windoof-Notebook rausgekramt. Da sind die Einstellungen exakt gleich.

Frustrierend :-D
 

dg2rbf

Aktives Mitglied
Registriert
08.05.2010
Beiträge
8.396
Hi,
Da hilft nur diesen Bug in Thunderbird, dem Support von Thunderbird melden.
Gruss Franz
 

xentric

Aktives Mitglied
Registriert
11.05.2007
Beiträge
4.209
https://bugzilla.mozilla.org/show_bug.cgi?id=1387292

"Workarounds" gibts genug:
http://forums.mozillazine.org/viewtopic.php?f=39&t=2925221&p=14097695#p14097695

http://forums.mozillazine.org/viewtopic.php?f=39&t=2925221&p=14097695#p14097695 schrieb:
1) My preferred solution:
Open TB Preferences -> Attachments -> Incoming.
Choose "Save files to" and hit the "Choose" button.
In the upcoming Finder window select "Macintosh HD", then hit the Shift + Cmd + . (period) keyboard shortcut to show the hidden folders
(N.B. in your Finder window the "List" view must be active, otherwise the keyboard shortcut won't work).
Browse to /private/, select /temp/ and hit "Open".

Now, when you open attachments they will be stored in the hidden temp folder and no longer on your Desktop.
The temp folder will be cleared at each system restart (--> "Recovered files" in the Mac's Trash bin).

2) If you prefer a simple workaround:
open TB Preferences > Advanced > General > Config editor (about:config),
search for "browser.helperApps.deleteTempFileOnExit" and set its value to true.
Now all attachments scattered around on your Desktop will disappear on TB shut down.
 

Difool

Frontend Admin
Registriert
18.03.2004
Beiträge
13.221
Hallo,
ich klicke nicht auf "Speichern unter" sondern auf "Öffnen mit..."
Dann schaue ich mir die PDF an, danach schliesse ich sie ohne irgendwas zu speichern und trotzdem legt der eine Datei an, die er auch nicht mehr von alleine löscht nach dem schliessen.
Bei Windoof kenne ich das so nicht... Daher meine Frage wie ich das hier geändert bekomme.
Um nur kurz etwas anzusehen, in einer empfangenen eMail den Anhang bsw., reicht es den Anhang zu markieren (auswählen) und die Leertaste zu drücken.
Quickview zeigt dann das PDF z.B. "aus der eMail heraus" – ohne es irgendwo hin zu speichern etc.
 

win2mac

Aktives Mitglied
Registriert
07.09.2004
Beiträge
3.494
Um nur kurz etwas anzusehen, in einer empfangenen eMail den Anhang bsw., reicht es den Anhang zu markieren (auswählen) und die Leertaste zu drücken.
Quickview zeigt dann das PDF z.B. "aus der eMail heraus" – ohne es irgendwo hin zu speichern etc.
Aber nicht wenn sie als Anhänge in Thunderbird angezeigt werden.
 
Oben Unten