OS auf Sata-SSD oder PCI-NVME

  • Ersteller doncorleone pro
  • Erstellt am
doncorleone pro

doncorleone pro

Aktives Mitglied
Thread Starter
Dabei seit
05.03.2008
Beiträge
780
Reaktionspunkte
5
Ich stehe gerade vor der Frage ob ich mein OS auf einer Sata SSD belassen soll, oder ob ich auf eine PCI NVME wechseln soll. Dachte eigentlich dass für das reine System und Speicher der Programme eine SSD ausreichen würde. Aber scheinbar wechseln doch viele auf die schnellere NVME Variante. Was genau wären die Vorteile gegenüber der Sata-SSD? Merkt man da einen großen Unterschied in der Performance/Stabilität?
 
Merkt man da einen großen Unterschied
Und ob. Dürfte auch klar sein.
Hier kannst Du Einiges zum Thema bzw. der Umsetzung nachlesen (s. auch Benchmark). Sowohl macOS als auch WinOS sind bei meinem MP5.1 auf NVMe-SSDs untergebracht. WinOS ist etwas tüfteliger - macOS überhaupt kein Problem.
https://www.macuser.de/threads/mac-pro-5-1-win10-uefi-nvme-ssd-970-evo-plus.928889/

So schaut das dann im FPDP aus:

FPDP@MP5.1.png
 
Den Unterschied merkt man in der Regel kaum. Eine SATA SSD schafft ca. 550 MB/s. Eine durchschnittliche NVMe SSD schafft 2000-3000 MB/s. Diesen Unterschied merkt man in der Regel nur wenn man regelmäßig und häufig sehr große Datenmengen auf entsprechend andere ebenso schnelle SSDs überträgt.
Man kann im Internet Tests finden die zeigen das Apps mit NVMe SSD statt SATA SSD im 1/10 Sekundenbereich schneller starten können. Der Mac startet vielleicht auch ein paar Sekunden schneller. Das eigentliche arbeiten im normalen Bereich ist wenig betroffen und auch nie langsam. Bei extremen Sachen mit Video/Bildern ist das etwas anderes.

Viel wesentlicher ist, das SSDs im Vergleich zu HDDs einen ca. 100x schnelleren Zugriff auf die Daten haben. Da spielt es keine Rolle ob das eine SATA oder NVMe SSD ist.
Da die Preise für NVMe SSDs im Vergleich zu früheren Jahren stark gesunken sind und diese kaum noch teurer sind als die SATA Varianten, lohnt bei einer neuen Anschaffung die NVMe!
 
Beim MP ist der Unterschied größer, dank Sata 2 werden hier etwa bis 300 MB/sec bei der Sata SSD erreicht, bei der NVMe bis 1500 MB/sec

Es komme immer drauf an, wenn ich eine App habe die auf der Systemdisk auslagert dann merke ich das. Ich behaupt Otto Normaluser wird es nicht bemerken.

Wirtschaftlich besteht inzwischen kein Grund auf eine NVMe zu verzichten, die Preise geben sich nichts mehr.
 
Beim MP ist der Unterschied größer, dank Sata 2 werden hier etwa bis 300 MB/sec bei der Sata SSD erreicht, bei der NVMe bis 1500 MB/sec
Eben - und hier geht es um den MP5.1 des TE.
Wirtschaftlich besteht inzwischen kein Grund auf eine NVMe zu verzichten, die Preise geben sich nichts mehr
Ist fast wie bei Gas & Öl: die Preise laufen fast parallel, haben aber in beiden Fällen in den letzten Monaten mehr als ordentlich zugelegt. Ich kann froh sein, im Sommer eingekauft zu haben.
 
Geht es wirklich nur um einen MP 5.1 oder ist das eine allg. Frage gewesen?
 
War gezielt auf den Einsatz mit dem MP 5.1
Ok. Wäre gut das eingangs zu schreiben da das einen Unterschied machen kann. Wir sind ja hier im Forum Peripherie.

Wenn der MP 5.1 SATA II hat, dann wäre eine SATA III SSD dadurch auf ca. 50% ihrer Übertragungsrate limitiert. Ob das einen Unterschied zu SATA III in der Nutzung macht ist fraglich. Was machst du denn so?
 
Was machst du denn so?
Hauptsächlich Videoschnitt (Premiere), also auf der Systemplatte eigentlich wirklich nur Programme gelagert...alles was Medien Daten betrifft bin ich sowieso auf den schnellen NVMEs.
 
Aber bitte nicht einfach irgendeine NVMe kaufen. Nicht alle laufen auch im Mac Pro
 
Ich kann von einwandfreiem Betrieb mit der Samsung 970 EVO Plus, der Samsung 980 Pro & der WD_Black SN770 im MP5.1 berichten (s. auch Bild #2).
Verwendest du einen einfachen Adapter oder einen Mehrfach-Adapter? Wenn es ein Mehrfach-Adapter ist, ist deine Aussage recht wertlos. Die 980 Pro dürfte nämlich laut Macrumors.com nicht einwandfrei arbeiten.
 
Wenn es ein Mehrfach-Adapter ist, ist deine Aussage nämlich wertlos
Überdenke Deine Aussage doch nochmal - vielleicht möchtest Du das Bild oben auch noch anschauen.

Die 980 Pro dürfte nämlich laut Macrumors.com nicht einwandfrei arbeiten
Ist das so? Weil Macrumors.com sagt, dass die 980 Pro nicht einwandfrei arbeitet, muss es auch so sein? Offenbar hat die 980 Pro das gar nicht mitbekommen, als sie noch im MP5.1 steckte.
Aber wurde von der 970 EVO Plus nicht auch behauptet, dass sie im MP nicht einwandfrei arbeitet? Funktioniert immer noch. Was mache ich nur falsch?

Man könnte in Abwandlung einer Redensart sagen: "Alle sagten, das geht nicht. Da kam eine NVMe. die das nicht wusste und funktionierte." :LOL:
 
Zuletzt bearbeitet:
Überdenke Deine Aussage doch nochmal - vielleicht möchtest Du das Bild oben auch noch anschauen.


Ist das so? Weil Macrumors.com sagt, dass die 980 Pro nicht einwandfrei arbeitet, muss es auch so sein? Offenbar hat die 980 Pro das gar nicht mitbekommen, als sie noch im MP5.1 steckte.
Aber wurde von der 970 EVO Plus nicht auch behauptet, dass sie im MP nicht einwandfrei arbeitet? Funktioniert immer noch. Was mache ich nur falsch?

Man könnte in Abwandlung einer Redensart sagen: "Alle sagten, das geht nicht. Da kam eine NVMe. die das nicht wusste und funktionierte." :LOL:

Poste doch bitte mal den Adapter auf dem deine M.2 NVMe SSDs stecken, denn das Bild sagt nicht wirklich etwas dazu aus.
 
Langsam müsstest Du doch inzwischen verstanden haben, dass in meinem MP kein Mehrfachadapter, sondern Einzel-Adapter verbaut sind, wenn Du die Threads bzgl. Mehrfachadapter, Raid etc. in letzter Zeit nur ein bißchen verfolgt hast. Hast Du Dich wieder triggern lassen?

Insofern hättest Du Dir von vorne herein den Satz mit "wertlos" sparen können, denn m. W. gibt es hier einen einzigen Foristen, der in seinem MP5.1 eine dafür geeignete Mehrfachkarte verbaut hat, die kürzlich hier wieder im Mac Pro-Forum vorgestellt wurde.
 
Den Unterschied merkt man in der Regel kaum. Eine SATA SSD schafft ca. 550 MB/s. Eine durchschnittliche NVMe SSD schafft 2000-3000 MB/s. Diesen Unterschied merkt man in der Regel nur wenn man regelmäßig und häufig sehr große Datenmengen auf entsprechend andere ebenso schnelle SSDs überträgt.
Würde ich jetzt so nicht unterschreiben. Für die „gefühlte“ Geschwindigkeit, also dafür, wie responsiv/„snappy" der Rechner ist, sind vor allem die „Random“-Lese- und Schreibraten von kleinen Datenblöcken ausschlaggebend. Das ist das, was auf einem Systemlaufwerk am häufigsten vorkommt. Und auch da ist eine NVMe gegenüber SATA, erst recht SATA II, ein Quantensprung!

Ich hab das mal gegenübergestellt, indem ich mein Bootdrive, eine 2TB Samsung 980 PRO Mit AmorphousDiskMark gegen eine SATA SSD, eine Samsung 860 EVO, ebenfalls 2TB, getestet habe. Hier die Werte. Besonders zu beachten sind die unteren vier Felder.

NVMe

NVMe.png

SATA
SATA.png

Man sieht also, speziell beim Schreiben reden wir etwa von Faktor 15!

Anzumerken ist, dass die NVMe bei mir auf einem sogenannten Switch Adapter sitzt. Das heißt, dass zumindest die sequentiellen Werte nicht, wie bei den einfachen Durchschleifadaptern, durch die 4 Lanes PCIe 2.0 limitiert sind, sondern im Prinzip der maximal mögliche Durchsatz der SSD selbst, bzw. die 4 Lanes PCIe 3.0 der Steckplätze auf dem Adapter die Grenze setzen. Das kommt in etwa auf’s Gleiche raus und ist ungefähr das Doppelte dessen, was mit den einfachen Adaptern geht. Ob das sich vom Faktor her so 1:1 auf die Random-Werte übertragen lässt, weiß ich nicht. Ich glaube an sich eher nicht. Eine technische Erklärung dafür würde mir dafür jedenfalls nicht einfallen.

Mein Fazit wäre aber auf jeden Fall, dass eine NVMe SSD auch als Systemlaufwerk einer SATA haushoch überlegen ist. Das deckt sich auch mit dem, was ich beim täglichen Arbeiten spüre. Hier würde ich sagen, dass die NVMe SSD, selbst als sie noch auf dem „normalen“ Adapter saß, das Upgrade war, das – vor allen CPUs und Grafikkarten – am meisten dafür gesorgt hat, dass sich der „uralte“ Mac Pro 5,1 selbst heute noch einigermaßen „modern“ anfühlt.
 
Zuletzt bearbeitet:
Ich kann von einwandfreiem Betrieb mit der Samsung 970 EVO Plus, der Samsung 980 Pro...
Naja, so ganz makellos läuft das bei mir nicht.

Die sattsam bekannten TRIM-Probleme treten mit der 980 PRO jedenfalls auch mit einem Switch-Adapter auf: Ich habe unter Monterey Bootzeiten von um die 5 Minuten. Mit deaktiviertem TRIM bootet der Rechner zwar schneller, legt dafür dann aber in der ersten 10 Minuten nach dem Start ein eher als erratisch zu bezeichnendes Laufverhalten mit teils minutenlangem Beachball bei den banalsten Sachen an den Tag. Da hab ich denn doch lieber die Bootzeiten genommen. Zumal mir das einigermaßen egal ist, da ich die Kiste, wenn überhaupt, normalerweise nur einmal am Tag neu starte. Ansonsten läuft die 980 aber absolut einwandfrei.

Vorteile sind „Zukunftssicherheit“ durch PCIe 4.0. Falls also irgendwann mal was moderneres an Rechner ins Haus kommt, hat sie rund 7GB/S Lesen/Schreiben. Und die Betriestemperaturen! Unter Dauerlast im Schnitt fast 10 Grad kühler als eine 970 EVO plus. Ein nicht ganz unerheblicher Punkt, bei zwei von den Teilen unter einem gemeinsamen Kühlkörper auf einer Adapterkarte, von der man den Lüfter demontiert hat. 😁
 
Bootzeiten von um die 5 Minuten
.. gab es bei mir nie - allenfalls 50 Sekunden bis Login -, wenngleich ja schon der OCLP-Vorlauf das Ganze ab Start etwas verzögert. Ich kann es jetzt nicht mehr stoppen, weil sie inzwischen beide im Hackintosh stecken.
Aber auch mich haben Bootzeiten nie sonderlich interessiert.
 
.. gab es bei mir nie - allenfalls 50 Sekunden bis Login -, wenngleich ja schon der OCLP-Vorlauf das Ganze ab Start etwas verzögert.
Merkwürdig! Ganz am Anfang war das mal kürzer. Und jetzt auch noch ab und zu mal, völlig „random“. Ich weiß nicht wieso. Vielleicht „verzichtet“ sie ja ab und an auf TRIM. Und, wenn das – bei aktiviertem TRIM – so ist, dann läuft der Rechner auch von Anfang an normal. Aber meistens sind es eben um die 5 Minuten. Das aber nun gottseidank schon seit einer ganzen Weile unverändert. Es gibt ja auch Berichte, nach denen das kontinuierlich immer mehr geworden ist.

War das bei dir auch unter Monte? Mit den 970ern unter HS nativ, also ohne OpenCore, hab ich von TRIM auch nie was gemerkt.
 
Zurück
Oben Unten