MAC 5.1 2023 was ist noch aus der Kiste rauszuholen?

Irgendwie ist das doch eine schöne ironische Wendung. Für mich besiegelt Monterey nun das Ende des Macs doch mit Windows 11 werde ich diesen schönen Computer bestimmt noch lange nutzen! Wenn es irgendwann garnicht mehr geht werde ich ihn ausschlachten und einen Hackintosh bauen. Das Gehäuse ist einfach so zeitlos schön…oder ich reiche es bei den Jungs von Vissmann als Gehäuseidee für Wärmepumpen ein 😂 als nächstes folgt das bluetooth wlan upgrade!
 
Trial and Error

until Success:
Bei dem Lied kann ich durchaus mitsingen. :)

Das schaut doch gut aus - gratuliere. (y)
Welchen Weg bist Du denn jetzt gegangen? Separate Partition oder eingebettet via Bootcamp? Bitte mehr Details, damit Andere es auch nachvollziehen können.
ausschlachten und einen Hackintosh bauen. Das Gehäuse ist einfach so zeitlos schön
Dafür habe ich hier auch schon einen PM G5 vorbereitet stehen, aber das Gehäuse eines MP3.1/5.1 ist wohl besser geeignet.
 
Jetzt solltest nach diesen Booten und Abwürgen schauen ob die Firmware noch ohne Zertifikat geblieben ist.
 
Welchen Weg bist Du denn jetzt gegangen?
Da würde ich gerne auf Mr. Sinatras Worte zurückgreifen und sagen: "I did it my way! " :D

Also im Prinzip ist es ganz easy man braucht einen Stick mit min 8gb Speicherplatz. Lädt sich die Software Rufus runter und baut damit einen bootfähigen Stick. Allerdings habe ich die Iso Datei mit Windows 11 direkt von der Windows Homepage bezogen und nicht mit Rufus gedownloadet.

Folgende Einstellungen habe ich in Rufus vorgenommen (Siehe Bild). Sobald Rufus mit der Stick Konfiguration durch ist wird es nicht nochmal gesondert angezeigt um den Prozess zu beenden drückt man einfach auf cancel und wirft den Stick aus.

Ich habe den Weg über ein eigene interne Sata SSD gewählt, dazu habe ich den Mac in OS Monterey hochgefahren und im Festplattendienstprogramm die SSD mit GUID und EXFAT formatiert.

Den Mac ausgechaltet, den Stick in einen der USB Ports gesetckt und mit gedrückter Alt Taste gebootet. Beim Bootpicker den Stick gewählt und die Windows Installation gestartet. Die Installation ist selbsterklärend bis zu dem Punkt, wo Windows nach dem Installationslaufwerk fragt, da muss man aufpassen denn man könnte sich die falsche Festplatte formatieren. Daher am Besten alle unnötigen Datenträger vorher entfernen. Bei mir war es jetzt nicht schwer, die richtige Platte zu erkennen, da sie sich in der Speicherkapazität von der NVME unterscheidet. Man wählt die Festplatte auf die Windows soll an und drückt auf "löschen" dann legt man sie über den Befehl "neu" an. Ab dann ist das Feld mit "weiter" nicht mehr ausgegraut und die Installation läuft von alleine. Hoffe mit diesen Infos könnte ich helfen! LG
 

Anhänge

  • Screenshot 2023-10-25 120028.png
    Screenshot 2023-10-25 120028.png
    49,2 KB · Aufrufe: 56
Den Mac ausgechaltet, den Stick in einen der USB Ports gesetckt und mit gedrückter Alt Taste gebootet. Beim Bootpicker den Stick gewählt und die Windows Installation gestartet

also nicht den Weg über OpenCore?

Nächste Aufgabe: Zertifikat entfernen durch Flashen eines Firmware Backups
 
"I did it my way!
In der Tat, wenngleich ich meine, dass ursprünglich Dein Plan ja darin bestand, nicht eine Sata-SSD, sondern eine NVMe-SSD für Win11 zu verwenden. Letzteres macht die Installationsgeschichte nämlich deutlich schwieriger. Nicht bei macOS Monterey-Installation o. A., denn das ist Standard. Tricky wird's bei WinOS.

Fast schade, denn ich hatte nach Deinen bisherigen Worten gehofft, Du hättest einen Weg gefunden ("Neue Köpfe - neue Ideen" ;) ), eine NVMe-SSD im MP5.1 mit Win10/11 zu bespielen.

Das soll Deinen Erfolg nicht schmälern, denn wichtig ist, dass Du es hinbekommen hast, ein Win11 zu installieren.

Windows im MP5.1 auf SSD hatte ich schon fast von Anfang an - nur eben in der sicheren MBR-Version, für die man keinen vorgeschalteten OCLP benötigt.
Da frage ich mich schon, was Dich bewogen hat, nach dem Wechsel weg von der NVMe-SSD zur Sata-SSD dennoch eine UEFI-Installation zu machen. Oder gibt es zwingende Gründe, dass eine sichere MBR-Installation für Deine Zwecke nicht ausreicht?

Da Deine Schilderung nicht eindeutig Aufklärung darüber gibt, ob du bei Beginn der Installation am Apple-Picker Windows oder EFI-Boot gewählt hast, solltest Du sehr zeitnah (nicht aufschieben) mit dem Rom-Backup-Test überprüfen, ob Du Dir ein MS-Zertifikat eingefangen hast. Wenn ja - entfernen.

Da muss aber jetzt keine Panik entstehen, wenngleich wir MP5.1 Anwender dieses Thema "Firmware & Zertifikate" immer im Blick haben sollten. Ich gehe ja davon aus, dass Du vor Beginn der Arbeiten einen Dump gemacht und den gut aufbewahrt hast.

Ich weiß, wovon ich rede, denn bei meinen Versuchen in den letzten Wochen in Sachen NVMe-SSD & WinOS habe ich mir mindestens 5 oder 6 Zertifikate eingefangen.
Nicht unmittelbar hintereinander (wer weiß, ob da nicht der Speicher geplatzt wäre :LOL:), denn nach jeder neuen Installationsaktivität mit einem Win-Stick habe ich einen Dump gemacht und geprüft: war ein Zertifikat vorhanden (sehr böse), habe ich es entfernt.

Auch da bin ich frei nach Frank Sinatra vorgegangen: kein FW-Flash, sondern mit dem bekannten Griff des PRAM-Reset ALT+CMD+P+R.
Sieht ulkig aus, wenn man da so vor der Tastatur hängt - ich setze den rechten, kleinen Finger auf P und den rechten Zeigefinger auf R, schalte mit der linken Hand ein und halte zustzlich zu P+R die beiden anderen Tasten mit linkem Mittel- & Zeigefinger gedrückt.

Anfänglich war es 4x MUH, dann habe ich es reduziert (mindert die verkrampfte Fingerhaltung ;) ) bis runter auf ein MUH.
Hat bisher immer geklappt. Wenn doch mal nicht, selbst nach 4 x Muh: die Sammlung der Dumps ist inzwischen auf ca. 18 - 20 angewachen, wobei min. 13 Zertifikat-freie Dumps vorhanden sind.

Viel Spaß mit der Käsereibe. :)
 
Manchmal klappt das, ein Zertifikat durch nvram Reset wieder loszuwerden, manchmal nicht.

Ein Muster ist schlecht zu erkennen. Da ich das Zertifikat durch Neuaufbau rausnehme und das Risiko selbst nicht eingehe dass die Garbage Collection hängt, habe ich das nicht näher erforscht.

Geht mal, geht mal nicht. Wenn das Zertifikat den Weg in den zweiten Stream schon gefunden hat geht's deutlich weniger oft.
 
Ohh Gott ich habe jetzt Panik!

Habe schnell eine video hochgeladen um zu zeigen wie es bei mir installiert ist: https://youtu.be/HHRsiVzxZdc

Was muss ich genau mit den Zertifikaten tun, damit mein Mac nicht kaputt geht? Rom backup habe ich zum Glück noch!
 
Ohh Gott ich habe jetzt Panik!

Habe schnell eine video hochgeladen um zu zeigen wie es bei mir installiert ist: https://youtu.be/HHRsiVzxZdc

Was muss ich genau mit den Zertifikaten tun, damit mein Mac nicht kaputt geht? Rom backup habe ich zum Glück noch!

Hier startest über OpenCore und hast somit den NVRAM Schutz. Aber wie war es bei den diversen Versuchen davor?

Dump ziehen, mein Dumper macht alles in einem Rutsch: Firmware aus dem Flash laden und anzeigen der Zertifikate und vieler anderer Problemen und abweichenden Prüfsummen.

Bootscreen scheinst auch keinen zu haben, damit hättest mehr Kontrolle wie gebootet wird wenn schon direkt ab Start wählen kannst welche ESP ausgeführt wird.
 
  • Gefällt mir
Reaktionen: dg2rbf
Ohh Gott ich habe jetzt Panik!
Jetzt lass Dich mal nicht verrückt machen. Mit Panik/Hektik ist Dir nicht geholfen.
Lass die Kiste aus
und komm erst mal zur Ruhe, damit Du die Vorgehensweise ganz entspannt planen kannst. Da passiert nix, was sich nicht regeln/beheben lässt.
Dein MP geht nicht kaputt - es sei denn, Du lässt Dich weiter so treiben und unüberlegt handeln.
 
  • Gefällt mir
Reaktionen: dg2rbf
Ich halte das für eine völlig überzogene Panikmache.
Ja, man kann seinen Mac damit unbrauchbar machen. Ja, man sollte eine Sicherungskopie von seinem Bootrom haben. Ja, man sollte da reinschauen, ob da was nicht mit stimmt. Ja, ich mache mich mit dieser Aussage unbeliebt.

Trotz aller Bemühungen habe ich es noch nicht geschafft, meiner Kiste einen MS-Eintrag zu verpassen und davor lief das Ding jahrelang trotz korrumpiertem Bootrom ohne Störungen.

Ich würde trotzdem nach Möglichkeit bevorzugt im MBR-Mode installieren (es ist dann auch als Startvolume aus macOS heraus setzbar), wenn es keinen wirklichen Anlass für eine UEFI-Installation gibt.
Bei fremden Macs sowieso, weil wenn aus irgendeinem Grund Windows versehentlich ohne OC gebootet wird und der Nutzer aus Unwissenheit das zur Gewohnheit macht, brickt die Kiste irgendwann.
 
  • Gefällt mir
Reaktionen: dg2rbf und LuckyOldMan
Wer macht hier Panik?

Man sollte danach schauen und das Zertifikat wieder rausbekommen, weil mit dem Zertifikat und weiteren Problemen in NVRAM die Garbage Collection durcheinanderkommen kann.

Durch einen tiefen NVRAM Reset hatten schon einige User Erfolg das Ding wieder loszuwerden. Manche aber nicht.

Ich habe eine kleine Sammlung von Firmwares von Boards wo ich einen Firmware Chip mit Zertifikaten ausgelötet hab wo der zweite NVRAM Stream "übergelaufen" ist und dadurch nicht mehr gestartet haben. Nach Reparatur liefen die wieder.
Dazu noch ein gutes Dutzend von fremden Roms die von den Usern oder Werkstätten ausgelötet wurden die ein ähnliches Fehlerbild zeigten.

Das Problem tritt häufig in Kombination mit weiteren Fehlern auf.

Wenn jemand nur UEFI Windows auf der Kiste gerannt hat und sonst nicht großartig mit Systemen experimentiert hat kann die Kiste jahrelang so laufen (mit Zertifikat). Man weiß es halt nicht weil die nicht-Problemfälle meistens unentdeckt sind.



Es gab eine alte Firmware MP51.0087.B00 die durch fehlende Microcodes direkt durch Windows gebrickt werden konnte, die ist aber lange Geschichte. Das ist aber noch in den Köpfen von manchen drin und dann kommen immer irgendwo Warnungen: UEFI Windows = Brick.


PS: Ich weiß dass sich inzwischen ein paar von Euch sich auf mich eingeschossen haben. Mit meinen Ton kommt nicht jeder zurecht, aber sei's drumm. Ich muss auch nicht mit jedem klar kommen...
 
  • Gefällt mir
Reaktionen: dg2rbf
Ich halte das für eine völlig überzogene Panikmache.
Ja, man kann seinen Mac damit unbrauchbar machen. Ja, man sollte eine Sicherungskopie von seinem Bootrom haben. Ja, man sollte da reinschauen, ob da was nicht mit stimmt. Ja, ich mache mich mit dieser Aussage unbeliebt.

Trotz aller Bemühungen habe ich es noch nicht geschafft, meiner Kiste einen MS-Eintrag zu verpassen und davor lief das Ding jahrelang trotz korrumpiertem Bootrom ohne Störungen.

Ich würde trotzdem nach Möglichkeit bevorzugt im MBR-Mode installieren (es ist dann auch als Startvolume aus macOS heraus setzbar), wenn es keinen wirklichen Anlass für eine UEFI-Installation gibt.
Bei fremden Macs sowieso, weil wenn aus irgendeinem Grund Windows versehentlich ohne OC gebootet wird und der Nutzer aus Unwissenheit das zur Gewohnheit macht, brickt die Kiste irgendwann.

Wieso meinst du, du würdest dich mit dieser Aussage unbeliebt machen?

Deine Aussage ist in jedem Punkt korrekt.
 
Moin Leute,

nach einer sehr unruhigen Nacht bin ich heute früh aufgestanden und habe den Pram Reset durchgeführt (4 Gongs).
Jetzt noch Macschraubers Romdumper gestartet hier der Screenshot. Ist da nun etwas korrumpiert oder nicht? Mich nervt ein wenig, dass die SSD auf der Windows liegt auf dem Desktop angezeigt wird kann man das irgendwie deaktivieren (die NVME soll aber noch weiter angezeigt werden)?
LG
Bildschirmfoto 2023-10-26 um 08.20.55.png
 
  • Gefällt mir
Reaktionen: LuckyOldMan
Ist da nun etwas korrumpiert
Kurzer Blick: ich sehe keinen MS-Zertifikatseintrag. Da ist Alles im grünen Bereich.

(zwei Tassen Kaffee später ....)

Hatte ich übrigns gestern vergessen zu erwähnen. ich sehe bei Deinem YT-Clip einen wunderbaren Apple-Bootpicker mit dem grauen macOS-Icon (plus OCLP) und dann hinter der OCLP-Schranke macOS & Windows in OCLP-Icon-Format.

Was die gelben/grauen Icons angeht: Derlei habe ich überhaupt nicht.

Desktop Monterey@MP5.1-01.png


Gelb ist meist eine Kennung für externe USB-Quellen - egal, ob NVMe-SSD, Sata-SSD. HDD. Was das graue Icon da soll, wüsste ich ad hoc auch nicht.
Schau mal im Finder/Einstellungen, ob Du da was in der Richtung angeklickt hast.
 
Zuletzt bearbeitet:
Moin Leute,

nach einer sehr unruhigen Nacht bin ich heute früh aufgestanden und habe den Pram Reset durchgeführt (4 Gongs).
Jetzt noch Macschraubers Romdumper gestartet hier der Screenshot. Ist da nun etwas korrumpiert oder nicht? Mich nervt ein wenig, dass die SSD auf der Windows liegt auf dem Desktop angezeigt wird kann man das irgendwie deaktivieren (die NVME soll aber noch weiter angezeigt werden)?
LG
Anhang anzeigen 411627

Sieht gut aus, der zweite Stream hat sich durch die forcierte Garbage Collection geleert. Was normal ist und immer passiert.

Das Anzeigen der Laufwerke kannst in den Finder Einstellungen bestimmen.
 
  • Gefällt mir
Reaktionen: dg2rbf
Guten Abend,
mein Mac funktioniert bislang sehr gut. Wie schon angekündigt habe habe ich heute ein WLan/Bluetooth upgrade durchgeführt.
Dafür habe ich folgende PCI Karte gekauft:

https://www.amazon.de/dp/B07W92MZGF?ref=ppx_yo2ov_dt_b_product_details&th=1

mleider kam die Karte mit einem 9 Pin Block, der nicht auf den Header vom Bluetooth Anschluss gepasst hat daher habe ich das gelbe gelbe und weisse Kabel einfach ausgepinnt sowie auch D+ und D- am kurzen Kabel was das BT Modul mit dem Logicboard verbunden hat und die Enden aneinender gelötet. Die restlichen Kabel habe ich mit Abisolierband versehen und im Chassis untergebracht. Ich habe dann die original Airport ausgebaut. Das Original Bluetoothmodul habe ich so gelassen ist ja ohne Funktion ohne den Stromanschluss.

Nach dem Booten habe ich OCLP gestartet auf 1.2.1 geupdatet den Core neu gebaut und die Rootpatches installiert. Leider funktioniert bislang nur die Bluetoothverbindung von Maus und Tastatur. Airdrop mit meinem Iphone iOS 17.1 funktioniert leider nicht. Das Iphone findet den Mac nicht.

Das WLan ist gänzlich außer Funktion. Kann mir ehrlichgesagt nicht erklären warum. Vielleicht sieht jemand von euch den Fehler...

Unter Windows 11 funktioniert die Karte (Bluetooth + Wlan; habe einfach die win 10 Treiber die dabei waren installiert) . Vielleicht weiss einer von ja Rat ansonsten geht die Karte zurück und ich kaufe mir eins von diesen überteuerten Aufrüstsets aus den USA. LG MCM
 

Anhänge

  • 1699648864618.png
    1699648864618.png
    339,7 KB · Aufrufe: 32
  • Bildschirmfoto 2023-11-10 um 21.30.42.png
    Bildschirmfoto 2023-11-10 um 21.30.42.png
    531,5 KB · Aufrufe: 33
  • 1699649477917.png
    1699649477917.png
    484,9 KB · Aufrufe: 35
  • Bildschirmfoto 2023-11-10 um 21.34.38.png
    Bildschirmfoto 2023-11-10 um 21.34.38.png
    485 KB · Aufrufe: 32
In meinem Dumper Paket sind Skripte drin um Wifi über die CLI Tools zu befüttern.

Manchmal funktioniert nur die GUI nicht, die Tools dahinter schon. Auch kann es nötig sein die Systemsettings neu auzubauen, oder die NVRAM Variablen der bekannten Netzwerke.

Für die Systemsettings hab ich ein Skript im Paket, fürs NVRAM macht man einen tiefen Reset über 3x in Folge ohne Unterbrechung mit cmd alt p r drei mal gongen lassen.

Versuch macht kluch.
 
  • Gefällt mir
Reaktionen: McMillan
Moin, vielen Dank schonmal für die Hilfe. Wenn ich im Verzeichnis wifi tools befinde starte ich das skript "select Wi-Fi from found Networks" es erscheint ein Auswahlfenster in dem ich mein Wlan sehe und auswählen kann. Danach erfolgt die Passworteingabe, im nächsten Schritt fragt er mich ob ich die preferred Netzwerke vom Keychain löschen möchte, da habe ich auf "nein" geclickt. Nach ca 3 minuten öffnet sich ein neues fenster mit "could not find network" returned. Mache ich etwas falsch?
 
Zurück
Oben Unten