Dateien lassen sich nicht löschen

Diskutiere das Thema Dateien lassen sich nicht löschen im Forum Mac OS Server, Serverdienste.

  1. schenni

    schenni Thread Starter Registriert

    Beiträge:
    1
    Zustimmungen:
    0
    Mitglied seit:
    19.06.2007
    Hallo,

    nachdem ich nun die Suchfunktion ausgiebig benutzt habe und nichts gefunden habe, stelle ich Euch nun die Frage ...

    Ich habe Daten über unser Bandarchiv auf unsere Raid gespeichert.
    Diese Daten konnten ohne Probleme genutzt werden, jedoch können diese nicht gelöscht werden.

    Es kommt jedes Mal eine der Fehlermeldung:
    "Der Vorgang konnte nicht abgeschlossen werden, da das Objekt "Raid 1250 GB OS X Server" in Verwendung ist."

    "Der Vorgang konnte nicht abgeschlossen werden, da Sie für einige Objekte nicht die notwendigen Zugriffsreche besitzen"

    Ich bin auf dem Mac als Administrator eingeloggt.

    Nun weiß ich nicht, wie man die Daten löschen kann.
    Ich bin schon ganz verzweifelt, weil es insg. 6 GB Müll sind, die sich nicht löschen lassen :o

    Vielleicht könnt ihr mir ja helfen :)
     
  2. blue-skies

    blue-skies Mitglied

    Beiträge:
    682
    Zustimmungen:
    10
    Mitglied seit:
    12.06.2003
    admin ist nicht alles; evtl. müssen für die entsprechenden Files/Ordner noch die Benutzerrechte umgebogen werden (chmod).
     
  3. Jessiblue

    Jessiblue Mitglied

    Beiträge:
    970
    Zustimmungen:
    10
    Mitglied seit:
    12.04.2005
    Servus,
    sorry wenn ich mich jetzt an den Threat hänge, aber ich habe selbes Problem, allerdings funktioniert bei mir wohl das ändern der Rechte nicht! (ich bin als user angemeldet auf meinem mac und versuche dateien zu löschen!) Laut der Info ist der user Eigentümer! aber ich kann die files nicht löschen! Woran liegt das denn? (in der Ansicht ist auch so n Vorhängeschloss an den dateien!)

    erst mal grüsse Jessi
     
  4. tridion

    tridion Mitglied

    Beiträge:
    7.283
    Zustimmungen:
    242
    Mitglied seit:
    21.06.2003
    @ Jessi

    ich weiß ja nicht, welche Dateien du nicht löschen kannst. Aber es kann, auch innerhalb von Programmen, Dateien geben, die "geschützt" sind. Um den Schutz aufzuheben, klickst du die Dateien mit Apfel-i an und hebst den Schutz auf. (Dazu müssen die Dateien außerhalb des Papierkorbs liegen.)

    Ich hatte auch mal einen Fall, wo sich Dateien eines Programms nicht löschen ließen, weil das zugehörige Programm schon gelöscht war. In dem Fall half nur, dieses Programm nochmal zu installieren und dann per AppZapper oder uApp (Tools, die ein Programm samt aller zugehörigen Dateien löschen) zu eliminieren.

    Gruß tridion
     
  5. highbuilder

    highbuilder Mitglied

    Beiträge:
    413
    Zustimmungen:
    5
    Mitglied seit:
    04.02.2005
    dieses problem habe ich auch, all meine handyfotos sind so, gibt es eine möglichkeit, diesen schutz gleich bei allen dateien auf einmal aufzuheben?
     
  6. CHRISCHAN86

    CHRISCHAN86 Mitglied

    Beiträge:
    44
    Zustimmungen:
    0
    Mitglied seit:
    08.03.2007
    ja gibt es:

    Ich hänge mich auch dran, an den Thread. Bei mir ist das Problem, dass der Ordner den ich löschen will scheinbar in Verwendung sein soll. Ist er aber nicht.

    [​IMG]

    gibts da auch einen Terminal Befehl, der den Ordner aus seiner pseudo verwendung befreit?
     
  7. AloeVera

    AloeVera Mitglied

    Beiträge:
    1.720
    Zustimmungen:
    196
    Mitglied seit:
    02.04.2008
    Versuch doch mal, eben diesen Prozess in der Aktivitätsanzeige zu finden, dort dann "Prozess beenden", danach müsste löschen der Datei funktionieren, hier hat es gestern mit dieser Lösung zumindest gut funktioniert.
     
  8. Umac_de

    Umac_de Mitglied

    Beiträge:
    469
    Zustimmungen:
    28
    Mitglied seit:
    04.11.2006
  9. spikey2

    spikey2 Mitglied

    Beiträge:
    22
    Zustimmungen:
    0
    Mitglied seit:
    17.11.2005
    hallo!

    also ich habe Mac OS X 10.4.11 (Tiger), und Whats Open ist erst ab 10.5 (Leopard)!

    Die Anleitung für das Terminal hat bei mir zumindest für Ordner NICHT funktioniert.

    Folgendes aber schon:

    Vor das ganze nur noch "sudo " setzen.
    Also:

    sudo chflags -R nouchg (mit Leerzeichen dahinter!)

    und dann wie gehabt, den Ordner rüberziehen. Enter
    Dann muss man nur noch sein Benutzer-Passwort eingeben, ENTER, fertig :)

    hier der Link zur betreffenden Apple-Seite:

    http://support.apple.com/kb/TS1402?viewlocale=de_DE


    LG Spikey
     
  10. Opa_Bommel

    Opa_Bommel Mitglied

    Beiträge:
    640
    Zustimmungen:
    48
    Mitglied seit:
    13.03.2005
    Ich versuche die Datei „Install macOS High Sierra“ von meinem MacBook mit 10.14.4 (FileVault aktiv) zu löschen, leider erfolglos. Wenn ich die Datei in den Papierkorb verschiebe (Passwort muss eingegeben werden) und löschen möchte, dann bekomme ich die Meldung:

    „ Der Vorgang konnte nicht abgeschlossen werden, da das Objekt „Install macOS High Sierra“ in Verwendung ist.

    Lösungsansätze:

    - Neustart
    - Sicherer Neustart
    - Rechte aus der MacOS-Wiederherstellung repariert
    - Löschen über die Terminal mit den Befehl rm -R und anschließender Bestätigung wird gekontert mit „Operation not permittet“
    - sudo rm -R und anschließender Passworteingabe wird gekontert mit „Directory not empty“
    - sudo chflags -R nouchg und anschließender Passworteingabe ändert nichts an meinem Problem

    Hat jemand von euch eine Idee wie ich diesen rund 4,7 gb große Datei löschen kann?
     
  11. KOJOTE

    KOJOTE Mitglied

    Beiträge:
    5.579
    Medien:
    1
    Zustimmungen:
    1.159
    Mitglied seit:
    06.11.2004
    Etwas Vorsicht ist geboten, bei derartigen Befehlen, nicht dass zum Schluss gar nix mehr geht.
    Wenn du als Admin angemeldet bist, dann:

    Einzelne Inhalte des Papierkorbs löschen:

    1. Terminal aufrufen und nachfolgenden Code incl. Leerzeichen am Ende eingeben
    2. Code:
      rm -ri 
    3. Die zu löschende Datei dahinter in das Terminal-Fenster ziehen
    4. Enter/Return
    5. Bestätigen des Löschvorgangs mit y (y steht für yes)
    6. Enter/Return
    Bitte den Befehl kopieren, bzw. beim Abschreiben beachten, dass nach dem ...i ein Leerzeichen folgt.
     
  12. Opa_Bommel

    Opa_Bommel Mitglied

    Beiträge:
    640
    Zustimmungen:
    48
    Mitglied seit:
    13.03.2005
    Hi Kojote,
    danke für deine Hilfe. Leider hat auch der Befehl rm -ri nicht geholfen. (Ich hatte die gleiche Vorgehensweise (drag & drop) mit den Pfaden ins Terminal bei meinen vorhergehenden Versuchen probiert.)
    Als Ergebnis bekomme ich: (*** = zensiert)

    examine files in directory /Users/***/Desktop/Install macOS High Sierra.app? y
    examine files in directory /Users/***/Desktop/Install macOS High Sierra.app/Contents? y
    examine files in directory /Users/***/Desktop/Install macOS High Sierra.app/Contents/SharedSupport? y
    remove /Users/***/Desktop/Install macOS High Sierra.app/Contents/SharedSupport/InstallESD.dmg? y
    rm: /Users/***/Desktop/Install macOS High Sierra.app/Contents/SharedSupport/InstallESD.dmg: Operation not permitted
    remove /Users/***/Desktop/Install macOS High Sierra.app/Contents/SharedSupport? y
    rm: /Users/***/Desktop/Install macOS High Sierra.app/Contents/SharedSupport: Permission denied
    remove /Users/***/Desktop/Install macOS High Sierra.app/Contents? y
    rm: /Users/***/Desktop/Install macOS High Sierra.app/Contents: Permission denied
    remove /Users/***/Desktop/Install macOS High Sierra.app? y
    rm: /Users/***/Desktop/Install macOS High Sierra.app: Directory not empty

    Gibt es noch alternative Ideen?
     
  13. KOJOTE

    KOJOTE Mitglied

    Beiträge:
    5.579
    Medien:
    1
    Zustimmungen:
    1.159
    Mitglied seit:
    06.11.2004
    Du bist in diesem Benutzer-Account kein Admin, oder?
    Die Install.dmg liegt aktuell auf deinem Schreibtisch und der Papierkorb ist sonst bereits geleert, richtig?
     
  14. Opa_Bommel

    Opa_Bommel Mitglied

    Beiträge:
    640
    Zustimmungen:
    48
    Mitglied seit:
    13.03.2005
    Hi,
    ich bin als Admin angemeldet. Auch mit dem Zusatz sudo komme ich im Terminal nicht weiter.
    Die Datei liegt auf dem Schreibtisch und der Papierkorb ist leer.
     
  15. KOJOTE

    KOJOTE Mitglied

    Beiträge:
    5.579
    Medien:
    1
    Zustimmungen:
    1.159
    Mitglied seit:
    06.11.2004
    Schalte vorher mal die SIP aus:

    Code:
    sudo spctl --master-disable
    Neustart im Anschluss nicht vergessen.
     
Die Seite wird geladen...
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite weitersurfst, akzeptierst du unseren Einsatz von Cookies. Akzeptieren Weitere Informationen...