HILFE >> Volume verschwunden, Mountpoint nich aktiviert

Dieses Thema im Forum "Mac Pro, Power Mac, Cube" wurde erstellt von tim_toxxic, 10.12.2004.

  1. tim_toxxic

    tim_toxxic Thread Starter MacUser Mitglied

    Beiträge:
    109
    Zustimmungen:
    0
    MacUser seit:
    30.01.2004
    ich war am arbeiten als sich Photoshop aufgehängt hat und ausser dem Mauszeiger ging nichts mehr. Kam so ziemlich zum erstenmal vor. Dann hab ich halt ausgeschaltet und wieder eingeschaltet >> und shit, eine 80gb-platte die ich seit ca. 2monaten drin hab ist nicht mehr da.

    Im Festplatten-Dienstprogramm und im System-Profiler wird die Platte angezeigt, aktivieren kann ich sie nicht! (siehe screenshots)

    HILFE! die ist doch hoffentlich nicht abgekrazt!!???!!!
     

    Anhänge:

  2. abgemeldeter Benutzer

    abgemeldeter Benutzer Gast

  3. Lucky_Darts

    Lucky_Darts MacUser Mitglied

    Beiträge:
    412
    Zustimmungen:
    0
    MacUser seit:
    28.01.2004
    das problem kenn ich - bei mir hat die verwendung von diskwarrior geholfen, mit dem festplattendienstprogramm war leider nix zu erreichen
     
  4. tim_toxxic

    tim_toxxic Thread Starter MacUser Mitglied

    Beiträge:
    109
    Zustimmungen:
    0
    MacUser seit:
    30.01.2004
    danke für eure hilfe, aber es hat leider nicht funktioniert.

    diskwarrior hängt sich auf.

    folgendes hab ich im terminal versucht:
    - sudo mkdir /Volumes/Media
    - sudo mount -t hfs /dev/disk0s3 /Volumes/Media/
    hat nichts gebracht, bzw. es kam irgendwie was mit "invalid...", nach neustart war nix da

    dann noch:

    diskutil repairDisk disk0s3
    Started verify/repair on disk disk0s3 Media
    Checking HFS Plus volume.
    Checking Extents Overflow file.
    Checking Catalog file.
    Checking Catalog hierarchy.
    Checking volume bitmap.
    Checking volume information.
    The volume Media appears to be OK.
    Verify/repair finished on disk disk0s3 Media

    aber ich nehme an, das ist dasselbe wie im Festplatten-Dienstprog.

    dann noch
    - sudo diskutil mount disk0s3
    - Volume disk0s3 mounted
    nach neustart war nix da


    oh je, was mach ich nur? die daten sind doch hoffentlich nicht weg, oder?
     
  5. abgemeldeter Benutzer

    abgemeldeter Benutzer Gast

    Versuch es mal mount mit -r für readonly. Allerdings wird, wenn Du den Befehl "mount" nimmst, das Volume zwar für das BSD-Subsystem gemountet, die GUI-Programme, wie der Finder wissen nichts davon. In der Shell dürftest Du so aber Zugriff auf Deine Daten haben.

    Unter Mac OS X nimmt man "diskutil" zum mounten (bzw. macht der diskarbitrationd das von selbst). Wenn das Volume dann nicht erscheint, sie noch mal in der Konsole nach, ob es da eine Meldung gibt. (Vermutlich "Error replaying the journal!").

    Wenn Du allerdings einen Mac hast, der ein System vor Mac OS X 10.2.3 starten kann, brauchst Du das Volume nur einmal dort zu mounten. Dann wird das Journal obsolet und macht keinen Fehler mehr (davon auszugehen, dass das Journal das Problem ist, siehe Konsole).
     
  6. tim_toxxic

    tim_toxxic Thread Starter MacUser Mitglied

    Beiträge:
    109
    Zustimmungen:
    0
    MacUser seit:
    30.01.2004
    wo muss ich -r hinschreiben?

    "Error replaying the journal!" kam bei mir nicht, sondern

    diskutil mount disk0s3
    Volume disk0s3 mounted

    dann sollte ja eigentlich alles in Ordnung sein....!?!
    wenn ich via shell nachsehe, ob was da ist, finde ich nix (bei /Volumes/)

    nützt dir das vielleicht was:

    diskutil info disk0s3
    Device Node: /dev/disk0s3
    Device Identifier: disk0s3
    Mount Point:
    Volume Name: Media

    File System: Journaled HFS+
    Permissions: Disabled
    Partition Type: Apple_HFS
    Bootable: Is bootable
    Media Type: Generic
    Protocol: ATA

    Total Size: 76.2 GB
    Free Space: 0.0 B
     
  7. abgemeldeter Benutzer

    abgemeldeter Benutzer Gast

    Ich meinte die Meldung in der Konsole (nicht im Terminal) im system.log. Müsste ungefähr aussehen, wie hier: [DLMURL]http://www.macuser.de/forum/showpost.php?p=497519&postcount=5[/DLMURL]

    -r kommt hinter mount:
    sudo mount -r -t hfs /dev/disk0s3 /Volumes/Media/
     
  8. tim_toxxic

    tim_toxxic Thread Starter MacUser Mitglied

    Beiträge:
    109
    Zustimmungen:
    0
    MacUser seit:
    30.01.2004
    DU BIST MEIN HELD!!!
    das mit readonly funktioniert! in demfall ist noch alles da..!!! buaa......
    im terminal und ftp wirds angezeigt!
    das krieg ich hoffentlich noch in den normalzustand zurück, oder?

    hier der auszug aus der konsole:

    Dec 11 03:15:02 M-A-C syslogd: restart
    Dec 11 03:15:02 M-A-C syslogd: hostname changed, "localhost" to "M-A-C"
    Dec 11 03:17:20 M-A-C sudo: andy : TTY=ttyp1 ; PWD=/Users/andy ; USER=root ; COMMAND=/sbin/mount -r hfs /dev/disk0s3 /Volumes/Media/
    Dec 11 03:17:32 M-A-C sudo: andy : TTY=ttyp1 ; PWD=/Users/andy ; USER=root ; COMMAND=/bin/mkdir /Volumes/Media/
    Dec 11 03:17:35 M-A-C sudo: andy : TTY=ttyp1 ; PWD=/Users/andy ; USER=root ; COMMAND=/sbin/mount -r hfs /dev/disk0s3 /Volumes/Media/
    Dec 11 03:19:01 M-A-C sudo: andy : TTY=ttyp1 ; PWD=/Volumes ; USER=root ; COMMAND=/sbin/mount -r -t hfs /dev/disk0s3 /Volumes/Media/
    Dec 11 03:19:02 M-A-C kernel: jnl: replay_journal: from: 1940992 to: 2515968 (joffset 0x264000)
    Dec 11 03:19:02 M-A-C kernel: jnl: replay_journal: bad block list header @ 0x264400 (checksum 0x0 != 0xffffffff)
    Dec 11 03:19:02 M-A-C kernel: jnl: journal_open: Error replaying the journal!
    Dec 11 03:19:02 M-A-C kernel: hfs: early jnl init: failed to open/create the journal (retval 0).
    Dec 11 03:19:15 M-A-C sudo: andy : TTY=ttyp1 ; PWD=/Volumes ; USER=root ; COMMAND=/sbin/mount -r -t hfs /dev/disk0s3 /Volumes/Media/
    Dec 11 03:19:15 M-A-C kernel: jnl: journal start/end pointers reset! (jnl 0x23a8b4c; s 0x1d9e00 e 0x266400)
     
  9. abgemeldeter Benutzer

    abgemeldeter Benutzer Gast

    Du könnstest es mal mit "/System/Library/Filesystems/hfs.fs/hfs.util -U /Volumes/Media" versuchen. Allerdings habe ich das noch nicht ausprobiert.
     
  10. tim_toxxic

    tim_toxxic Thread Starter MacUser Mitglied

    Beiträge:
    109
    Zustimmungen:
    0
    MacUser seit:
    30.01.2004
    M-A-C:~ andy$ /System/Library/Filesystems/hfs.fs/hfs.util -U /Volumes/Media
    Failed to make volume /Volumes/Media UN-journaled (Operation not permitted)
    M-A-C:~ andy$ sudo /System/Library/Filesystems/hfs.fs/hfs.util -U /Volumes/Media
    Password:
    Failed to remove the journal /Volumes/Media/.journal (Read-only file system)
    Failed to remove the journal info block /Volumes/Media/.journal_info_block (Read-only file system)
    Journaling disabled on /Volumes/Media
     
Die Seite wird geladen...
Ähnliche Themen - HILFE Volume verschwunden
  1. NotoII
    Antworten:
    72
    Aufrufe:
    2.092
    Paul1983
    26.11.2016
  2. andonia
    Antworten:
    2
    Aufrufe:
    114
    andonia
    14.10.2016
  3. Mabylina
    Antworten:
    11
    Aufrufe:
    510
    rembremerdinger
    03.03.2016
  4. FrizonYT
    Antworten:
    2
    Aufrufe:
    204
    FrizonYT
    11.02.2016
  5. mackata
    Antworten:
    3
    Aufrufe:
    294
    mackata
    10.01.2016