VMware Fusion 11 Mojave "Could Not Open /dev/vmmon: Broken Pipe"

tubo

Mitglied
Mitglied seit
10.11.2004
Beiträge
295
@vanyedoom
Neu installieren? Wie ich schrieb, trat das Problem gerade durch eine Neu-Installation – über das bestehende System – auf.
Du müsstest zur Vermeidung also schon den Datenträger löschen, dann darauf neu installieren, aus dem Backup den Zustand von vorher wiederherstellen.
Ich würde auch zunächst die 12er Version ausprobieren – ohne Löschorgie.
Allerdings::: Du musst dafür Mojave aufgeben und erst auf wenigstens 10.15 (Catalina) aktualisieren.
 

vanyedoom

Neues Mitglied
Thread Starter
Mitglied seit
18.01.2019
Beiträge
48
Ich habe gerade Mojave 10.14.6 über die Recovery-Funktion neu aufgespielt, ohne Programmen und Daten zu verlieren. Das hat ewig gedauert, aber problemlos funktioniert.

Die aktuelle VMware Fusion 11.5.7 funktioniert.

Er muss jetzt noch folgendes Nachinstallieren:
Bildschirmfoto 2020-11-21 um 11.21.48.png


Jetzt traue ich mich aber nicht, die Updates einzuspielen...

Ich benötige leider noch Mojave, da ich einige 32bit-Anwendungen benötige und dafür noch keinen Ersatz habe.
 

vanyedoom

Neues Mitglied
Thread Starter
Mitglied seit
18.01.2019
Beiträge
48
Benötigt VMware in Sicherheit/Datenschutz Festplattenvollzugriff? Unter Bedienungshilfen ist es eingetragen und hat einen Haken?
 

vanyedoom

Neues Mitglied
Thread Starter
Mitglied seit
18.01.2019
Beiträge
48
Sobald die Updates eingespielt wurden, funktioniert VMware Fusion nicht mehr!
 

vanyedoom

Neues Mitglied
Thread Starter
Mitglied seit
18.01.2019
Beiträge
48
Guten Morgen.

Erstmal ein großes Dankeschön in die helfende Runde.
Am Wochenende hatte ich Zeit, mich etwas genauer mit der Problematik zu beschäftigen. Wetter war ja nicht so toll ;)

Ergebnis:
Definitiv geholfen hat eine komplette Neuinstallation. Im Recovery-Modus SSD formatieren und neu einrichten und anschließend Mojave neu aufspielen. Danach hat er noch Updates nachinstalliert. Anschließend habe ich nur die Daten übernommen und alle Programme neu eingerichtet.

Sobald ich auch die Programme von der defekten Installation migrierte, trat der Fehler wieder auf.

Zusammenfassung:
Problemlösung: System komplett neu aufsetzten.
 

AlexausMuc

Neues Mitglied
Mitglied seit
16.01.2021
Beiträge
6
Ich kämpfe auch mit dem Problem (bis 10.13. lief alles, ab 10.14 eben nicht mehr) und denke, das es daran liegt (zumindest bei mir):
Das System ist auf einer externen Platte, darauf ist ein Container mit Mojave, aber keine Recovery). Auf der Platte sind aus alten Zeiten noch einige weiteren Partitionen. Ist halt so.
Ohne die Recovery kann die "Kextfreigabe" nicht gespeichert werden :-( SIP abschalten hilft zwar, aber das ist ja keine Lösung sondern lediglich eine Krücke.
Leider ist es mir bis jetzt nicht gelungen, auf eben dieser externen SSD eine Recovery anzulegen.

Ein Versuch mit einem System auf einer internen SSD machte dagegen keine Probleme. Kann ich aber nicht nutzen, weil ich mit dem Externen System immer wieder an "fremden" Rechnern arbeiten muß und die dann eben von meiner SSD starte. Und diese SSD mit all ihren Partitionen in Container umzuwandeln, das mag ich auch nicht. Schade Apple, Sicherheit ist zwar schön und gut, aber den Usern solche Steine mit Updates in den Weg zu werden, ist gar nicht nett.
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
56.472
Ich kämpfe auch mit dem Problem (bis 10.13. lief alles, ab 10.14 eben nicht mehr) und denke, das es daran liegt (zumindest bei mir):
Das System ist auf einer externen Platte, darauf ist ein Container mit Mojave, aber keine Recovery). Auf der Platte sind aus alten Zeiten noch einige weiteren Partitionen. Ist halt so.
Ohne die Recovery kann die "Kextfreigabe" nicht gespeichert werden :-( SIP abschalten hilft zwar, aber das ist ja keine Lösung sondern lediglich eine Krücke.
Leider ist es mir bis jetzt nicht gelungen, auf eben dieser externen SSD eine Recovery anzulegen.
Die Recovery ist doch bei APFS mit im Container.
Das mit dem
/usr/sbin/spctl kext-consent add EG7KH642X6
klappt auch nicht?
 

AlexausMuc

Neues Mitglied
Mitglied seit
16.01.2021
Beiträge
6
Hallo oneOeight,
es ist nur der Container mit dem System drauf mit AFPS formatiert. Ich denke, die Recovery hat dann entweder einen eigen Container oder liegt in dem Container von System so die vorhanden ist. Die anderen Partitionen liegen „neben“ dem Systemconainer.
Alle Vorschläge hier haben leider nicht geholfen. Daher meine Vermutung, das eine Recovery vorhanden sein muß und es ohne bei Mojave nicht geht.
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
56.472
Hallo oneOeight,
es ist nur der Container mit dem System drauf mit AFPS formatiert. Ich denke, die Recovery hat dann entweder einen eigen Container oder liegt in dem Container von System so die vorhanden ist. Die anderen Partitionen liegen „neben“ dem Systemconainer.
Man kann bestimmt den Mojave Installer dazu überreden die Recovery in den APFS Container zu packen.
diskutil list
zeigt den nicht?
 

Macschrauber

Aktives Mitglied
Mitglied seit
08.02.2014
Beiträge
7.436
Vielleicht fehlen ein paar Grundsätze.

Recovery wird nicht mehr vom Boot Picker angezeigt.

Mit cmd r ist sie aufzurufen beim Start

Oder

sudo nvram "recovery-boot-mode=unused" && sudo reboot recovery


Am nvram kann ich auch mit einem gebooteten usb Installer Änderungen vornehmen.
 

AlexausMuc

Neues Mitglied
Mitglied seit
16.01.2021
Beiträge
6
@Macschrauber,
die externe Platte hat keine Recovery. Hier die Ausgabe von diskutil List:

Zur Erklärung:
- disk1 ist so wie ich das interpretiere, auf disk0
- disk2 ist meine externe SSD (und da ist keine Recovery zu sehen (außer disk4 ist der Inhalt vom APFS Container auf disk2), Apfel+R bootet aber in die Recovery von disk 1

bie nächster Gelegenheit werde ich schmal mit alt starten. Dann kann ich entweder die "richtige" externe Recovery auswählen und davon starten. Oder auch nicht (laut Macschrauber). Aber vielleicht wird nur die interne unterdrückt und die externe ist doch sichtbar...
Der iMac hier ist ein 21,5" late2013 falls das wichtig ist.

Code:
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *250.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         249.8 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +249.8 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume SSD intern              64.5 GB    disk1s1
   2:                APFS Volume Preboot                 45.9 MB    disk1s2
   3:                APFS Volume Recovery                510.5 MB   disk1s3
   4:                APFS Volume VM                      2.1 GB     disk1s4

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                 Apple_APFS Container disk4         120.7 GB   disk2s2
   3:                  Apple_HFS Datenplatte             250.0 GB   disk2s3
   4:                  Apple_HFS No Name City            550.0 GB   disk2s4
   5:                  Apple_HFS Terra incognita         20.0 GB    disk2s5
   6:                  Apple_HFS Tempix                  30.0 GB    disk2s6
   7:                  Apple_HFS xxx                     28.5 GB    disk2s7

/dev/disk3 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *2.0 TB     disk3
   1:                        EFI EFI                     209.7 MB   disk3s1
   2:                  Apple_HFS Backup                  2.0 TB     disk3s2

/dev/disk4 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +120.7 GB   disk4
                                 Physical Store disk2s2
   1:                APFS Volume Mojave                  87.7 GB    disk4s1
   2:                APFS Volume Preboot                 43.0 MB    disk4s2
   3:                APFS Volume Recovery                510.5 MB   disk4s3
   4:                APFS Volume VM                      4.3 GB     disk4s4
 

Macschrauber

Aktives Mitglied
Mitglied seit
08.02.2014
Beiträge
7.436
Ich sehe aber 2 Recoveries in den Containern.

Mit alt (BootPicker) siehst Du keine Recoveries die in Containern stecken.
 

AlexausMuc

Neues Mitglied
Mitglied seit
16.01.2021
Beiträge
6
Keine Ahnung was ich sehen werde wenn ich das nächste Mal mit alt boote. Muß ich mir dann aufschreiben oder nen Foto machen was da alles erscheint oder nicht.
Wenn ich dich richtig verstehe, werde ich beim Start mit Cmd & r in der Recovery der internen SSD landen. Nur wenn ich von der internen SSD starte, brauch ich den ganzen Zinnober nicht, da startet VM-Ware ja problemlos. Kann man die Recovery der internen SSD auf die externe klonen ohne das Mojave dann meckert? Oder wie kann ich die Kextfreigabe auf der externen Platte festschreiben?
 

Macschrauber

Aktives Mitglied
Mitglied seit
08.02.2014
Beiträge
7.436
Normal lädt er die zugehörige Recovery vom geBlessten System mit cmd r

Also wenn die Externe das Systemlaufwerk ist die Recovery im gleichen Container.
 

AlexausMuc

Neues Mitglied
Mitglied seit
16.01.2021
Beiträge
6
Hmm, nur leider klappt es bei mir mit keinem der Terminalbefehle, VM-Ware wieder zum Leben zu erwecken. Daher meine Vermutung, das es bei mir mit dem "speziellen Mix aus Partitionen und Containern auf meiner externen SSD zusammenhängt. die extra auf der internen SSD durchgeführte Testinstallation hat ja gezeigt, das es dort geht. Nur kann ich mangels Alternativer Reserveplatte / SSD meine externen Partitionen nicht "mal eben" auf eine reine "Containerlösung umstellen und das dann dort zumindest testen.
Der Staus quo ist derzeit unbefriedigend. Hatte aber den Thread hier gefunden und wollte meine Erfahrung mit dem selben Problem kund tuen. Neuinstallation auf frische Platte hilft, eine "echte" Lösung schein es aber (noch) nicht zu geben. Die gemachten Vorschläge helfen in bestimmten Fällen, in meinem (speziellen) leider nicht :-(
 

AlexausMuc

Neues Mitglied
Mitglied seit
16.01.2021
Beiträge
6
Sooo, da sich das Problem nicht freiwillig verabschiedet hat, hab ich heute mal weiter gebohrt und Heureka, nach etlichen anderen Fehlermeldungen beim Versuch, die jetzt zur Mitarbeit zu bewegen bin ich hier https://communities.vmware.com/t5/VMware-Fusion-Discussions/VM-s-not-working-in-Fusion/td-p/2289028 im 11.Post von jameslodberg auf die Lösung gestoßen.
Um es kurz zu machen: "Einfach" in die Recovery starten, im Terminal dann
Code:
chflags restricted '/Volumes/NameDerSystemplatte/private/var/db/KernelExtensionManagement'
eingeben und den Rechner neu starten. Das hat nun sogar auf meiner externen Platte geklappt.
Demzufolge ist meine oben gemachte Vermutung falsch, die Lösung ist allerdings viel einfacher so man sie den endlich gefunden hat :)
 

tubo

Mitglied
Mitglied seit
10.11.2004
Beiträge
295
Wow @AlexausMuc
Code:
chflags restricted '/Volumes/NameDerSystemplatte/private/var/db/KernelExtensionManagement'
(mit Tab-Vervollständigung sogar einigermaßen stressfrei im Recovery einzugeben)
Löste das Problem sofort, danke!!
 
Oben