SMB Zugriff auf NAS

lisanet

Aktives Mitglied
Registriert
05.12.2006
Beiträge
4.994
Kannst Du da mal teilen welche Parameter Du da genau änderst/setzt? Würde mich interessieren.


Hier der Link zu einer Anleitung, wie ich auf dem QNAP den SMB-Server aufgesetzt habe.

https://lisanet.de/qnap-smb-macos-und-das-problem-mit-rwx-rechten/

Wenn ihr die dort verlinkten "Goodies" runter ladet könnt ihr aus der Datei smb.conf aus der [global]-Section die Parameter entnehmen. Die könnt ihr dann so auf euren Server oder NAS übernehmen bzw. damit vergleichen.

Bei den shares ist nichts wesentlich anderes als die üblichen Standardparameter zu beachten.
 

lisanet

Aktives Mitglied
Registriert
05.12.2006
Beiträge
4.994

bei der Lösung muss man aber auch dann dran denken, dass man, sollte man einen aktuellen SMB-Server mal nuzten wollen, den Mac auf SMB festgenagelt hat und somit das eigentlich zu bevorzugende SMB3 nicht nutzen kann.

Erfahrungsgemäß vergessen das gerade die User, die wenig von der Konfiguration verstehen. Die wundern sich dann, warum Jahre später mit einem NAS irgendwelche Probleme oder Unzulänglichkeiten auftreten.
 

wegus

Moderator
Registriert
13.09.2004
Beiträge
17.919
Hier der Link zu einer Anleitung, wie ich auf dem QNAP den SMB-Server aufgesetzt habe.

https://lisanet.de/qnap-smb-macos-und-das-problem-mit-rwx-rechten/

Wenn ihr die dort verlinkten "Goodies" runter ladet könnt ihr aus der Datei smb.conf aus der [global]-Section die Parameter entnehmen. Die könnt ihr dann so auf euren Server oder NAS übernehmen bzw. damit vergleichen.

Bei den shares ist nichts wesentlich anderes als die üblichen Standardparameter zu beachten.
Ah ok, das ist ein QNAP spezifisches Problem.
 

lisanet

Aktives Mitglied
Registriert
05.12.2006
Beiträge
4.994
Ah ok, das ist ein QNAP spezifisches Problem.

Das Thema mit den Rechten tritt bei QNAP auf und bei allen SMB-Servern die ebenso auf Windows hin konfiguriert wurden. Wie Synology das tut weiß ich nicht, kannst du aber einfach testen, indem du eine Textdatei normal auf dem Mac erstellst und aufs NAS kopierst. Anschließend holst du die wieder vom NAS runter und vergleichst die Rechte: wenn die dann -rwx------ sind (was ich fast annehme) dann ist Synology ebenso Windows-zentriert wie QNAP.

Die Konfiguration eines SMB-Servers ist aber vom Rechte-Thema unabhängig. Und die Parameter könnt ihr aus der beigefügten smb.conf entnehmen und mit eurer Konfig vergleichen.
 

wegus

Moderator
Registriert
13.09.2004
Beiträge
17.919
NAS runter und vergleichst die Rechte: wenn die dann -rwx------ sind (was ich fast annehme) dann ist Synology ebenso Windows-zentriert wie QNAP.
Dafür gibt es ja die diversen force-parameter und die create mask. Wenn die Datei wirklich nur einem User und keiner Gruppe zugehören soll und wenn sie im Ursprung executable war, sehe ich da aber erst einmal keinen Fehler.
 

lisanet

Aktives Mitglied
Registriert
05.12.2006
Beiträge
4.994
Dafür gibt es ja die diversen force-parameter und die create mask. Wenn die Datei wirklich nur einem User und keiner Gruppe zugehören soll und wenn sie im Ursprung executable war, sehe ich da aber erst einmal keinen Fehler.

Nee, eine Textdatei hat unter macOS standardmäßig die Rechte -rw-r--r--. So sind sie auf dem Mac. Wenn du die dann aufs NAS kopierst und wieder vom NAS zurück auf den Mac holst, sind die Rechte verändert auf -rwx------. Das ist alles aber nicht korrekt. Und, es ist auch vollkommen unabhänig davon welche create mask oder force mask du setzt. QNAP beachtet das einfach nicht und liefert immer diese -rwx------ zurück.

Ob nun Synology da immer -rwxrwxrwx liefert müsste erst noch jemand mal genau testen bzw. @tinatrompete bestätigen.

Edit:
ich kann auch dir auch sagen, woran das grundsätzlich liegt. Nämlich daran das QNAP standarmäßig folgendes setzt:

fruit:nfs_aces = no

Seltsamerweise verursacht ein Löschen bzw. setzen auf yes andere Probleme mit der QNAP-Implementation, die ich nicht mit dem mitgelieferten samba-Server lösen konnte. Daher dann ein seaprat installierter Samba-Server, der sich auch exakt so verhielt, wie es das samba-Projekt beschreibt.
 

tinatrompete

Mitglied
Registriert
17.03.2021
Beiträge
164
Standardmäßig legt macOS Textdateien nicht so an, sondern immer ohne executable (x)

Ja, genau.
Standardmäßig sind die Rechte "-rw-r--r--" hier bei mir unter Big Sur 11.6.1.

Edit:
Bei meinen Tests lieferte meine DiskStation immer "-rwxrwxrwx" "-rwx------" zurück.
Protokoll ist SMB3. OS wie geschrieben Big Sur 11.6.1.

Edit 2:
Hab das gleiche gerade auch mal bei meiner Fritzbox gemacht.
Die Fritzbox liefert "-rwx------" zurück. Fritz!OS ist 07.28.

Edit 3:
Muss mich korrigieren, Synology liefert per SMB3 auch "-rwx------" zurück.
Ich hatte mich zum Test versehentlich per AFP verbunden und dabei kam "-rwxrwxrwx" zurück.
 
Zuletzt bearbeitet:

lisanet

Aktives Mitglied
Registriert
05.12.2006
Beiträge
4.994
Ja, genau.
Standardmäßig sind die Rechte "-rw-r--r--" hier bei mir unter Big Sur 11.6.1.

Edit:
Bei meinen Tests lieferte meine DiskStation immer "-rwxrwxrwx" zurück.
Protokoll ist SMB3. OS wie geschrieben Big Sur 11.6.1.

Edit 2:
Hab das gleiche gerade auch mal bei meiner Fritzbox gemacht.
Die Fritzbox liefert "-rwx------" zurück. Fritz!OS ist 07.28.

Danke für's Bestätigen.

Mit der von mir dargestellten Installation eines separaten samba-Servers passiert dies nicht und die Rechte bleiben unverändert, wie auch auf jeder Standardinstallation von samba auf einem Linux (Debian, Ubuntu)
 

picollo

Mitglied
Registriert
01.05.2020
Beiträge
515
Kann ich bestätigen. Klasse Beitrag @lisanet !
Ich habe zwar kein QNAP, aber eine Fritz!Box und eigene SMB-Server (Ubuntu 20.04, Debian Buster auf RaspberryPi). Nur die eigenen Server liefern mir die richtigen -rw-r--r-- Rechte. Meine Einstellungen sind etwas anders als wie die von @lisanet, aber es ist ja auch eine andere Umgebung mit der Notwendigkeit eines SMB1 Protokolls (altes Smart-TV).
 

picollo

Mitglied
Registriert
01.05.2020
Beiträge
515
Mit diesen Einstellungen der Shares in der smb.conf erhalte ich das Verhalten, das ich vom Mac oder Linux aus im Zugriff erhalten will (-rw-r--r--). Die Ausführungsrechte für Ordner sind dabei drwxr-xr-x@ (vom Mac aus). Damit kann ich auch im SMB NT Modus (SMB1) drauf zugreifen:

Code:
[SMB_Raspi]
        fruit:aapl = yes
        ea support = yes
        path = /srv/share1/foldername
        ...
        browseable = yes
        writeable = yes
        create mask = 0770
        force create mode = 060
        create directory mask = 0770
        force directory mode = 070
 

Niebelung

Mitglied
Registriert
19.05.2008
Beiträge
82
Nein, ich habe keine ACL verwendet, aber du kannst sie ja auch mit dem "eigenen" Samba-Server aktivieren und verwenden. Wieso fragst du?
Weil das bei mir nicht so klappt, wie Du es beschreibst und ich nicht weiß, ob die ACL da dazwischenfunken. Ich habe einen TrueNAS-Server und da kann ich die Config nicht 100% steuern. Deine Beschreibung war aber dennoch hilfreich, denn jetzt weiß ich erstmals, wo ich da überhaupt hinschauen muss.
 

lisanet

Aktives Mitglied
Registriert
05.12.2006
Beiträge
4.994
ACL haben da definitiv einen Einfluss drauf. Und eben die config option fruit:nfs_aces, wie in #8 beschrieben.
 
Oben Unten