macOS Mojave MacMini braucht lange zum aufwachen aus Ruhezustand über Nacht

TechGeek

Mitglied
Thread Starter
Dabei seit
13.09.2012
Beiträge
737
Punkte Reaktionen
77
Wenn mein Büro Mini (late 12) über Nacht im Ruhezustand ist, dauert das Aufwachen immer enorm lang. (Durch den Tag bei kürzeren Ruhezustandphasen ist das nicht so.) Zuerst erscheint unten am Bildschirm so ein Ladebalken mit vielen vertikalen Strichen. Dann kommt der Anmeldebildschirm wo es aber auch ewig dauert bis überhaupt eine Eingabe möglich ist. Die Maus (MM2) reagiert erst nach dem Aus- und wieder Einschalten. Das Prozedere dauert fast gleich lang wie wenn man ihn neu booten würde.

Habe zu Hause einen genau gleichen Mini bei dem ist das nicht so. Da reagiert der Ruhezustand wie man es erwartet und nach dem Aufwecken ist er sofort bereit. Warum reagieren die gleichen Geräte mit gleichem OS so unterschiedlich? Gibt es eine Einstellung die ich übersehen habe?

Danke für die Hilfe.
 

oneOeight

Aktives Mitglied
Dabei seit
23.11.2004
Beiträge
63.839
Punkte Reaktionen
13.037
Es gibt verschiedene Standby Modi.
Bei dem einen wird der Inhalt des RAMs auf die Platte geschrieben und dann wieder geladen.
Das ist Absicherung wenn der Strom weg ist.
 

TechGeek

Mitglied
Thread Starter
Dabei seit
13.09.2012
Beiträge
737
Punkte Reaktionen
77
Das erklärt aber immer noch nicht das unterschiedliche Verhalten. Und wie man es denn einstellen kann, welchen Modus verwendet werden soll.
 

Stargate

Aktives Mitglied
Dabei seit
27.02.2002
Beiträge
10.475
Punkte Reaktionen
2.657
Warum reagieren die gleichen Geräte mit gleichem OS so unterschiedlich? Gibt es eine Einstellung die ich übersehen habe?

Der Terminal Befehl: pmset -g | grep hibernatemode lässt folgende Antworten zu:

hibernatemode 0:
Normaler Standy/Sleep-Modus

hibernatemode 1:
Das RAM wird auf die Festplatte kopiert, danach wird komplett ausgeschaltet.

hibernatemode 3:
(Default Mode) Safe Sleep (RAM wird auf die Festplatte kopiert, bleibt aber unter Strom/Standby)

hibernatemode 5:
Der gleiche Modus wie 1, anstelle des RAM wird der virtueller Speicher verwendet.
(Einstellen in System Einstellungen -> Sicherheit).

hibernatemode 7:
Wie Modus 3, aber für die Verwendung des sicheren virtuellen Speichers.


Um den Ruhezustand (Hibernate-Modus) zu ändern dient der Befehl: sudo pmset -a hibernatemode x

Wenn du notiert haben möchtest welcher Mode einstellt ist erledigt das der Befehl:
sudo pmset -g | grep hibernatemode > ~/Desktop/current_mode.txt
Erzeugt eine Datei mit entsprechendem Inhalt auf dem Desktop.
 

MiketheBird

Aktives Mitglied
Dabei seit
07.02.2021
Beiträge
1.568
Punkte Reaktionen
1.177
Wenn mein Büro Mini (late 12) ...

Habe zu Hause einen genau gleichen Mini ...

Warum reagieren die gleichen Geräte mit gleichem OS so unterschiedlich? Gibt es eine Einstellung die ich übersehen habe?
Antwort 1: Weil sie in unterschiedlichen Umgebungen stehen, siehe farblich markierte Zitate.
Antwort 2: Nicht notwendigerweise in deinen eigenen Einstellungen, sondern im Netz des Büros.

Im Büronetz dürften einige Dinge über Netzlaufwerke und Routereinstellungen anders laufen als zu Hause. Wenn der Mac aus dem Ruhezustand wieder aufwacht, dann stellt der einige Dinge erst wieder her bis das System sich betriebsbereit meldet. Typischerweise ist in den Büroumgebungen die Zeit bis die Wiederherstellung von im Netz befindlicher Ressourcen deutlich länger (manchmal wartet der Mac bis zum TimeOut der Gegenstelle und bei Netzressourcen geht es im Mac auch einfach nicht weiter bei bestimmten Dingen um die Systemintegrität zu erhalten).
 

TechGeek

Mitglied
Thread Starter
Dabei seit
13.09.2012
Beiträge
737
Punkte Reaktionen
77
Der Terminal Befehl: pmset -g | grep hibernatemode lässt folgende Antworten zu:

hibernatemode 0:
Normaler Standy/Sleep-Modus

hibernatemode 1:
Das RAM wird auf die Festplatte kopiert, danach wird komplett ausgeschaltet.

hibernatemode 3:
(Default Mode) Safe Sleep (RAM wird auf die Festplatte kopiert, bleibt aber unter Strom/Standby)

hibernatemode 5:
Der gleiche Modus wie 1, anstelle des RAM wird der virtueller Speicher verwendet.
(Einstellen in System Einstellungen -> Sicherheit).

hibernatemode 7:
Wie Modus 3, aber für die Verwendung des sicheren virtuellen Speichers.


Um den Ruhezustand (Hibernate-Modus) zu ändern dient der Befehl: sudo pmset -a hibernatemode x

Wenn du notiert haben möchtest welcher Mode einstellt ist erledigt das der Befehl:
sudo pmset -g | grep hibernatemode > ~/Desktop/current_mode.txt
Erzeugt eine Datei mit entsprechendem Inhalt auf dem Desktop.
Danke für die Infos. Aber gemäss der Ausgabe mit obigem Befehl ist "hibernatemode 0" eingestellt. Das passt aber nicht zu meinem beschriebenen Verhalten! Die Maus muss ich auch immer erst aus- und wieder einschalten bevor sie reagiert. (Beim Ausschalten wird aber sofort "Maus aus" eingeblendet.) Aber eben nur wenn der Ruhezustand über Nacht aktiv ist. Über Mittag oder ein paar Stunden am Nachmittag ist das nicht so. Der baugleiche Mini mit dem selben Mojave OS reagiert zu Hause ganz anders. Der ist ja den ganzen Tag und die ganze Nacht im Ruhezustand, wenn ich den Abends wecke ist er sofort da mit dem Anmeldebildschirm.


Antwort 1: Weil sie in unterschiedlichen Umgebungen stehen, siehe farblich markierte Zitate.
Antwort 2: Nicht notwendigerweise in deinen eigenen Einstellungen, sondern im Netz des Büros.

Im Büronetz dürften einige Dinge über Netzlaufwerke und Routereinstellungen anders laufen als zu Hause. Wenn der Mac aus dem Ruhezustand wieder aufwacht, dann stellt der einige Dinge erst wieder her bis das System sich betriebsbereit meldet. Typischerweise ist in den Büroumgebungen die Zeit bis die Wiederherstellung von im Netz befindlicher Ressourcen deutlich länger (manchmal wartet der Mac bis zum TimeOut der Gegenstelle und bei Netzressourcen geht es im Mac auch einfach nicht weiter bei bestimmten Dingen um die Systemintegrität zu erhalten).
In der Theorie kann ich das nachvollziehen, in der Praxis aber nicht. Ich bin selbständig und habe für mich alleine ein eigenes Büro. Nur der Mini und machchmal noch das MBP hängen dort im Netz. Alle Geräte von mir selber installiert und eingerichtet. Internet vom gleichen Anbieter. OK der Router ist nicht das gleiche Modell, aber kann mir irgendwie nicht vorstellen, dass der Einfluss auf den Ruhezustand des Minis hat. Zudem laufen die Router in den Standardeinstellungen des Anbieters, habe da nichts verändert.
 

Stargate

Aktives Mitglied
Dabei seit
27.02.2002
Beiträge
10.475
Punkte Reaktionen
2.657
Danke für die Infos. Aber gemäss der Ausgabe mit obigem Befehl ist "hibernatemode 0" eingestellt. Das passt aber nicht zu meinem beschriebenen Verhalten! Die Maus muss ich auch immer erst aus- und wieder einschalten bevor sie reagiert. (Beim Ausschalten wird aber sofort "Maus aus" eingeblendet.) Aber eben nur wenn der Ruhezustand über Nacht aktiv ist. Über Mittag oder ein paar Stunden am Nachmittag ist das nicht so. Der baugleiche Mini mit dem selben Mojave OS reagiert zu Hause ganz anders. Der ist ja den ganzen Tag und die ganze Nacht im Ruhezustand, wenn ich den Abends wecke ist er sofort da mit dem Anmeldebildschirm.

Keine Ursache.

Das die Maus erst wieder nach dem Ein- bzw. Ausschalten hat tut hat eher was mit Bluetooth zu tun UND ob der Mac bei Bewegung dieser Maus Aufwachen soll. Das unterschiedliche Verhalten kann natürlich auch von den Einstellung der jeweiligen Benutzer-Umgebung abhängig sein.

Wenn bei diesen Symptomen in den ganzen Einstellungen nichts ungewöhnliches zu finden ist würde ich durchaus auch einen NVRAM-Reset machen. Kaputt geht dadurch nichts.

Ziemlich ungewöhnlich finde ich den Eingangs beschrieben Ladebalken mit den vielen Strichen.
Ohne es gesehen zu haben würde ich das als Laden des Speicherinhalts von einer Festplatte deuten.
 

TechGeek

Mitglied
Thread Starter
Dabei seit
13.09.2012
Beiträge
737
Punkte Reaktionen
77
Ziemlich ungewöhnlich finde ich den Eingangs beschrieben Ladebalken mit den vielen Strichen.
Ja, eben ich ja auch! Darum dieses Thema hier! ;)

Ohne es gesehen zu haben würde ich das als Laden des Speicherinhalts von einer Festplatte deuten.
Ja genau das wird es sein. (Macht das MBP auch wenn dem mal der Saft ausgegangen ist.) Das würde ja für den hibernatemode 1 oder 3 sprechen. Die Abfrage sagt aber, dass hibernatemode 0 eingestellt wäre. Steht ja immer unter Strom! Werde nächste Woche mal den NVRAM-Reset versuchen.

Was mich eben irritiert ist, weil es zwei baugleiche Geräte mit gleicher Software sind. Sie haben auch gleich viel RAM. Einziger Unterschied ist, der Büro Mini hat noch ne HDD und der zu Hause eine SSD. Klar ist die HDD langsamer, aber doch nicht so. Und wie gesagt, es passiert ja nur wenn er über Nacht im Ruhezustand war. Über Mittag zum Beispiel passiert das nicht, das erwacht er ganz schnell wieder aus dem Ruhezustand!
 

TechGeek

Mitglied
Thread Starter
Dabei seit
13.09.2012
Beiträge
737
Punkte Reaktionen
77

RIN67630

Aktives Mitglied
Dabei seit
13.09.2021
Beiträge
2.636
Punkte Reaktionen
1.104
Bei diesem Bild aus dem Netz sieht man was ich meine (bin ja jetzt grad nicht im Büro):
Das Bild zeigt ein Moiré-Effekt der nur bei Digitalkameras vorkommt. Das merkt man weil die Linien krumm sind.
Das kannst Du kaum mit bloßen Augen so gesehen haben.

Sind bei Dir die Linien perfekt senkrecht, sieht es eher nach aussterbende Kapazitoren am Inverter der Hintergrundbeleuchtung oder der Hauptstromversorgung.
 

JenaroFios

Mitglied
Dabei seit
05.08.2021
Beiträge
83
Punkte Reaktionen
42
Nein. Er spricht doch von dem „Ladebalken“ in der Mitte im unteren Drittel oberhalb der Symbole und nicht von den farbigen Streifen des Moiré-Effektes.
 

tocotronaut

Aktives Mitglied
Dabei seit
14.01.2006
Beiträge
29.830
Punkte Reaktionen
9.454
Es gibt dann noch einen weiteren Tiefschlafmodus, der mit dem Mode 0 kombiniert werden kann.

Dann geht der Rechner nach ...iirc... 4 Stunden im modus 0 in den modus 1 (oder so ähnlich)
edit: Ich meine die Einstellung müsste autopoweroffdelay heissen und ist eine EU-Vorgabe.

Poste doch mal die gesamte Übersicht an pmset Einstellungen die bei dir gesetzt sind. (pmset -g)
 
Zuletzt bearbeitet:

RIN67630

Aktives Mitglied
Dabei seit
13.09.2021
Beiträge
2.636
Punkte Reaktionen
1.104
Nein. Er spricht doch von dem „Ladebalken“ in der Mitte im unteren Drittel oberhalb der Symbole und nicht von den farbigen Streifen des Moiré-Effektes.
Tut mit Leid, ich kann mir nicht vorstellen, was sonnst mit "so ein Ladebalken mit vielen vertikalen Strichen" gemeint sein kann.
Ich wil auch nicht darüber rätseln.
 

MacKaz

Aktives Mitglied
Dabei seit
12.01.2020
Beiträge
2.449
Punkte Reaktionen
1.506
Tut mit Leid, ich kann mir nicht vorstellen, was sonnst mit "so ein Ladebalken mit vielen vertikalen Strichen" gemeint sein kann.
Ich wil auch nicht darüber rätseln.
Brauchst Du Dir ja auch nicht vorzustellen oder zu rätseln, ist doch auf dem Bild sehr deutlich oberhalb des Dock zu sehen ;)
 

tocotronaut

Aktives Mitglied
Dabei seit
14.01.2006
Beiträge
29.830
Punkte Reaktionen
9.454
na der ladebalken mit den einzelnen punkten aus dem verlinkten bild. recht weit unten, mittig. Weiße Punkte.

Das Bild selbst ist allerdings irgendwo aus dem Internet und hat in der tat einen moire effekt der durch die Kamera verursacht wird.
das tut aber hier nichts zur Sache es geht um das Aussehen des Balkens. (Ladebalken der aus einzelnen "Strichen" zusammengesetzt ist)

Und der kommt immer dann, wenn der mac aus dem Tiefschlaf erwacht und den Speicherinhalt von der Festplatte wieder in den RAM Schaufelt.
Grafikprobleme hat er nicht und (vermutlich auch deshalb) zu deinem Wunsch nach "abfotografieren" noch gar nichts gepostet...

Des Rätsels Lösung müsste ein:
Der Rechner geht nach 4 stunden Hibernate 0 in den Hibernate 1.
Deshalb stört das bei der Arbeit Tagsüber nicht, Morgens braucht er allerdings länger.

Diese Einstellung für Elektrogeräte wurde irgendwann von der EU als Vorgabe gegeben.
Fernseher schalten (voreingestellt) auch nach 4 Stunden aus.

p.s.:
Apple nennt das ganze "Sicheren Ruhezustand."
https://support.apple.com/de-de/guide/mac-help/mh10328/mac
Da aktuelle Supportdokument nennt das nur für Mobilcomputer, Früher waren da aber auch Minis und iMacs erwähnt.

Die pmset Variable autopoweroffdelay sollte den Zeitpunkt für den wechsel in Hibernate 1 in Sekunden anzeigen.
14400 sekunden = 4 Stunden sollten standard sein.

Eventuell ist der private mini da mal angepasst worden, wenn er das Verhalten nicht zeigt.
 
Zuletzt bearbeitet:

Stargate

Aktives Mitglied
Dabei seit
27.02.2002
Beiträge
10.475
Punkte Reaktionen
2.657
Ja genau das wird es sein. (Macht das MBP auch wenn dem mal der Saft ausgegangen ist.) Das würde ja für den hibernatemode 1 oder 3 sprechen. Die Abfrage sagt aber, dass hibernatemode 0 eingestellt wäre. Steht ja immer unter Strom! Werde nächste Woche mal den NVRAM-Reset versuchen.

Dann sollte das theoretisch auch so sein, das sich der Modus des Ruhezustands selbstständig ändert habe ich noch nie gehört.

Was mich eben irritiert ist, weil es zwei baugleiche Geräte mit gleicher Software sind. Sie haben auch gleich viel RAM. Einziger Unterschied ist, der Büro Mini hat noch ne HDD und der zu Hause eine SSD. Klar ist die HDD langsamer, aber doch nicht so. Und wie gesagt, es passiert ja nur wenn er über Nacht im Ruhezustand war. Über Mittag zum Beispiel passiert das nicht, das erwacht er ganz schnell wieder aus dem Ruhezustand!

Die Einstellungen "Energie Sparen" mischen da auch noch ein wenig mit.
Ausgeschlossen ist halt nicht das es nicht doch irgend wo ein Programm, eine Einstellung gibt die Einfluss auf das Verhalten hat.

Ich schliesse nach all den Jahren "Apple" inzwischen auch nicht mehr aus das bei Apple baugleiche Geräte doch nicht gleich sind - besonders nicht wenn vielleicht doch auf den gleichen Geräten u.U unterschiedliche Firmware geben kann.
 

tocotronaut

Aktives Mitglied
Dabei seit
14.01.2006
Beiträge
29.830
Punkte Reaktionen
9.454
Der dienstliche Mac arbeitet ja korrekt.
vielleicht wurde es am Privaten mac irgendwann mal umgestellt.

Das sind Dinge die man gerne auch wieder Vergisst, nachdem man eine Anleitung aus dem Internet abgearbeitet hat. :noplan:
 

TechGeek

Mitglied
Thread Starter
Dabei seit
13.09.2012
Beiträge
737
Punkte Reaktionen
77
Es gibt dann noch einen weiteren Tiefschlafmodus, der mit dem Mode 0 kombiniert werden kann.

Dann geht der Rechner nach ...iirc... 4 Stunden im modus 0 in den modus 1 (oder so ähnlich)
edit: Ich meine die Einstellung müsste autopoweroffdelay heissen und ist eine EU-Vorgabe.

Poste doch mal die gesamte Übersicht an pmset Einstellungen die bei dir gesetzt sind. (pmset -g)
Hier der Auszug aus dem privaten Mini zu Hause:

Code:
System-wide power settings:
Currently in use:
 standby              1
 Sleep On Power Button 1
 womp                 0
 autorestart          0
 hibernatefile        /var/vm/sleepimage
 powernap             0
 networkoversleep     0
 disksleep            10
 standbydelayhigh     86400
 sleep                60
 autopoweroffdelay    14400
 hibernatemode        0
 autopoweroff         1
 ttyskeepawake        1
 displaysleep         60
 highstandbythreshold 50
 standbydelaylow      86400

Und hier der Büro Mini:

Code:
System-wide power settings:
Currently in use:
 standby              0
 Sleep On Power Button 1
 womp                 1
 autorestart          0
 hibernatefile        /var/vm/sleepimage
 powernap             0
 networkoversleep     0
 disksleep            10
 standbydelayhigh     86400
 sleep                180
 autopoweroffdelay    14400
 hibernatemode        0
 autopoweroff         1
 ttyskeepawake        1
 displaysleep         180
 highstandbythreshold 50
 standbydelaylow      86400

autopoweroffdelay ist bei beiden identisch, trotz des unterschiedlichen Verhaltens.

Des Rätsels Lösung müsste ein:
Der Rechner geht nach 4 stunden Hibernate 0 in den Hibernate 1.
Deshalb stört das bei der Arbeit Tagsüber nicht, Morgens braucht er allerdings länger.

Diese Einstellung für Elektrogeräte wurde irgendwann von der EU als Vorgabe gegeben.
Fernseher schalten (voreingestellt) auch nach 4 Stunden aus.

p.s.:
Apple nennt das ganze "Sicheren Ruhezustand."
https://support.apple.com/de-de/guide/mac-help/mh10328/mac
Da aktuelle Supportdokument nennt das nur für Mobilcomputer, Früher waren da aber auch Minis und iMacs erwähnt.

Die pmset Variable autopoweroffdelay sollte den Zeitpunkt für den wechsel in Hibernate 1 in Sekunden anzeigen.
14400 sekunden = 4 Stunden sollten standard sein.
Ok, jetzt wissen wir warum der Büro Mini tut was er tut. Fragt sich nur warum der Heim Mini das nicht macht, trotz der identischen 14400 Sekunden.

Ausserdem fragt sich, wie man dem Büro Mini das Verhalten "abgewöhnen" kann...?
 
Oben Unten