Installation eines *.tar -Verzeichnisses/Linux-Programmes, viel probiert, nix klappt!

unidog

Mitglied
Thread Starter
Dabei seit
31.03.2005
Beiträge
556
Punkte Reaktionen
58
Hallo zusammen,

bin zwar kein Neuling am Mac, aber absolute Anfängerin was Unix usw. angeht und auch sonst eben eher normale Nutzerin ohne große "Nerd-Ambitionen"...

Also zu meinem Problem (bitte nicht lachen):

Ich möchte das Programm "Chemtools" zum Laufen bringen (http://ruby.chemie.uni-freiburg.de/~martin/chemtool).
Nachdem ich stundenlang im www nach Anleitungen und Tipps gesucht habe, habe ich folgendes bereits getan:

1) X11 installiert
2) Developer Tools installiert
3) Fink installiert, in der Hoffnung, dass ich damit dieses tar-Paket irgendwie installieren kann. Ich kapiere Fink allerdings nicht...

geklappt hat Folgendes: Über das Terminal habe ich im (entpackten) chemtool-Ordner ./configure ausgeführt habe - keine Fehlermeldung, hat also wohl funktioniert.

Wenn ich es richtig verstanden habe, müsste ich jetzt den Befehl make ausführen. Wenn ich das tue (ich tippe make und drücke dann Enter), folgt diese Meldung:
make: *** No targets specified and no makefile found. Stop.

Ich raffs nicht ... mehrere Dateien mit Namen Makefile mit verschiedenen Endungen liegen im entsprechenden Ordner...

Was muss ich jetzt machen? Und: Wie starte ich das Programm, wenn es sich denn installieren lässt?

Hoffe, ich habe mich verständlich ausgedrückt und wäre für Hilfe sehr dankbar,
unidog
 

oneOeight

Aktives Mitglied
Dabei seit
23.11.2004
Beiträge
63.961
Punkte Reaktionen
13.104
ein tar file ist gepackt, du musst es erst auspacken.
einfach doppel klicken, dann kriegst du einen ordner mit den sourcen...
 

unidog

Mitglied
Thread Starter
Dabei seit
31.03.2005
Beiträge
556
Punkte Reaktionen
58
Danke erstmal.
Den Ordner habe ich schon, nur kann ich damit leider nichts anfangen ...
 

oneOeight

Aktives Mitglied
Dabei seit
23.11.2004
Beiträge
63.961
Punkte Reaktionen
13.104
dann cd mal in den ordner, danach
./configure
make
sudo make install
 

unidog

Mitglied
Thread Starter
Dabei seit
31.03.2005
Beiträge
556
Punkte Reaktionen
58
Bis
./configure
komme ich, wenn ich "make" eingebe, folgt diese Meldung

make: *** No targets specified and no makefile found. Stop.

Und bei sudo make install folgt diese Meldung:

kvs-macbook:chemtool-1.6.12 admin$ sudo make install
Password:
make: Nothing to be done for `install'.
 
Zuletzt bearbeitet:

oneOeight

Aktives Mitglied
Dabei seit
23.11.2004
Beiträge
63.961
Punkte Reaktionen
13.104
wenn du nach dem configure kein Makefile hast, ist es halt nicht erfolgreich durchgelaufen und dir fehlen noch sachen...
 

unidog

Mitglied
Thread Starter
Dabei seit
31.03.2005
Beiträge
556
Punkte Reaktionen
58
Warum willst du den Source selber kompilieren?
Gibt doch fertige Chemtool Pakete für Fink (und auch Darwinports hat's im Angebot)

Danke, dass ihr euch bemüht. Leider stelle ich mich gerade unglaublich dämlich an: Deinen Link kenne ich schon, nur leider passiert nichts, wenn ich auf die Links zu den Chemtool-Paketen klicke.
Mit Darwinports kann ich nichts anfangen, werde mich schlau machen...


wenn du nach dem configure kein Makefile hast, ist es halt nicht erfolgreich durchgelaufen und dir fehlen noch sachen...

Offensichtlich ist das leider so, obwohl "Makefiles" im Ordner liegen.

unidog
 

oneOeight

Aktives Mitglied
Dabei seit
23.11.2004
Beiträge
63.961
Punkte Reaktionen
13.104
macports ist ähnlich wie fink...
warum nutzt du fink nicht einfach, wenn du es schon installiert hast?
fink install chemtools
sollte alles sein, was du tun musst...
 

oneOeight

Aktives Mitglied
Dabei seit
23.11.2004
Beiträge
63.961
Punkte Reaktionen
13.104
hast du fink korrekt installiert und mal ein selfupdate gemacht?
 

oneOeight

Aktives Mitglied
Dabei seit
23.11.2004
Beiträge
63.961
Punkte Reaktionen
13.104
dann sollte chemtools da sein...

kannst ja auch mal macports installieren und es dort versuchen...
 

unidog

Mitglied
Thread Starter
Dabei seit
31.03.2005
Beiträge
556
Punkte Reaktionen
58
ja danke, werde ich im Laufe des Tages mal probieren mit macports
 

unidog

Mitglied
Thread Starter
Dabei seit
31.03.2005
Beiträge
556
Punkte Reaktionen
58
so! Mit macports das chemtool-Paket gefunden, nach 1,5-stündiger Installation:

On Mac OS X 10.5, tiff 3.9.1 requires Xcode 3.1 or later but you have Xcode 3.0.
Error: Target org.macports.extract returned: incompatible Xcode version


Jetzt gebe ich wirklich auf, besonders nachdem ich auf eine einfachere kostenlose Möglichkeit zum Strukturformel malen gekommen bin...

Danke für die Hilfe, macports ist toll, das werde ich weiterhin nutzen.
unidog
 

unidog

Mitglied
Thread Starter
Dabei seit
31.03.2005
Beiträge
556
Punkte Reaktionen
58
was hindert dich Xcode 3.1 zu laden?

im Moment sollte ich eigentlich lernen. Xcode 3.1 laden, installieren (=warten) usw. lenkt mich ab. Leider habe ich eh schon zu viel Zeit verdaddelt ...

aber neugierig wär ich schon, dass Programm endlich zum Laufen zu kriegen ...

bis dahin :p
unidog
 
Oben Unten