iMac PowerPC G4 (Lampe) > Piepton während Booten

liquidplace

Neues Mitglied
Thread Starter
Registriert
16.03.2021
Beiträge
11
Hallo liebe Community,

ich habe mich heute im Forum angemeldet und hoffe auf geballte "Fachkompetenz"! ;-) und vielleicht Eure Hilfe bei einem kleinen Problem.

Von einem Arbeitskollegen habe ich einen wunderschönen 20" iMac PowerPC G4 / 1,25GHz / 80GB Festplatte (Hitachi) / 1GB RAM (2x512GB DDR SDRAM) / 2004 / Mac OS 10.5.8 (aka: "Die Lampe" :) geschenkt bekommen und möchte ihm nun ein würdevolles, verlängertes Leben mit kleinen Extras wie SSD und RAM Upgrades ermöglichen.

Er hat ein kleines Problem, welches ich zu beheben hoffe:
  • Gleichmäßiger Piepton während des Bootvorgangs
  • Mehrere, nacheinander folgende Bootvorgänge (mit Ein-/Ausschalten) ergeben unterschiedliche Dauer des Bootvorgangs:
  • Bootvorgang 1 > Wenn ich den iMac boote, dauert der Bootvorgang eine bestimmte Zeit und man hört die ganze Zeit über einen gleichmäßigen Piepton.
  • Bootvorgang 2 > Wenn ich direkt nach diesem ersten Bootvorgang den iMac ausschalte und erneut starte, dauert der Bootvorgang wesentlich kürzer und man hört nur 3 Pieptöne.
  • Bootvorgang 3 > Wenn ich den iMac nach diesem zweiten Bootvorgang erneut ausschalte und wieder boote, ist der Bootvorgang nochmal kürzer und es ertönt nur 1 kurzer Piepton.
Meine Google-Recherche zu den gängigen, bei versch. iMac Baureihen existierenden Pieptönen (nicht erkannter RAM BAustein etc. ...), ergab leider kein Ergebnis.
Der iMac wurde in den letzten 1,2 Jahren laut Vorbesitzer im Jahr nur sehr selten eingeschaltet/benutzt. Könnte es vielleicht die Pufferbatterie sein, welche nach 17 Jahren jetzt auf ihr baldiges Lebensende hinweist?

Zusatzfrage: Wenn der iMac eingeschaltet ist, springt der Lüfter schnell an und läuft hörbar die ganze Zeit. Kann es Sinn machen bei einem solchen 17 Jahren alten Modell einen neuen Lüfter einzubauen, welche leiser wäre? Kauftipp? ;-)

Anbei findet Ihr die 3 Bootvorgänge audiovisuell festgehalten als Videos.

Bootvorgang 1 > http://www.liquidplace.com/imac/iMac_Bootvorgang_1.mp4
Bootvorgang 2 > http://www.liquidplace.com/imac/iMac_Bootvorgang_2.mp4
Bootvorgang 3 > http://www.liquidplace.com/imac/iMac_Bootvorgang_3.mp4

So now .... I'll cross my fingers and hope for some help within that super great Mac Forum ;-)

Vorab schonmal DANKE!

Gruß

Micha

--------------------------------------

English Version

--------------------------------------

Hello dear community,

I registered myself in the forum today and hope for concentrated "expertise"! ;-) and maybe your help with a little problem.

A work colleague gave me a beautiful 20 "iMac PowerPC G4 / 1.25GHz / 80GB hard drive (Hitachi) / 1GB RAM (2x512GB DDR SDRAM) / 2004 / Mac OS 10.5.8 (aka:" The lamp ":) and would now like to enable it to have a dignified, extended life with little extras such as SSD and RAM upgrades.

He has a little problem that I hope to fix:
  • Uniform beep during the boot process
  • Several successive boot processes (with switching on / off) result in different boot process times:
  • Boot process 1> When I boot the iMac, the boot process takes a certain amount of time and you can hear a steady beep all the time.
  • Boot process 2> If I switch off the iMac immediately after this first boot process and start it again, the boot process takes much shorter and you only hear 3 beeps.
  • Boot process 3> If I switch off the iMac again after this second boot process and boot it again, the boot process is again shorter and only 1 short beep sounds.
My Google research on the common beeps that existing for various iMac series (RAM module not recognized, etc. ...) unfortunately yielded no result.
According to the previous owner, the iMac was very rarely turned on / used in the past 1/2 years. Could it be the backup battery that, after 17 years, is now pointing to the end of its life?

Additional question: When the iMac is switched on, the fan starts up quickly and audibly runs all the time. Can it make sense to install a new fan in such a 17 year old model, which would be quieter? Buying tip? ;-)

Enclosed you will find the 3 boot processes recorded audiovisually as videos.
So now .... I'll cross my fingers and hope for some help within that super great Mac Forum ;-)

Thank you in advance!

Regards

Micha
 

Stargate

Aktives Mitglied
Registriert
27.02.2002
Beiträge
9.781
Moin,

Willkommen im Forum.

Der laute Gong beim Start ist normal.

Drei Pieptöne beim Start deuten auf einen fehlerhaften Arbeitsspeicher hin. Das muss man suchen und durch austauschen der RAM-Module feststellen.
Auf der DVD die zu diesem iMac gehört befindet sich der Apple Hardware Test (AHT) den man durch drücken und halten von "D" beim Systemstart laufen lassen kann.
Die DVD muss dazu aber vor dem Systemstart schon eingelegt gewesen sein.

Wenn ich es noch richtig weiß läuft der Lüfter in diesem Modell grundsätzlich immer und ist abhänig der internen Temperatur in der Drehzahl geregelt.

Die Pufferbatterie hält in der Regel ca. 15 Jahre maximal.
Ob sie leer ist sieht man daran das sich der Mac Datum und Uhrzeit nicht merken kann wenn er länger stromlos war.

Wenn das Oberteil des Gehäuses ab ist kann man die (meistens) lila oder grüne Batterie kaum übersehen.

Die Festplatte ist übrigens IDE, d.h wenn du eine SSD einbauen möchtest geht das nur über den IDE-Anschluß.
Ob es da was passendes gibt kann ich aus dem Stand nicht beantworten.
Von OWC gab es jedoch mal "G4 SSD Kits".. als Anhaltspunkt.
 
Zuletzt bearbeitet:

oneOeight

Aktives Mitglied
Registriert
23.11.2004
Beiträge
57.679
Es ist nicht die Puffer Batterie.
Die Beeps kommen nur bei RAM Problemen.
Hast du denn das RAM schon getauscht?
Falld ja, ist es überhaupt kompatibel?
Guck sonst mal rein, ob da Staub an den Sockeln ist.
Vielleicht hilt es auch die RAM Module kurz aus und wieder richtig rein zu stecken.

Hast du die DVDs mitbekommen?
Eine müsste den Hardware Test haben.
 

JeanLuc7

Aktives Mitglied
Registriert
04.04.2005
Beiträge
5.269
Vielleicht hilt es auch die RAM Module kurz aus und wieder richtig rein zu stecken.
Sofern Du das Unterteil vom Oberteil trennst, musst Du danach auch wieder Wärmeleitpaste auf die Unterseite der dicken Metallsäule auftragen. Das ist nämlich ein Teil der Kühlung.
 

liquidplace

Neues Mitglied
Thread Starter
Registriert
16.03.2021
Beiträge
11
Moin,

Willkommen im Forum.

Der laute Gong beim Start ist normal.

Drei Pieptöne beim Start deuten auf einen fehlerhaften Arbeitsspeicher hin. Das muss man suchen und durch austauschen der RAM-Module feststellen.
Auf der DVD die zu diesem iMac gehört befindet sich der Apple Hardware Test (AHT) den man durch drücken und halten von "D" beim Systemstart laufen lassen kann.
Die DVD muss dazu aber vor dem Systemstart schon eingelegt gewesen sein.

Wenn ich es noch richtig weiß läuft der Lüfter in diesem Modell grundsätzlich immer und ist abhänig der internen Temperatur in der Drehzahl geregelt.

Die Pufferbatterie hält in der Regel ca. 15 Jahre maximal.
Ob sie leer ist sieht man daran das sich der Mac Datum und Uhrzeit nicht merken kann wenn er länger stromlos war.

Wenn das Oberteil des Gehäuses ab ist kann man die (meistens) lila oder grüne Batterie kaum übersehen.

Die Festplatte ist übrigens IDE, d.h wenn du eine SSD einbauen möchtest geht das nur über den IDE-Anschluß.
Ob es da was passendes gibt kann ich aus dem Stand nicht beantworten.
Von OWC gab es jedoch mal "G4 SSD Kits".. als Anhaltspunkt.

@Stargate:

Wow!!!! Das ging schnell, tolles Forum :) Vielen Dank.

Der gleichmäßige Piepton dauert immer solange wie er bootet.

Der RAM sollte es auch nicht sein, der wird im OS mit Status OK für beide Module angezeigt. Auch der Piepcode passt nicht dazu.

Der Hinweis mit dem AHT war gut, konnte ich mit den vorliegenden DVDs (sollten laut Vorbesitzer auch die mitgelieferten sein) aber leider nicht nachvollziehen, die deutsch beschriftete DVD (mit AHT Hinweis > siehe angehängtes Foto) hat das Laufwerk scheinbar garnicht wirklich lesen können, die englisch beschriftete DVD schon + "D" während Bootvorgang ... hat leider auch nichts bewirkt, er hat einfach normal gebootet und die DVD dann ausgeworfen. Die "D" Taste hatte ich während des kompletten Bootvorgangs gedrückt ... mhmmmm. ODer mach ich da was falsch? ;-)

iMac_OS_CDs.jpeg

Crazy >>> Wenn man direkt nacheinander mehrere Ein-/Ausschalt-/Bootvorgänge durchführt, verkürzt sich die Bootzeit jedes mal.

Beim 4. Mal war der Piepton dann garnicht mehr vorhanden, siehe folgendes Video:
Vorhin habe ich ihn 2 Std. ausgeschaltet gelassen und jetzt wieder eingeschaltet .... und das Piepen ist wieder da > jetzt 4 mal :) :) :) #Beepmachine!!! :)
Die Pufferbatterie werd ich wohl besser einfach mit wechseln, wenn ich ihn öffne, 17 Jahren werden genug sein ;-)

Bezgl. Festplatte hab ich schon ein paar gute YT Videos gesehen und einen Tip zu einer passenden Crucial-SSD von nem Freund bekommen. Er hat sie in seinem iBook G4 schonmal eingesetzt > https://www.amazon.de/dp/B07G3KRZBX...b9f740eb629d8&language=de_DE&ref_=as_li_ss_tl

Gruß

Micha
 

liquidplace

Neues Mitglied
Thread Starter
Registriert
16.03.2021
Beiträge
11
Sofern Du das Unterteil vom Oberteil trennst, musst Du danach auch wieder Wärmeleitpaste auf die Unterseite der dicken Metallsäule auftragen. Das ist nämlich ein Teil der Kühlung.
Vielen Dank, der Hinweis ist gut. Ich werd mir eine bestellen, welche ich in einem YT Video dazu gesehen habe.
 

liquidplace

Neues Mitglied
Thread Starter
Registriert
16.03.2021
Beiträge
11
Es ist nicht die Puffer Batterie.
Die Beeps kommen nur bei RAM Problemen.
Hast du denn das RAM schon getauscht?
Falld ja, ist es überhaupt kompatibel?
Guck sonst mal rein, ob da Staub an den Sockeln ist.
Vielleicht hilt es auch die RAM Module kurz aus und wieder richtig rein zu stecken.

Hast du die DVDs mitbekommen?
Eine müsste den Hardware Test haben.
Die RAMs wurde mal getauscht. Mein Kollege/der Vorbesitzer hat das höchst offiziell bei Gravis mal upgraden lassen.
Es sind zwei 512 GB DDR-SDRAMs verbaut, beide werden im OS/Systeminfo mit Status OK gelistet.
Der Piepcode entspricht wohl leider auch keinem RAM Fehler, er ist gleichmäßig und dauert so lange wie der Bootvorgang dauert, siehe dazu meine Update/Antwort an Stargate von gerade eben.
 

ylf

Aktives Mitglied
Registriert
30.09.2006
Beiträge
1.385
Mal 'ne ganz blöde Frage, kommt der "Beep" aus dem Lautsprecher oder pfeift da einfach nur die mechanische Festplatte, weil sie einen Lagerschaden hat oder der Schreib/Lesekopf schwingt wegen Read-Errors?
Kann ein Problem mit der Spannungsversorgung den "Beep" verursachen? (Alte Netzteile, alte Elkos, unsaubere Spannung)
Wenn das System den Speicher erkennt, ist das zwar gut und schön, aber kein Garant, dass der Speicher Zelle für Zelle in Ordnung ist.
Mehr fällt mir gerade auch nicht ein.
Viel Erfolg bei der Fehlersuche!
 

JeanLuc7

Aktives Mitglied
Registriert
04.04.2005
Beiträge
5.269
oder pfeift da einfach nur die mechanische Festplatte, weil sie einen Lagerschaden hat oder der Schreib/Lesekopf schwingt wegen Read-Errors?
Das ist eine berechtigte Frage, daran hatte ich noch nicht gedacht. Aber alte Platten machten solche Geräuscheja manchmal schon von hause aus - ich denke da an meine erste Seagate-Platte, eine ST-251 mit 40MB. Ein Heuler!
 

liquidplace

Neues Mitglied
Thread Starter
Registriert
16.03.2021
Beiträge
11
Moin,

Willkommen im Forum.

Der laute Gong beim Start ist normal.

Drei Pieptöne beim Start deuten auf einen fehlerhaften Arbeitsspeicher hin. Das muss man suchen und durch austauschen der RAM-Module feststellen.
Auf der DVD die zu diesem iMac gehört befindet sich der Apple Hardware Test (AHT) den man durch drücken und halten von "D" beim Systemstart laufen lassen kann.
Die DVD muss dazu aber vor dem Systemstart schon eingelegt gewesen sein.

Wenn ich es noch richtig weiß läuft der Lüfter in diesem Modell grundsätzlich immer und ist abhänig der internen Temperatur in der Drehzahl geregelt.

Die Pufferbatterie hält in der Regel ca. 15 Jahre maximal.
Ob sie leer ist sieht man daran das sich der Mac Datum und Uhrzeit nicht merken kann wenn er länger stromlos war.

Wenn das Oberteil des Gehäuses ab ist kann man die (meistens) lila oder grüne Batterie kaum übersehen.

Die Festplatte ist übrigens IDE, d.h wenn du eine SSD einbauen möchtest geht das nur über den IDE-Anschluß.
Ob es da was passendes gibt kann ich aus dem Stand nicht beantworten.
Von OWC gab es jedoch mal "G4 SSD Kits".. als Anhaltspunkt.

Hi Stargate,

hier ein neues Video wo man sehr gut alles Töne während des Bootens hört :)
http://www.liquidplace.com/imac/iMac_Boot_Sound.mp4
 

liquidplace

Neues Mitglied
Thread Starter
Registriert
16.03.2021
Beiträge
11

liquidplace

Neues Mitglied
Thread Starter
Registriert
16.03.2021
Beiträge
11
Mal 'ne ganz blöde Frage, kommt der "Beep" aus dem Lautsprecher oder pfeift da einfach nur die mechanische Festplatte, weil sie einen Lagerschaden hat oder der Schreib/Lesekopf schwingt wegen Read-Errors?
Kann ein Problem mit der Spannungsversorgung den "Beep" verursachen? (Alte Netzteile, alte Elkos, unsaubere Spannung)
Wenn das System den Speicher erkennt, ist das zwar gut und schön, aber kein Garant, dass der Speicher Zelle für Zelle in Ordnung ist.
Mehr fällt mir gerade auch nicht ein.
Viel Erfolg bei der Fehlersuche!

Hi ylf,

hier ein neues Video wo man sehr gut alles Töne während des Bootens hört :)
http://www.liquidplace.com/imac/iMac_Boot_Sound.mp4
 

oneOeight

Aktives Mitglied
Registriert
23.11.2004
Beiträge
57.679
Vielleicht ein Fall für das Recapping?
Schon mal rein geguckt, wie die Kondensatoren aussehen?
 

JeanLuc7

Aktives Mitglied
Registriert
04.04.2005
Beiträge
5.269
Das ist ganz klar die Festplatte. Die Beeps vom RAM kämen vor dem Einschaltgong - und der wäre dann gar nicht zu hören. Bau die Platte aus und rüste auf SSD um - es gibt PATA-auf-SATA-Adapter, mit denen das möglich ist.
 

JeanLuc7

Aktives Mitglied
Registriert
04.04.2005
Beiträge
5.269
Kondensatoren können mit den Jahren auslaufen, speziell wenn die Geräte länger nicht in Betrieb waren
Nein, jedenfalls nicht generell. Es gab dieses Problem, als die asiatischen Hersteller sich von US-Chemikalien unabhängig machen wollten - die Kondensatoren der ersten Jahre alterten, und das Elektrolyt lief aus. Aber ich habe hier 40-50 Jahre alte Elkos, die noch weitgehend dieselbe Kapazität haben wie damals. Und ab ca 2010 hatten auch die Asiaten das Problem im Griff. Mit In-Betrieb oder Nicht-in-Betrieb hat das zudem gar nichts zu tun.
 

ylf

Aktives Mitglied
Registriert
30.09.2006
Beiträge
1.385
Ich würde auch sagen, soweit man das per Video beurteilen kann, das ist die Festplatte.

(Es ist ja auch kein Beep-Ton, sondern ein Summen. Ein Beep müßte aus den Lautsprechern kommen, denke ich mal. Man hört ja genau, wie die Platte hochdreht, die Scheiben auf Nenndrehzahl gebracht werden und in dem Moment, wo die Schreibleseköpfe von ihrer Parkposition losfahren und den Bootblock lesen wollen, summt es. Er will etwas lesen und es klappt nicht so richtig, der Vorgang wird mehrfach wiederholt --> Summen. Irgend wann klappt es dann doch.)

Es gibt auch PATA SSDs, sind aber nicht billig. Alternativ gibt es auch IDE-mSATA Konverter. z.B. von Delock (reichelt Link) Das passt dann mechanisch besser ggf.
 

Macothan

Mitglied
Registriert
09.03.2009
Beiträge
394
Hallo,

ich habe selbst jahrelang einen iMac USB 2.0/PowerMac6.3 besessen und denke beim Lesen dieses Threads wehmütig an dieses schöne Gerät zurück. Ich schließe mich der Ansicht meiner Vor-Poster an und halte ebenso einen Defekt der Harddisk für wahrscheinlich. Pufferbatterie schließe ich ebenfalls aus.
Die "D" Taste hatte ich während des kompletten Bootvorgangs gedrückt ... mhmmmm. ODer mach ich da was falsch? ;-)
...die Anleitung, die auf der DVD steht, lautet "Wahl" Taste...Übrigens ist meiner Erinnerung nach nur der ausführliche Test aussagekräftig, aber es hört und sieht m.E. nicht nach RAM-Fehler aus - ein Riegel ist ja bekanntermaßen nur nach Öffnen des Gerätes zugänglich.
Wenn ich es noch richtig weiß läuft der Lüfter in diesem Modell grundsätzlich immer und ist abhänig der internen Temperatur in der Drehzahl geregelt.
Kann ich bestätigen.

Hier noch wichtige Literatur zu diesem Gerät (zu meiner Überraschung immer noch im Netz zu finden). Viel Erfolg bei der Wiederinbetriebnahme (und nicht überrestaurieren..:i;):- Spaß, muss natürlich jeder selbst entscheiden)

Gruß Macothan
 
Oben