HP auf ibook mit .htaccess-was mach ich falsch???

Dieses Thema im Forum "Web Page Design" wurde erstellt von basti2701, 21.05.2004.

  1. basti2701

    basti2701 Thread Starter Banned

    Beiträge:
    867
    Zustimmungen:
    0
    MacUser seit:
    03.11.2003
    Dieses Zitat habe ich von folgender Seite:

    http://selfhtml.teamone.de/diverses/htaccess.htm#verzeichnisschutz

    Und zwar habe ich eine kleine Homepage auf meinem iBook am laufen. Ich möchte nun aber den Download-Bereich mit .htaccess schützen.
    Wie auf der oben genannten Seite angegeben, habe ich die .htusers Datei gebastelt und auch die .htaccess. Aber irgendwie will er den Bereich nicht schützen!?

    .htaccess-datei:

    # .htaccess-Datei fuer yxz/downloads
    AuthType Basic
    AuthName "Download-Bereich"
    AuthUserFile /Benutzer/basti/Dokumente/privat/xyz.htusers
    <Files downloads.html>
    require user xxxx xxxx
    </Files>

    Die Datei ist auch unter /webserver/documents abgespeichert. Und zwar so:
    xyz.htaccess. Ist das überhaupt so zulässig?

    .htusers-datei:

    # Benutzerdatei fuer Web-Projekt
    xxxx:xxxx
    xxxx:xxxx

    Die Datei ist, wie oben zu sehen in meinem Privatordner "versteckt"!

    Was mache ich falsch? Oder muss ich wirklich am Apache rumspielen?

    Über antworten würde ich mich sehr freuen, denn erst, wenn der Bereich geschützt ist, kann ich die Seite einer größeren Gemeinschaft zeigen.

    basti2701
     
    Zuletzt von einem Moderator bearbeitet: 24.10.2015
  2. Tjo, da musst du mal ne Runde mit der httpd.conf schnacken ;)

    Als Root anmelden, die versteckte Datei httpd.conf suchen und dann


    <Directory />
    Options FollowSymLinks
    Options All
    AllowOverride All
    </Directory>


    eintragen.


    Danach im Terminal


    sudo apachectl restart


    So, wie der Apache standardmäßig konfiguriert ist, erlaubt er deiner htaccess nicht, zu funktionieren.


    Rock On


    Yves
     
  3. HAL

    HAL

    Scheint so, als wenn Du wirklich mal einen Blick auf die
    Apache-Config werfen musst, von Haus aus schaut der
    entsprechende Absatz so aus:

    #
    # This controls which options the .htaccess files in directories can
    # override. Can also be "All", or any combination of "Options", "FileInfo",
    # "AuthConfig", and "Limit"
    #

    AllowOverride None


    Das bedeutet, das ohne den expliziten Aufruf einer Datei (z.b. index.html)
    kein Zugriff auf einen Ordner möglich ist. Der Browser wirft in dem Fall einen
    403 Error (keine Zugriffsrechte) aus.

    Wenn Du dagegen

    AllowOverride All

    verwendest, kannst Du a) jedes Unterverzeichnis deines Servers einsehen
    und b) dein .htaccess sollte funktionieren.
     
  4. remember HAL…


    Mit der gleichen Weisheit habe ich ihn mal Nachts gegen 2 vor totaler Resignation mit anschließendem Amoklauf im KDW gerettet ;)
     
  5. basti2701

    basti2701 Thread Starter Banned

    Beiträge:
    867
    Zustimmungen:
    0
    MacUser seit:
    03.11.2003
    Cool, dass sich noch jemand meldet.

    Aber wie schaue ich jetzt in die apache-config!?

    Kannst du mir das nicht mal ganz kurz idiotensicher erklären? ich weiß, es gibt da so einen thread zu, aber der hat für mich schon zu viel information. ;-)
    Ich brauche ja wirklich nur diese eine Information.
     
  6. Ich dachte das war schon idiotensicher…


    Als ROOT anmelden, httpd.conf suchen,

    dann den ersten directory tag durch den, den ich dir o.g. habe ersetzen.

    Und dann den Apache restarten.


    Ansonsten poste mal deine httpd.conf, ich trag dir die Werte ein.
     
  7. basti2701

    basti2701 Thread Starter Banned

    Beiträge:
    867
    Zustimmungen:
    0
    MacUser seit:
    03.11.2003
    @yves

    oh sorry, deine erste antwort habe ich garnicht gesehen..

    lese ich mir jetzt noch mal in ruhe durch und schaue ob ich weiter komme damit
     
  8. Machte doche nixe, bastiano…

    Und wenn's nicht klappt, fragst du halt nochmal und wir machen das zusammen :)


    Liebe Grüße

    Yves
     
  9. basti2701

    basti2701 Thread Starter Banned

    Beiträge:
    867
    Zustimmungen:
    0
    MacUser seit:
    03.11.2003
    ich kann die datei nicht finden.

    siehe auch bild!?

    sorry, aber für mich ist das alles nicht trivial
     

    Anhänge:

    • root.jpg
      root.jpg
      Dateigröße:
      29,4 KB
      Aufrufe:
      27
  10. HAL

    HAL

    OK, dann den Weg über den Finder.

    gehe zu > gehe zum ordner > /etc/httpd/

    dort findest du die httpd.conf
     
Die Seite wird geladen...

Diese Seite empfehlen