macOS Big Sur 5 GBit Ethernet Adapter unter Big Sur lauffähig?

mailtopp

Mitglied
Thread Starter
Mitglied seit
17.09.2003
Beiträge
755
Hi zusammen,

hat es jemand von euch schonmal geschafft, unter Big Sur einen 5 GBit USB-Ethernet Adapter zum laufen zu bekommen? Mit Catalina hat alles noch geklappt, aber seit dem Big Sur Update geht keiner mehr. Folgende waren vorher prinzipiell kompatibel:
  • QNAP QNA-UC5G1T USB A/C (Gen1)
  • Sonnet Solo5G USB A/C
  • TRENDnet TUC-ET5G USB C (Gen2)
  • StarTech.com US5GC30 USB C (Gen1)
Alle basieren auf dem gleichen Chip "Marvell AQtion AQC111C", aber sowohl auf der Marvel Webseite noch auf der Sonnet Webseite gibt es einen Treiber, der unter Big Sur funktioniert. Sonnet behauptet auf der Webseite, Big Sur kompatibel zu sein, aber ich kann das nicht bestätigen. Im Systembericht taucht der Treiber immer auf, aber immer mit "Geladen = Nein" (siehe Screenshot) und dann hab ich nur 100 MBit, keine 5G. Ich hab auch schon SIP ausgeschaltet, aber das hat auch nichts geholfen.

So sieht es aus, wenn ich den Treiber von Sonnet manuell laden möchte:

Code:
sh-3.2# kextload /Library/Extensions/pacific.kext/
Executing: /usr/bin/kmutil load -p /Library/Extensions/pacific.kext
Error Domain=KMErrorDomain Code=71 "Kernel request failed: (libkern/kext) not loadable (reason unspecified) (-603946989)" UserInfo={NSLocalizedDescription=Kernel request failed: (libkern/kext) not loadable (reason unspecified) (-603946989)}
Hat jemand einen Tipp oder einen anderen Adapter mit mindestens 5GBit zum laufen gebracht?

Dankeschön!
 

Anhänge

Schlapotnik

Registriert
Mitglied seit
30.12.2020
Beiträge
4
Moin, ich habe das Problem auch... im Apple Developer Forum gibt es eine ausführliche Beschreibung dazu. Ich habe Sonnet dazu angeschrieben, aber noch keine Antwort...
 

mailtopp

Mitglied
Thread Starter
Mitglied seit
17.09.2003
Beiträge
755
Ich hab mit Sonnet schon Kontakt, und hab auch schon einiges an Debug Material hingeschickt, aber so richtig vorwärts kommen wir da auch nicht. Wär super, wenn wir hier in Kontakt bleiben.
Hast du einen Link zu dem Apple Developer Forum Post?
 

mailtopp

Mitglied
Thread Starter
Mitglied seit
17.09.2003
Beiträge
755
Update: Bei mir klappts jetzt aus irgendeinem Grund auf einmal... keine Ahnung warum. Aber quasi zeitgleich habe ich dieses github Projekt gefunden. Ich würd mal folgendes Probieren:

- SIP Protection am Mac ausschalten
- Droplet runterladen: (https://github.com/chris1111/Kext-Droplet-Big-Sur)
- aktuellsten Sonnet Treiber runterladen: (http://www.sonnettech.com/support/kb/kb.php?cat=562&expand=&action=a3#a3)
- Sonnet Treiber installieren, um in /Library/Extensions an die pacific.kext zu kommen
-> An den Punkt gings bei mir seltsamer weise schon, falls es noch nicht geht:
- Droplet nutzen und das pacific.kext nochmal da rein ziehen, im Gatekepper "erlauben" und neu starten

Klappts damit?
 

mailtopp

Mitglied
Thread Starter
Mitglied seit
17.09.2003
Beiträge
755
Noch ein Update von meiner Seite:
  • also sowohl mein QNAP QNA-UC5G1T als auch mein Sonnet SOLO5 funktionieren jetzt prinzipiell mit dem gleichen Treiber und die Schnittstelle konfiguriert sich auf 5G-BASE-T
  • ich hab jetzt sowohl den pacific.kext von Sonnet probiert, als auch den direkt von Marvel (https://www.marvell.com/support/downloads.html), bei beiden gehts jetzt
  • Download von meinem NAS über smb share geht so mit ca. 240 MB / sec, was ganz ordentlich ist
  • Problem aber: Upload geht quasi gar nicht... er fängt gar nicht erst so richtig an und der Mac hat sich auch schon 2-3 mal hart aufgehängt
Kannst du das bestätigen nach meiner Anleitung oben?

Mit dem Treiber gibts scheinbar noch Probleme, aber ohne Marvell wird auch Sonnet an der Stelle nichts tun können.
 

Schlapotnik

Registriert
Mitglied seit
30.12.2020
Beiträge
4
Moin, ich habe ähnliche Erfahrungen. Ich werde jetzt mal die 2,5 Gbit-Adapter mit dem Realtek-Chipset ausprobieren. Ich hatte mit dem Pacific/Sonnet schlechtere Ergebnisse als über 1Gbit. Die Thunderbolt-Adapter laufen mit bis zu 9,8 GBit (iPerf3). Die Solo PCI Karte im Gehäuse läuft auch super...

Grüße
 

Schlapotnik

Registriert
Mitglied seit
30.12.2020
Beiträge
4
Moin, genau ich habe den Sabrent 2,5 Gbit (NT-S25G) und erreiche ca. 280 Mbyte/sec (2,35 gbit/sec) über iperf gemessen. Ich habe kaum Unterschiede bei Up- oder Download.
 

mailtopp

Mitglied
Thread Starter
Mitglied seit
17.09.2003
Beiträge
755
Ich hab den Delock 65990 mal bestellt, sobald der da ist, geb ich Bescheid
 

steve it

Mitglied
Mitglied seit
26.05.2009
Beiträge
842
Wenn Realtek, dann bitte den mit „b“: RTL8156B
Vom 8156 ohne b sollte man imho die Finger lassen.
Funktioniert übrigens ohne extra Treiber.
 

mailtopp

Mitglied
Thread Starter
Mitglied seit
17.09.2003
Beiträge
755
Danke für den Hinweis,.. ich finde mit dem Chip nur so einen billigen weißen China-Adapter. Gibts da noch andere USB/Thunderbolt Adapter mit dem Chip?
 

steve it

Mitglied
Mitglied seit
26.05.2009
Beiträge
842

mailtopp

Mitglied
Thread Starter
Mitglied seit
17.09.2003
Beiträge
755
Der Post ist aber schon 6 Monate alt, als mittlerweile scheint es Adapter zu geben, die den Chip drin haben. Den CSL werd ich jetzt mal testen parallel zu dem Delock
 

mailtopp

Mitglied
Thread Starter
Mitglied seit
17.09.2003
Beiträge
755
Also ich hab jetzt vier verschiedene Adapter ausprobiert mit RTL8156, RTL8156B und ACQ111..

- Aquantia ACQ111 (5 GBit): Mit dem Sonnet Solo 5G Treiber und SIP protection disabled hab ich ihn zum laufen bekommen. Download > 400MB/sec, aber Upload geht gar nicht. => Unbrauchbar leider
- RTL8156, RTL8156B (2,5 GBit): Hier geht Upload und Download zuverlässig, und ich erreiche auch > 200 MB/sec, aber alle 1-2 Tage hat sich der iMac hart ausgeschaltet und immer wieder gabs Fallbacks auf 1GBit. Nur ein/ausstecken hat das Problem gelöst -> Besser aber auch nicht tauglich

Also hab ich ein bisschen tiefer in die Tasche gegriffen und einen Sonnet Solo 10G mit Aquantia ACQ107 chip drin. Das ist glücklicherweise der gleiche Chip, den der iMac Pro nativ verwendet und Apple bringt den Treiber nativ in Big Sur mit
=> Funktioniert perfekt ohne Einschränkungen. Direkt Plug an play, 10Gbit möglich, MTU9000 möglich.

Also Zusammenfassung: Entweder man lebt mit instabilen Einschränkungen oder man gibt knapp 200€ aus.. mit den aktuell verfügbaren Treibern machen die günstigen Lösungen keinen Spaß. Vielleicht tut sich ja noch was.
 

Zappermaster

Neues Mitglied
Mitglied seit
21.01.2021
Beiträge
5
Vielen Dank für die schnelle Rückmeldung.
D.h. Es gab keinen Unterschied zwischen CSL(RTL8156B) und DELOCK (RTL8156) weil der selbe Treiber verwendet wird vermute ich?
 

mailtopp

Mitglied
Thread Starter
Mitglied seit
17.09.2003
Beiträge
755
Da konnte ich keinen Unterschied feststellen, ich hab den CSL behalten, der jetzt aber überflüssig geworden ist, weil ich den SOLO 10G behalte. Magst du den CSL zufällig haben? Ich würd ihn jetzt verkaufen.
 

Zappermaster

Neues Mitglied
Mitglied seit
21.01.2021
Beiträge
5
Versteh. Danke. Leider brauch Ichs für die Firma mit Rechnung aufs Unternehmen. Vll findet sich hier ja jemand der Interesse hat...
 
Oben