Email-Faxbenachrichtigung (mal wieder, aber anders)

Diskutiere mit über: Email-Faxbenachrichtigung (mal wieder, aber anders) im Mac OS X Forum

  1. klanor

    klanor Thread Starter MacUser Mitglied

    Beiträge:
    13
    Zustimmungen:
    0
    Registriert seit:
    10.07.2005
    Moin zusammen,

    ich erlaube mir mal, hier eine etwas umfangreichere Schilderung dieser (bisher ungelösten) Problematik bei meinem Mac mini.

    Es fing damit an, dass ich den mini hauptsächlich als lokalen Server für Websites, als Printserver und als Faxgerät und Browsertester einsetzen wollte. Das läuft auch soweit recht zufriedenstellend, aber dann habe ich gesehen, dass man eben diese Fax-Email-Benachrichtigung hat, und weil ich am Mac selbst nicht arbeite und daher immer nachschauen muss, ob Faxe eingetroffen sind, wollte ich diese Benachrichtigung aktivieren.

    Als das nicht funktionierte, versuchte ich, herauszubekommen, was da nicht klappt und bin über postfix und xinetd gestolpert. Da aber meine Unix-Kenntnisse nur ausgesprochen marginal sind, konnte ich daraus gewonnene Erkenntnisse, wie auch die Mail-Log-Meldungen nicht wirklich in sinnvolle Aktionen umsetzen.

    Mit dem FaxEmailHelper hatte ich dann die Hoffnung, dass sich das Problem lösen ließe, da andere mit dem gleichen Problem anscheinend gute Erfolge erzielen. Allein bei mir änderte sich nichts.
    Um auszuschließen, dass es nicht am dort eingetragenen SMTP-Server, bzw. einer "Blockade" desselben durch meinen Online-Provider liegt, habe ich verschiedene Server ausprobiert (ich habe da mehrere zur Verfügung), aber auch das führte zu keiner Verbesserung.
    Im Mail-Log habe ich dann Einträge dieser Art:
    Mar 3 16:08:43 MacKlaus postfix/smtp[23407]: 01C8D118794: to=<faxeingang@[mein_zielserver].de>, relay=none, delay=265358, status=deferred (Host or domain name not found. Name service error for name=mail.[mein_smtp_server].de type=MX: Host not found, try again)
    Mar 3 16:08:43 MacKlaus postfix/smtp[23408]: warning: 02A81118698: defer service failure

    Was da passiert ist mir ja klar. OSX kann mit dem Namen nichts anfangen.
    Aber warum? Wenn ich surfe, werden die Namen prima aufgelöst. Wenn ich mit Mail etwas verschicke, ebenfalls.
    Mein Router, über den ich online bin, filtert oder sperrt nichts; es muss da wohl irgendwas in den Einstellungen meim Mac nicht stimmen. Nur bin ich wohl nicht schlau und / oder wissend genug, das herauszufinden.
    Zu dem ganzen Zirkus kommt jetzt auch noch, dass in den Systemeinstellungen der Bereich "Drucken & Faxen" nicht mehr aufgerufen werden kann.

    Normalerweise bin ich ja weder dumm noch ungeschickt, aber mit diesen Problemen komme ich beim Mac nun irgendwie gar nicht zurecht.

    Wenn sich jemand meiner erbarmen könnte, wäre ich heilfroh. Nicht nur, weil das Problem dann vielleicht gelöst werden kann, sondern auch, weil ich dann vielleicht endlich verstehe, was da vorgeht.
     
  2. nicolas-eric

    nicolas-eric MacUser Mitglied

    Beiträge:
    7.729
    Zustimmungen:
    10
    Registriert seit:
    30.05.2005
    mit dem faxmailhelper kann ich auch nur mails über einen externen mailserver versenden. der osx eigene will igrendwie nicht...
     
  3. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    Registriert seit:
    24.09.2003
    Mit OS hat das gar nichts zu tun und mit dem Postfix Mailserver, der auf Deinem Rechner läuft in diesem Fall auch nicht. Der versucht nämlich die Mail ganz ordnungsgemäß zuzustellen.
    Der Mailserver, an den er die Mail senden willst, nimmt die Mail allerdings nicht an, weil er den Namen Deines Rechner überprüft und die übermittelte DNS-Information nicht auflösen kann.

    Das kann man lösen, indem man ein wenig "lügt". Der Preis dafür ist, dass man keine Mailer-Daemon Nachrichten erhalten kann, wenn was fehlschlägt :D.

    Frage: Hast Du einen DynDNS Account?
    Falls ja, wie heisst der?
     
  4. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    Registriert seit:
    24.09.2003
    Folgendes sollte eigentlich klappen:
    Code:
    sudo postconf -e "myorigin = mail.gmx.net"
    sudo postfix reload
    Der Reload ist eigentlich nicht zwingen, da der Postfix nach kurzer Zeit die Änderung auch so übernimmt.
    Wenn Du eine DynDNS Domain hast, kannst Du statt "mail.gmx.net" diese verwenden. Damit vermeidest Du möglicherweise Probleme, wenn Du mails an gmx-Adressen senden möchtest.
    Im Detail musst Du das aber selbst testen :).
    [edit]Habe gerade gemerkt, dass gmx ohnhin keine Mails von Mailservern mit dynamischer IP annimmt. Wenn man also an gmx Adressen senden möchte, muss man wieder andere Tricks anwenden :)"[/edit]

    HTH
     
    Zuletzt bearbeitet: 05.03.2006
  5. klanor

    klanor Thread Starter MacUser Mitglied

    Beiträge:
    13
    Zustimmungen:
    0
    Registriert seit:
    10.07.2005
    Hallo maceis,

    erstmal vielen Dank für Deine schnelle Antwort. Allerdings hat's bei meinem Mac nicht geholfen.
    myorigin habe ich auf den Namen meines Mailservers gesetzt. reload wurde als unbekannter Parameter gemeldet, daher habe ich sicherheitshalber mal neu gestartet. Aber es gehen noch immer keine Mails raus.

    Den bereits bekannten Meldungen im Log, die logischerweise immer noch auftreten, gehen übrigens diese voran:

    Mar 4 23:56:21 MacKlaus postfix/master[361]: daemon started -- version 2.1.5
    Mar 4 23:56:22 MacKlaus postfix/pickup[362]: 84B0911BB4B: uid=0 from=<faxeingang@xxxxxxxxxxxxxx.de>
    Mar 4 23:56:22 MacKlaus postfix/cleanup[363]: 84B0911BB4B: message-id=<20060304225621.84B0911BB4B@MacKlaus.local>
    Mar 4 23:56:23 MacKlaus postfix/qmgr[365]: 01C8D118794: from=<faxeingang@xxxxxxxxxxxxxx.de>, size=62874, nrcpt=1 (queue active)
    .
    .
    .
    Mar 4 23:56:25 MacKlaus postfix/qmgr[365]: B19C81182D0: from=<faxeingang@xxxxxxxxxxxxxx.de>, size=131080, nrcpt=1 (queue active)
    Mar 4 23:56:25 MacKlaus postfix/qmgr[365]: B529411AB17: from=<faxeingang@xxxxxxxxxxxxxx.de>, size=61348, nrcpt=1 (queue active)
    Mar 4 23:56:25 MacKlaus postfix/qmgr[365]: BE2EE118401: from=<faxeingang@xxxxxxxxxxxxxx.de>, size=66310, nrcpt=1 (queue active)
    .
    .
    .
    Mar 4 23:57:21 MacKlaus postfix/master[361]: master exit time has arrived


    Die qmgr-Einträge, es sind etwa 100, sind wohl (korrigiere mich, wenn ich da falsch liege) Versandaufträge, die in der Warteschlage (Queue) liegen und darauf warten, dass man sie rauslässt.

    Ich habe postconf auch einfach mal ohne Parameter aufgerufen und bekomme eine Ausgabe der aktuellen Einstellungen. Das sind ca. 400 Werte...
    Allerdings schaue ich da wie ein Schwein ins Uhrwerk. Würde es helfen, wenn ich die mal als Textdatei ins Netz stelle?

    DynDNS habe ich nicht. Ich weiß auch nicht, ob mein Router da mitspielen würde, aber die von Dir vorgeschlagene Lösung wäre darauf ja nicht angewiesen?!
     
  6. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    Registriert seit:
    24.09.2003
    Das mit dem reload war ein Verschreiber von mir, sorry.
    Ich habs oben korrigiert: muss heissen "sudo postfix reload"

    Um alle Nachrichten aus der Queue zu löschen, gibt es folgendes Kommando: "sudo postsuper -d ALL". Ansonsten wird standardmäßig vier Tage lang versucht, die Nachrichten zu versenden.

    "postconf -n" gibt alle Werte aus, die nicht den Standardeinstellungen entsprechen. Da ist die Liste schon mal deutlich kürzer.
    Im Augenblick würde mich aber nur mal
    "postconf myorigin"
    interessieren und die aktuelle Meldung im logfile beim Versenden einer Mail.
     
  7. klanor

    klanor Thread Starter MacUser Mitglied

    Beiträge:
    13
    Zustimmungen:
    0
    Registriert seit:
    10.07.2005
    Prima. postfix reload geht.
    Das Löschen mit postsuper -d ALL war ein hervorragender Tipp, weil die Liste mittlerweile doch verdammt lang geworden ist.

    Ich habe hier mal die vollständige Ausgabe von postconf -n:

    MacKlaus:~ root# postconf -n
    command_directory = /usr/sbin
    config_directory = /etc/postfix
    daemon_directory = /usr/libexec/postfix
    debug_peer_level = 2
    html_directory = no
    inet_interfaces = localhost
    mail_owner = postfix
    mailbox_size_limit = 0
    mailq_path = /usr/bin/mailq
    manpage_directory = /usr/share/man
    mydomain = MacKlaus.local
    mydomain_fallback = localhost
    mynetworks_style = host
    myorigin = mail.klausnordmann.de
    newaliases_path = /usr/bin/newaliases
    queue_directory = /private/var/spool/postfix
    readme_directory = /usr/share/doc/postfix
    relayhost = mail.klausnordmann.de
    sample_directory = /usr/share/doc/postfix/examples
    sendmail_path = /usr/sbin/sendmail
    setgid_group = postdrop
    smtp_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/etc/postfix/saslpasswd
    smtp_sasl_security_options = noanonymous
    smtpd_tls_key_file =
    unknown_local_recipient_reject_code = 550


    Im Logfile sieht's nach einer Faxeingang-Simulation durch den Helper so aus:

    Mar 5 14:37:19 MacKlaus postfix/master[1024]: daemon started -- version 2.1.5
    Mar 5 14:37:21 MacKlaus postfix/pickup[1029]: 1A0B911BDD9: uid=0 from=<faxeingang@klausnordmann.de>
    Mar 5 14:37:21 MacKlaus postfix/cleanup[1030]: 1A0B911BDD9: message-id=<20060305133718.1A0B911BDD9@MacKlaus.local>
    Mar 5 14:37:21 MacKlaus postfix/qmgr[1032]: 1A0B911BDD9: from=<faxeingang@klausnordmann.de>, size=50577, nrcpt=1 (queue active)
    Mar 5 14:38:18 MacKlaus postfix/master[1024]: master exit time has arrived
    Mar 5 14:38:37 MacKlaus postfix/smtp[1033]: warning: 1A0B911BDD9: defer service failure
    Mar 5 14:38:37 MacKlaus postfix/smtp[1033]: 1A0B911BDD9: to=<faxeingang@nordmann-net.de>, relay=none, delay=79, status=deferred (Host or domain name not found. Name service error for name=mail.klausnordmann.de type=MX: Host not found, try again)


    Meinen Domainnamen habe ich jetzt nicht wegge-xxxxx-t. Ist ja nicht wirklich ein Geheimnis...
     
  8. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    Registriert seit:
    24.09.2003
    nimm:
    Code:
    sudo postsuper -d ALL
    sudo postconf "myorigin=klausnordmann.de"
    sudo postfix reload
    Und dann eine Mail versenden.
    Ich hab Deinen MX damit erreicht.
     
  9. klanor

    klanor Thread Starter MacUser Mitglied

    Beiträge:
    13
    Zustimmungen:
    0
    Registriert seit:
    10.07.2005
    Das habe ich gemacht.
    Bisher hatte ich den reload immer gemacht, bevor der Daemon beendet wurde; jetzt kam eine Fehlermeldung, der Dienst sei nicht aktiv. Also habe ich postfix start vorher ausgeführt.
    In jedem Fall hatte ich aber die Einstellungen überprüft, bevor ich ein Fax durch den Helper simulierte.
    Jetzt steht myorigin auf klausnordmann.de (statt mail.klausnordmann.de), aber geändert hat sich überhaupt nichts.
    Den MX (Mailserver bei meinem Hoster?) erreiche ich ja ebenfalls, wenn ich eine Mail an die Adresse schicke. Nur der Mac mit seiner Email-Benachrichtigung kommt irgendwie nicht raus.

    Verflixte Angelegenheit...
     
  10. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    Registriert seit:
    24.09.2003
    Mal kurz zur Erklärung.
    Der MX Server (Mail eXchanger) ist der für eine Domain zuständige Posteingangsserver, der über das DNS abgefragt werden kann und der von anderen Mailserver zur Zustellung verwendet werden kann.
    Das ist oft nicht derselbe Server, der den Benutzern als Mailserver für POP, IMAP und SMTP zur Verfügung gestellt wird.
    Abfragen, welcher MX für eine Doamin zustaändig ist, kann man im Terminal mit dem Kommando "nslookup".
    Code:
    nslookup -type=MX klausnordmann.de
    Server:         192.168.100.10
    Address:        192.168.100.10#53
    
    Non-authoritative answer:
    klausnordmann.de        mail exchanger = 50 [b]mx0.klausnordmann.de.[/b]
    
    Authoritative answers can be found from:
    klausnordmann.de        nameserver = c1.wpns.hosteurope.de.
    klausnordmann.de        nameserver = c1.wsns.hosteurope.de.
    mx0.klausnordmann.de    internet address = 80.237.128.199
    Das selbe machen viel Mailserver auch, bevor Sie Mail annehmen.
    Das war auch das Problem als Du myorigin auf mail.klausnordmann.de gesetzt hattest.
    Code:
    nslookup -type=MX mail.klausnordmann.de
    ...
    Non-authoritative answer:
    *** Can't find mail.klausnordmann.de: No answer
    ...
    Das führte dann zu dem Logeintrag
    Warum es jetzt bei Dir nicht geht, weiss ich nicht. (Meine Mail ist angekommen?)
    Was steht im Log?
     
Die Seite wird geladen...
Ähnliche Themen - Email Faxbenachrichtigung (mal Forum Datum
Anmeldeskript / Finder fragt jeders mal nach Kennwort Mac OS X 27.10.2016
Unlesbare Zeichen bei Email versand Mac OS X 07.09.2016
In Time Machine nach eMail suchen geht nicht Mac OS X 31.08.2016
Öffentliche Beta ein 2. Mal laden/installieren Mac OS X 24.08.2016
Dateien aus Email drucken Mac OS X 22.08.2016

Diese Seite empfehlen

Benutzerdefinierte Suche