XAMPP - Problem

123

Aktives Mitglied
Thread Starter
Registriert
08.12.2008
Beiträge
1.888
Hallo,

ich versuche gerade XAMPP zum laufen zu bringen.
Wenn ich aber versuche den "Apache Web Server" (innerhalb der XAMPP-App) zu starten, dann startet er nicht. Die Anzeige in der GIU wechselt von rot auch gelb und nach ein paar Sekunden wieder auf rot.

Was mir aber auffällt ist, wenn ich XAMPP deinstalliere und http://localhost/ eingebe, dann kommt "Der Web-Dienst ist deaktiviert.
Ein Administrator kann ihn mit der Server-App aktivieren."

Hat das vllt. was mit der Server-App von Apple zu tuen welche ich noch installiert habe? Ich habe eig. alle Funktionen dort deaktiviert.

Kann mir da jemand von euch helfen?
 

falkgottschalk

Aktives Mitglied
Registriert
22.08.2005
Beiträge
24.083
Die Server-App von Apple hat mit Apache nichts zu tun.
Steht irgendwie eine verwertbare Fehlermeldung?
 

Mel Linus

Mitglied
Registriert
17.11.2009
Beiträge
183
Hallo,

in deinem XAMPP Verzeichnis gibt es ein logs Ordner mit einem entsprechenden error_log. Evtl. steht da was drin, warum Apache nicht läuft bzw. sich sofort wieder beendet.
 

beage

Aktives Mitglied
Registriert
18.01.2012
Beiträge
2.060
Hast Du evtl. Skype über Port 80 laufen? Schalt mal Skype ab und starte den Webserver nochmal.
 

123

Aktives Mitglied
Thread Starter
Registriert
08.12.2008
Beiträge
1.888
Skype ist aus. Habe ich anderswo schon gelesen, das es da zu konflikten kommen kann.

Die letzte Fehlermeldung in der error_log ist: "no listening sockets available, shutting down".

Davor steht : "Address already in use: xxx: make_sock: could not bind to address [::]:80"
Address already in use: xxx: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
xxx: Unable to open logs

xxx habe ich mal ersetzt, das stand noch ne Nummer.
 

beage

Aktives Mitglied
Registriert
18.01.2012
Beiträge
2.060
Dann läuft was Anderes auf Port 80, so wie die Fehlermeldung es sagt
 

beage

Aktives Mitglied
Registriert
18.01.2012
Beiträge
2.060
Such mal bei google nach could not bind to address 0.0.0.0:80. da findest du mehrere lösungsvorschläge
 

123

Aktives Mitglied
Thread Starter
Registriert
08.12.2008
Beiträge
1.888
Also irgendwie bekomme ichs nicht hin.
 

123

Aktives Mitglied
Thread Starter
Registriert
08.12.2008
Beiträge
1.888
Ich finde nicht mal raus, welches Programm den Port 80 blockiert.
Die Anleitung aus dem gepusteten Link funktioniert bei mir nicht, da muss ich zig Programme noch nachinstallieren.
Kann ich das nicht mit netstat oder mit top herausfinden? Ich finde nur nicht die passende Option in der man um mit das Programm anzeigen zu lassen, welches den Port 80 blockiert.
 

123

Aktives Mitglied
Thread Starter
Registriert
08.12.2008
Beiträge
1.888
Ich habe den Übeltäter gefunden, es ist:
/Library/Server/Web/Config/apache2/xxx_server_app.conf

Wenn ich das in google eingebe, dann kommt was mit der Mountain Lion Server-App. Wie kann ich den vollständig deaktivieren? Den brauche ich zur Zeit nämlich nicht.

Kurze anleitung für diejenigen die durch die Forumsuche/Suchmaschine auf diese Diskussion gestoßen sind.
Mit "lsof -i -P | grep :80" bekommt ihr die PIDs der Prozesse (zweite Spalte), welche den Port 80 blockieren.
Mit ps -axl könnt ihr dann schauen zu welchem Prozessen die PIDs gehören.
Die Befehle habe ich als sudo bzw. root ausgefüht. Wenn ihr nicht das erwartete Ergebnis bekommt versuchts damit.
 

123

Aktives Mitglied
Thread Starter
Registriert
08.12.2008
Beiträge
1.888
Ich finde den /Library/Server/ nur im Terminal. Wie kann ich mir den auch im Finder anzeigen lassen.
chflags nohidden ./Library hat nicht funktioniert (war natürlich im /Library Verzeichnis).

Wenn ich bei XAMPP den Port auf 8080 ändere, dann funktionierts übrigens auch nicht, obwohl der Port frei sin sollte. Allerdings schreibt er dann gar nichts mehr in die Fehlerlogdatei.
Aber das resultat ist das selbe wie bei Port 80 (bei Port 80 bekomme ich jetzt übrigens auch von XAMPP die Warnung, das der Port belegt ist, bei Port 8080 nicht).
 

falkgottschalk

Aktives Mitglied
Registriert
22.08.2005
Beiträge
24.083
Ich finde den /Library/Server/ nur im Terminal. Wie kann ich mir den auch im Finder anzeigen lassen.
chflags nohidden ./Library hat nicht funktioniert (war natürlich im /Library Verzeichnis).
Lasse da mal den Punkt weg.
Und immer dran denken es gibt 2 Library-Ordner.
 

123

Aktives Mitglied
Thread Starter
Registriert
08.12.2008
Beiträge
1.888
Lasse da mal den Punkt weg.
Und immer dran denken es gibt 2 Library-Ordner.

Wuste ich nicht mal, das es zwei Library-Ordner gibt xD

Ich habs jetzt deinstalliert, und jetzt gehts. Also der Apache Web Server funktioniert. Ich habe jetz auch überall grüne "Statuslämpchen" in XAMPP.

Leider habe ich jetzt mit phpmyadmin ein neues Problem.
Wenn ich http://localhost/phpmyadmin eingebe, bekomme ich folgende Fehlermeldung:
"phpMyAdmin - Error
Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly. Also ensure that cookies are enabled in your browser."

Cookies habe ich auf jeden Fall aktivert.
Jetzt bin ich gerade dabei dir Log-Datei zu suchen. Ist das die selbe wie vorhon von XAMPP oder hat phpmyadmin eine eigene error-log Datei?
 

falkgottschalk

Aktives Mitglied
Registriert
22.08.2005
Beiträge
24.083
apache,
mysql
und php
haben nach meinem Kenntnisstand jeweils ein eigenes Logfile.

Bevor Du lange rumfummelst - hast Du XAMP einfach mal drübergebügelt nachdem Du den in Deinem Fall nutzlosen ML-Server entsorgt hast?
Normalerweise läuft eine XAMP-Intallation völlig problemlos "out of the box", also ohne Gefummel irgendwo. :)
 

Ähnliche Themen

Oben