X11 startet nicht mehr

Dieses Thema im Forum "Mac OS - Unix & Terminal" wurde erstellt von Itekei, 01.01.2004.

  1. Itekei

    Itekei Thread Starter MacUser Mitglied

    Beiträge:
    4.990
    Zustimmungen:
    111
    Mitglied seit:
    11.11.2003
    Ich kann aus welchen Gründen auch immer mein X11 nicht mehr starten. Benutze da normalerweise Nicotine als P2P Lösung. Wenn ich in der Konsole nachschaue sehe ich Folgendes:

    dyld: /Applications/Utilities/X11.app/Contents/MacOS/X11 can't open library: /usr/X11R6/lib/libX11.6.dylib (No such file or directory, errno = 2)

    Wie kommt sowas und wie repariere ich das ? Danke für Eure Hilfe !

    Grüsse
    Itekei
     
  2. rupa108

    rupa108 MacUser Mitglied

    Beiträge:
    392
    Zustimmungen:
    1
    Mitglied seit:
    03.02.2003
    Hallo,

    starte doch mal Terminal und setze folgedes Kommando ab:

    cd /usr/X11R6/lib/

    dann:

    ls -l libX11.*

    das erzeugt bei mir folgende Ausgabe:

    -rw-r--r-- 1 root wheel 986820 11. May 2003 libX11.6.2.dylib
    lrwxr-xr-x 1 root wheel 16 19. Oct 15:15 libX11.6.dylib -> libX11.6.2.dylib
    -rw-r--r-- 1 root wheel 1607048 21. Dec 2002 libX11.a
    lrwxr-xr-x 1 root wheel 16 19. Oct 15:15 libX11.dylib -> libX11.6.2.dylib

    Ist das bei dir auch der Fall oder fehlt etwas?

    Wenn lediglich die zweite Zeile fehlt:

    ln -s libX11.6.2.dylib libX11.6.dylib


    Wenn alles fehlt, developper Tools neu installieren oder eventuell OSX nochmal drüberbügeln.

    Wenn nichts fehlt, probier doch mal:

    rm /tmp/.X0-lock

    Gruß Rupa
     
  3. Birke

    Birke MacUser Mitglied

    Beiträge:
    3.757
    Zustimmungen:
    131
    Mitglied seit:
    01.11.2007
    Mein X11 startet auch nicht mehr. :(

    Dabei habe ich lustiger Weise erst soeben die Dev Tools installiert.

    Wenn ich Deine beiden Terminalbefehle ausführe meint mein Terminal nur:

     
  4. aXon

    aXon MacUser Mitglied

    Beiträge:
    727
    Zustimmungen:
    37
    Mitglied seit:
    04.01.2004
    vielleicht hilft eine neuinstallation des X11 paketes? neueste versionen gibt es hier -> https://www.xquartz.org
     
  5. virus720

    virus720 MacUser Mitglied

    Beiträge:
    42
    Zustimmungen:
    1
    Mitglied seit:
    10.01.2008
    Hi,
    wenigstens bin ich nicht allein... total komisch habe OS X (Leo) neu aufgesetzt (x11 mit installiert), noch alle updates drübergebügelt und nun bemerke ich das bei mir X11 auch nicht mehr laufen will -> kann es an einem Leo update liegen das man X11 neuinstallieren muss?!
     
  6. aXon

    aXon MacUser Mitglied

    Beiträge:
    727
    Zustimmungen:
    37
    Mitglied seit:
    04.01.2004
    ja, das kann sein. das wird auch auf der seite von Xquartz angemerkt. dort steht, dass updates nicht immer mit den exakt neuesten X11 updates kommen und man so uU das neueste manuell installieren muss.
     
Die Seite wird geladen...
Ähnliche Themen - startet nicht mehr Forum Datum
Midnight Commander startet nicht Mac OS - Unix & Terminal 12.12.2013
Rechte verstellt, System startet nicht mehr Mac OS - Unix & Terminal 19.03.2012
Terminal startet nicht mehr richtig Mac OS - Unix & Terminal 23.03.2011
MySQL5 mittels macports installiert -> Server startet nicht Mac OS - Unix & Terminal 22.09.2008
PowerBook 12" startet nicht mehr Mac OS - Unix & Terminal 15.02.2007
apache2 startet nicht Mac OS - Unix & Terminal 23.02.2006
cronjob startet nicht Mac OS - Unix & Terminal 12.12.2005
GTKRadiant unter X11 startet nicht Mac OS - Unix & Terminal 26.06.2005
X11 startet nicht ?? Mac OS - Unix & Terminal 29.03.2005
fop startet nicht Mac OS - Unix & Terminal 06.05.2003