Windows 10 Bluetooth Treiber Mac Pro 1.1-3.1

Macschrauber

Aktives Mitglied
Thread Starter
Registriert
08.02.2014
Beiträge
7.833
Habe mir Windows 10 auf meinen Mac Pro 3.1 angetan.

Bluetooth wird nicht gefunden, das original CSR (Cambridge Silicon Radio, jetzt Qualcomm) Modul (Devide ID 0x8206) wird nicht gefunden.

Einen Treiber finde ich auch nicht bzw. traue den russischen Treiberseiten nicht ;-)

So eine Universal Treiber Software (Driver Booster) habe ich mal getestet und das hat mir meine Win Installation zerschossen, wie genau weiss ich nicht, hab das eh als Image vom 5.1er gehabt und wieder aufgespielt.

Ein Stick funktioniert, möchte aber schon das Original Modul (mit all seinen Nachteilen) lauffähig haben.

Bootcamp Utilities 6.1 vom iMac Pro 1.1 sind aufgespielt und funktionsfähig (APFS Bootenvolume auswählen funktioniert).

Bitte um sachdienliche Hinweise ;-)
 

Macschrauber

Aktives Mitglied
Thread Starter
Registriert
08.02.2014
Beiträge
7.833
Ich beantworte mir mal selber, hab es gefunden:


mit Brigadier die Mac Pro 3,1 (und andere) BootCamp Treiber laden

Code:
Brigadier -m MacPro3,1

dann in dem Paket in Drivers/Apple/x64

den Apple Bluetooth enabler installer ausführen.

Dann war ein Generic Bluetooth Adapter verfügbar und die Magic Mouse lies sich koppeln.

Scrollgesten funktionierten auf Anhieb (hatte allerdings die iMac Pro 1,1 Treiber schon vorher im System)

nur Natural Scrolling musste per RegEdit nachgerüstet werden:

https://www.windowscentral.com/how-reverse-scrolling-direction-windows-10
 
Zuletzt bearbeitet:

LuckyOldMan

Aktives Mitglied
Registriert
28.11.2015
Beiträge
1.056
Schön zu sehen, dass auch Experten schon mal mit der Technik hadern. ;)
Mensch bleibt halt doch Mensch und das ist auch gut so! :)

Scrolling habe ich bei meinem MP3.1 aber typisch Windows-mäßig belassen. Die Umstellung ergibt sich (fast) automatisch bei Auswahl des OS.
 

Macschrauber

Aktives Mitglied
Thread Starter
Registriert
08.02.2014
Beiträge
7.833
Moooooment, ich bin in Windows ein blutiger Laie.

Das Teufelszeug fass ich normal nicht mit der Beisszange an :-D
 

Macschrauber

Aktives Mitglied
Thread Starter
Registriert
08.02.2014
Beiträge
7.833
Unter Win 10 1903 wollte die Magic Mouse wieder nicht.
auch den Installer von #2 starten hat nicht geholfen.

Lösung:
im Bootcamp Paket 6.1 BootCamp\Drivers\Apple\AppleWirelessMouse\AppleWirelessMouse.inf
mit Rechtsklick anwählen,
installieren auswählen
neustarten,
eventuell Maus an- und abmelden.
 

JarodRussell

Aktives Mitglied
Registriert
02.06.2003
Beiträge
3.594
Generell scheint mir Win10 mit den letzten Updates die BT-Unterstützung von Apple Geräten massiv gestört zu haben. Ich kriege bei mir mittlerweile Magic Mouse und BT Keyboard nicht mehr verbunden. Allerdings bei mir handelt es sich um ein MBP Late 16. Das verstehe wer will...ich werde aber mal Deinen Weg ausprobieren.
 

frog_pilot

Mitglied
Registriert
27.08.2007
Beiträge
105
Code:
Brigadier -m MacPro3,1
Wo gebe ich das denn ein bzw. welchem Befehl wird das denn angefügt?

Ich lade die Bootcamp-Treiber in Catalina mit dem Boot-Camp-Assistenten herunter. Woher ist Deine Versionsnummer 6.1.? In meinem Paket steht:

<BuildInfo BuildNumber="4033" ProductName="Boot Camp"> <MsiInfo> <ProductManufacturer>Apple Inc.</ProductManufacturer> <ProductVersion>4.0.4033</ProductVersion> <ProductCode>{ADA3F9C8-A6D3-4fcf-BFBB-EAD69AC0884E}</ProductCode>

Brigadier auf der Windows Command Line als admin....
Quelle

Hab jetzt mit Hilfe von Brigadier ein dezidiertes Paket herunterladen können, das auch Support für die cMPs enthält, also auch 3,1. Releasedate Mitte 2019. DIe zentrale Setup-Routine verlangt Windows 7... Was für ein Alptraum. Die Versionsnummer in der BootCamp64.xml ist genau die selbe, wie im aktuellen von Bootcamp in Catalina angebotenen Download.

Hab gerade keinen Bock mehr. Im Grunde ist mein einziges Problem mit der aktuellen Version, dass meine Magic Mouse 1 zwar erkannt, aber nicht verbunden wird...

In /Bootcamp/Drivers/Apple/x64 habe ich nur exe-Dateien, keine Ordner mit infs...
 
Zuletzt bearbeitet:

frog_pilot

Mitglied
Registriert
27.08.2007
Beiträge
105
Immer noch erfolglos:

Windows 10 pro 20H2 installiert.
BootCamp-041-84868 geladen. Das ist eigentlich für Win 7 64 bit. Im Kompatibilitätsmodus für Win 7 installiert (Rechtsklick auf die setup-routine, Tab Kompatibilität, Kompatibilitätsmodus)

Danach wird die gesamte Hardware scheinbar erkannt und unterstützt, selbst Lautstärke- und Eject-Tasten der Tastatur.

BootCamp-061-97204 geladen (für IMacPro1,1) Komplettinstallation wird auf dem MacPro3,1 verweigert. AppleWirelessMouse.inf und diverse bluetoothtreiber einzeln installiert.

Jedesmal das gleiche Ergebnis:

Beim Versuch die Magic Mouse 1 als neues Bluetooth-Gerät hinzuzufügen, wird die Maus erkannt. Ihr Name wird angezeigt. Wenn ich "verbinden" anklicke, geht der Verbindungsversuch endlos ohne Ergebnis, bis die Maus sich aus dem Pairing-Modus ausschaltet. Ohne Erfolg.

Die einzige Änderung. die ich feststelle während der Maßnahmen ist, dass irgendwann die Mighty-Mouse am Tastatur-Hub nicht mehr erkannt wird und ich die direkt in einen USB- Anschluss am Mac stecken muss.

Wenn noch jemand Hinweise hat, bitte gern. Nach mehrmaligem löschen und reinstallieren der BootCamp-Software bin ich hier erstmal mit meinem Latein am Ende...
 
Oben