Wer kann mir mit einer Formel in Numbers Helfen

Charly-2022

Neues Mitglied
Thread Starter
Registriert
24.05.2021
Beiträge
17
ich eine zeitberechnung erstellt !!

feld a: Anfags Zeit feld b: endzeit feld c: dauer

wenn ich das fehlt dauer !! zusammen adiere
= Summe( c1:c15 ) sind im unten
nur das fehlerzeichen zu sehen!
weil z.b ein oder mehrere felder noch nicht
ausgefüllt sind und eine 0 darin steht !!!

Vielen Dank für Eure Hilfe
image.jpg
 

yew

Aktives Mitglied
Registriert
29.02.2004
Beiträge
7.838
Hi
dann gib doch in den Zellen die leer sind oder wo "0" drin steht, einfach mal 0:00 ein

Gruß yew
 

aao_scout

Mitglied
Registriert
08.02.2004
Beiträge
967
So funktioniert es bei mir:
Bildschirmfoto 2021-05-24 um 20.15.48.png


Die Zellenformatierung:
Bildschirmfoto 2021-05-24 um 20.17.39.png



Gruß
aao_scout
 

Charly-2022

Neues Mitglied
Thread Starter
Registriert
24.05.2021
Beiträge
17
Vielen Dank

bei mir Funktioniert Sie auch wenn alle
Felder eingetragen sind aber wenn eins
noch nichts drin Steht gibt es den Fehler
 

yew

Aktives Mitglied
Registriert
29.02.2004
Beiträge
7.838
Hi
und wie sieht es mit einer offiziellen Version von Big Sur aus? .... hast ja die Beta droben

Gruß yew


.... ah ok, seh grad, 11.4 ist schon draussen
 

yew

Aktives Mitglied
Registriert
29.02.2004
Beiträge
7.838
hab mich doch schon lang korrigiert .... solltet es halt mal lesen
 

yew

Aktives Mitglied
Registriert
29.02.2004
Beiträge
7.838
oder mit der passenden Formel (WENN) bei der Dauer, wenn die Zelle wirklich leer bleiben soll

=WENN(A1="";"";B1-A1)

... wenn in A die Startzeit ... in B die Endzeit steht


Gruß yew
 
Zuletzt bearbeitet:

Charly-2022

Neues Mitglied
Thread Starter
Registriert
24.05.2021
Beiträge
17
wenn ich in der Zell wo eine 0 Steht einfach 0:00
eintrage ist die Formel( z.b b3-a3) in der Zelle auch weg
 

Charly-2022

Neues Mitglied
Thread Starter
Registriert
24.05.2021
Beiträge
17
wenn ich die Dauer der Stunden im Feld (C)
Statt C1:C20 einzeln zusammen Zähle C1+C2+C3 und so weiter dann Bekomme ich keinen Fehler mehr.
 

DerdenMacliebt

Mitglied
Registriert
21.02.2008
Beiträge
508
oder mit der passenden Formel (WENN) bei der Dauer, wenn die Zelle wirklich leer bleiben soll

=WENN(A1="";"";B1-A1)

... wenn in A die Startzeit ... in B die Endzeit steht


Gruß yew
Genau! Wo ist das Problem? Soll die Zelle Dauer leer bleiben, wenn entweder Startzeit oder Endzeit leer ist, dann löst man das Problem mit einer ODER-Verknüpfung:

screenshot.jpeg
 

Charly-2022

Neues Mitglied
Thread Starter
Registriert
24.05.2021
Beiträge
17
nein Sie soll nicht leer Bleibt
die werden jeden Tag nach der Arbeit ausgefüllt
 

Charly-2022

Neues Mitglied
Thread Starter
Registriert
24.05.2021
Beiträge
17
aber die Formeln stehen schon im Feld Dauer
und unten die Dauer zusammen zu Rechnen
 

DerdenMacliebt

Mitglied
Registriert
21.02.2008
Beiträge
508
Klar steht bei mir in jedem Feld der Spalte C bereits analog die oben eingeblendete Formel, das Ergebnis wird halt erst berechnet, wenn Startzeit und Endzeit nicht leer sind.
 
Oben Unten