Videostream über VPN geht trotz ausreichender Verbindung nur langsam & ruckelig - was mache ich falsch?

zxcd

Mitglied
Thread Starter
Registriert
11.01.2009
Beiträge
482
Hi zusammen,

ich greife über eine VPN-Verbindung auf meinen NAS zu, der sich außerhalb meines jetzigen Netzwerks befindet. Der Upstream des Netzwerks, in dem sie der NAS befindet, beträgt vertragsgemäß 6 Mbit/s. Der Downstream des Netzwerks, in dem ich mich befinde, liegt darüber.
Verbinde ich mich nun über den VPN und mache einen Speedtest, wird mir als Downloadgeschwindigkeit nahezu 6 Mbit/s attestiert - das ist soweit ja richtig, oder?

Nun möchte ich auf (Video)Dateien auf dem NAS zugreifen, die unterschiedlich groß sind - teils HD-Videos mit 1080p, teils alte 480p Videos. Für das ruckelfreie Streamen dieser Dateien sollte der 6 Mbit/s Upstream doch eigentlich problemlos ausreichen. Trotzdem ist eine ruckelfreie Wiedergabe nicht möglich, da auf 2 Sekunden Video wieder 10 Sekunden Ladezeit folgen. Kopiere ich testweise eine Datei von 100 MB, geschieht dies in ca. 2,5 Minuten und damit eigentlich genau im Rahmen des 6 Mbit/s Upstreams. Er scheint die Geschwindigkeit also vollends nutzen zu können, nur das Streaming klappt einfach nicht ruckelfrei.

Es gibt keine weiteren Verbindungen/Geräte, die etwas an der Leitungsgeschwindigkeit beeinträchtigen - der Videostream ist die einzige Verbindung. Woran kann das liegen und was kann ich tun, damit eine störungsfreie Wiedergabe möglich ist?

Danke euch!
 

tocotronaut

Aktives Mitglied
Registriert
14.01.2006
Beiträge
26.499
FullHD 1080p als Fernsehstream hat etwa 12 Mbit/s.
Da wird es mit 6 mbit schon eng.

Ein anderes Problem kann sein dass der NAS das format eventuell umwandelt. Das kann dann je nach NAS auch problematisch sein.

Welches NAS?
Welche Software nutzt du für das Videostreaming auf dem NAS?
Wie greifst du mit deinem Endgerät auf die Videos zu?
 

zxcd

Mitglied
Thread Starter
Registriert
11.01.2009
Beiträge
482
NAS: MyCloud
Software: VLC Player
Zugriff: über die in OS X konfigurierte IPSec-VPN-Verbindung

Befinde ich mich bei gleicher Konfiguration der Software und des NAS in meinem eigenen Heimnetzwerk, funktioniert alles problemlos. Es geht konkret nur um den Zugriff über die VPN-Verbindung, also muss der Fehler irgendwie mit dem Fakt zusammenhängen, dass ich von außen darauf zugreife.
 

AgentMax

Super Moderator
Registriert
03.08.2005
Beiträge
48.861
Wer stellt den VPN in deinem Netzwerk daheim bereit?
Welche Bitrate hat denn das Video (Video und Audiospur)?
 

zxcd

Mitglied
Thread Starter
Registriert
11.01.2009
Beiträge
482
Wer stellt den VPN in deinem Netzwerk daheim bereit?
Die Frage verstehe ich nicht so ganz?
Welche Bitrate hat denn das Video (Video und Audiospur)?
Vollkommen unterschiedlich. Sind Konzertvideos, d.h. da sind teilweise echte in 1080p bei, teilweise aber auch alte Dateien in 480p.

Wenn ich bspw. über den VPN ein YouTube-Video in HD öffne, geschieht das absolut problemlos und sekundenschnell. Heißt in der Zusammenfassung:

Befinde ich mich im Netzwerk des NAS und greife auf Videodateien darauf dazu, läuft alles wunderbar.
Greife ich über den VPN auf den NAS zu, reicht die Bandbreite für das Ansehen von HD-Videos auf YouTube - nicht aber für das ruckelfreie Sehen der auf dem NAS gespeicherten Dateien :iconfused:
 

zxcd

Mitglied
Thread Starter
Registriert
11.01.2009
Beiträge
482
Achso. VPN-Server ist Fritz DynDNS.
 

AgentMax

Super Moderator
Registriert
03.08.2005
Beiträge
48.861
Dann kommt es jetzt noch darauf an welche FB das ist. Ältere Modelle schaffen da gerade mal 2 MBit. Egal wie schnell der Anschluss ist. Die CPU in der Fritzbox
ist einfach zu langsam um die Verschlüsselung durchzuführen. Aktuelle Modelle schaffen um die 8 MBit.
Eventuell liegt da das Problem.
 

tocotronaut

Aktives Mitglied
Registriert
14.01.2006
Beiträge
26.499
Fritzbox ist aktuell?
Software 7.20 hat den VPN Durchsatz ca. verdreifacht.
 

zxcd

Mitglied
Thread Starter
Registriert
11.01.2009
Beiträge
482
Software ist aktuell, ja. Es handelt sich um die 7490.

Edit: Der Durchsatz scheint ja auch generell in Ordnung zu sein, oder irre ich mich? Der Speedtest des VPNs zeigt ja 6 Mbit/s an (was eben dem maximalen Upstream des Netzwerks entspricht) und das Kopieren von Daten geht ja auch in der Geschwindigkeit. Nur das öffnen/abspielen von Dateien dauert einfach extrem lange, wenn man sie über den VPN versucht zu öffnen. Habe es jetzt mal mit Bildern à 200 kb via Vorschau probiert. Selbst die brauchen Sekunden, bis sie geöffnet sind.
 

tocotronaut

Aktives Mitglied
Registriert
14.01.2006
Beiträge
26.499
Die Firmware der Fritzbox solltest du aktualisieren, sobald verfügbar. Eventuell macht die Laborfirmware auch sinn... Musst du entscheiden.
Die 6-8 mbit schafft die FritzBox auch so, aber sie ächzt dabei. Mit der neuen Firmware sollte das etwas besser werden.

6 Mbit Upstream ist für FullHD etwa mau. Da sollten es 12 mbit sein.
480p sollte allerdings locker übertragen werden.

Das es im LAN funktioniert zeigt wie du schon schreibst das es vermutlich wirklich an der Internetverbindung liegt. Und ja, dabei ist dann der Upload/Upstream meist das Problem.

Letztlich ist Streaming etwas anspruchsvoller als eine reine Dateiübertragung. Pakete müssen zeitnah und in der richtigen Reihenfolge empfangen werden.
Vielleicht macht dir dein Internet-anbieter auch einen Strich durch die Rechnung, weil er beim Upload noch irgendetwas dazwischengeschaltet hat.
Oder der NAS kommt mit dem ganzen doch nicht klar.
Ist der NAS mit einem Kabel an der Fritzbox angeschlossen oder sind da noch repeater oder irgendwas dazwischen?

Hast du die Möglichkeit, mal testweise einen Rechner im netz laufen zu lassen und da z.b. www.plex.tv als server einzurichten?
 

lisanet

Aktives Mitglied
Registriert
05.12.2006
Beiträge
3.404
Ich komme nochmal auf die Bitrate der Videos zurück. Das kann echt was ausmachen, je nachdem _wie_ die kodiert wurden. In vielen Tools, z.B. auch in Handbrake, wird meist constant quality encoding ohne Bitratenbegrenzung verwendet, was dann durchaus zu sehr stark schwankenden Bitraten führen kann. Die durchschnittliche Bitrate aus der Dateigröße und Dauer berechnet sagt da halt nichts aus.

Spiele die Videos mal lokal ab und sieh dir die aktuelle Bitrate an. Geht auch mit VLC -> CMD + I -> Statistik. Vielleicht liegt's ja auch mit daran.
 

zxcd

Mitglied
Thread Starter
Registriert
11.01.2009
Beiträge
482
Die Firmware der Fritzbox solltest du aktualisieren, sobald verfügbar.
Ist bekannt, wann die 7.20 für die 7490 offiziell veröffentlicht wird?
6 Mbit Upstream ist für FullHD etwa mau. Da sollten es 12 mbit sein.
480p sollte allerdings locker übertragen werden.
Wie gesagt: Selbst das Laden von 200 kb Bildern dauert ewig. Das sollte die Diskussion nach der Übertragungsgeschwindigkeit und auch der Videobitrate ja eigentlich etwas abschwächen, oder habe ich da einen Denkfehler?
Ist der NAS mit einem Kabel an der Fritzbox angeschlossen oder sind da noch repeater oder irgendwas dazwischen?
Die Schaltung lautet: Vodafone Modem => Fritzbox => NAS (via LAN verbunden mit der Fritzbox)
Hast du die Möglichkeit, mal testweise einen Rechner im netz laufen zu lassen und da z.b. www.plex.tv als server einzurichten?
Nein, leider nicht.
Spiele die Videos mal lokal ab und sieh dir die aktuelle Bitrate an. Geht auch mit VLC -> CMD + I -> Statistik. Vielleicht liegt's ja auch mit daran.
Habe mal mehrere Videos getestet. Keins geht komplett ruckelfrei, selbst sehr niedrige Qualitäten nicht. Trotzdem unterscheiden sie sich ein wenig:
• Input-Bitrate 1333kb/s bzw. Stream-Bitrate 962 kb/s, avi-Datei in der Größe von 500 MB => geht verhältnismäßig gut
• Input-Bitrate 2031 kb/s bzw. Stream-Bitrate: 2035 kb/sm mp4-Datei in der Größe von 285 MB => läuft für 30 Sekunden, danach hakt es für 10 Sekunden, danach läuft es wieder für 30 Sekunden usw.
• Input-Bitrate 2642 kb/s bzw. Stream-Bitrate 2692 kb/s, mp4-Datei in der Größe von 2,65 GB => geht im Prinzip gar nicht.
 

lisanet

Aktives Mitglied
Registriert
05.12.2006
Beiträge
3.404
Habe mal mehrere Videos getestet. Keins geht komplett ruckelfrei, selbst sehr niedrige Qualitäten nicht. Trotzdem unterscheiden sie sich ein wenig:
• Input-Bitrate 1333kb/s bzw. Stream-Bitrate 962 kb/s, avi-Datei in der Größe von 500 MB => geht verhältnismäßig gut
• Input-Bitrate 2031 kb/s bzw. Stream-Bitrate: 2035 kb/sm mp4-Datei in der Größe von 285 MB => läuft für 30 Sekunden, danach hakt es für 10 Sekunden, danach läuft es wieder für 30 Sekunden usw.
• Input-Bitrate 2642 kb/s bzw. Stream-Bitrate 2692 kb/s, mp4-Datei in der Größe von 2,65 GB => geht im Prinzip gar nicht.
Sind das echt die Peak-Bitraten? Hast du die Bitraten mal über längere Zeit beobachtet? Bei max. 2700 kbit/s kann ich mir ein Ruckeln nicht vorstellen.
Das einzige was mir noch einfällt, ist vielleicht die Art des Dateizugriffes. Gehst du da über SMB? Das könnte möglicherweise auch einen Effekt haben, da soweit ich weiß SMB nicht einen konstanten Datenstrom liefert, sondern eher stückweise die Daten ausliefert. Das könnte dann in Verbindung mit hohen Peak-Bitraten, die an das Upload-Limit reichen, für das beobachtete Phänomen sorgen.

Ich würde fürs streamen eher den schon vorgeschlagenen Plex-Server empfehlen.
 
Zuletzt bearbeitet:

zxcd

Mitglied
Thread Starter
Registriert
11.01.2009
Beiträge
482
Sind das echt die Peak-Bitraten? Hast du die Bitraten mal über längere Zeit beobachtet? Bei max. 2700 kbit/s kann ich mir ein Ruckeln nicht vorstellen.
Habe das über >30 Sekunden beobachten. Es gab kleine Schwankungen (5%), aber im Prinzip hielt sich die Bitrate relativ konstant in diesem Bereich auf, ja.
Das einzige was mir noch einfällt, ist vielleicht die Art des Dateizugriffes. Gehst du da über SMB? Das könnte möglicherweise auch einen Effekt haben, da soweit ich weiß SMB nicht einen konstanten Datenstrom liefert[/QUOTE]Ja, gehe über SMB. Habe ich da irgendwelche anderen Möglichkeiten, die in der o.g. Konfiguration spontan testen könnte?
 

hutzi20

Aktives Mitglied
Registriert
08.08.2013
Beiträge
1.120
Ich denke mal du greifst direkt über SMB auf deine Daten zu. (also über den Finder) SMB ist über VPN extrem langsam da die hohe Latenz das Protokoll extrem ausbremst.
Aktuelle habe ich hier auch nur 6Mbit über den VPN anliegen und es mal getestet. Ich komme mit SMB nicht über 200 kilobyte sprich 1600 kbit/s, durchschnitt liegt bei 1200kbit/s.
 

hutzi20

Aktives Mitglied
Registriert
08.08.2013
Beiträge
1.120
Über smb kannst das vergessen. Kannst du auch anders auf dein NAS zugreifen? Weboberfläche? Dort kopierst du dir den Downloadlink der Video Datei und öffnest diesen als Stream in VLC
 
Oben