Tiger server: Probs mit Vhosts

Diskutiere das Thema Tiger server: Probs mit Vhosts im Forum Mac OS Server, Serverdienste

  1. bossy22

    bossy22 Thread Starter Mitglied

    Beiträge:
    59
    Zustimmungen:
    0
    Mitglied seit:
    28.07.2005
    Hi,

    habe folgendes Problem:

    Ich möchte auf meinem Tiger Server Vhosts konfigurieren. Dies habe ich folgendermassen gemacht.

    In der httpd.conf habe ich folgenden Eintrag:

    Code:
    Include "/etc/httpd/sites/virtual_host_global.conf"
    in der inkludierten conf datei stehen folgende Einträge:

    Code:
    Listen *:80
    
    NameVirtualHost 192.168.2.20:80
    
    
    <VirtualHost 192.168.2.20:80>
    ServerName local.clipcontact.dev
    ServerAlias .clipcontact.dev *.clipcontact.dev
    ServerPath  /Library/WebServer/Documents/drupal
    DocumentRoot /Library/WebServer/Documents/drupal
    </VirtualHost>
    

    Und selbstverständlich in der /etc/hosts:

    Code:
    192.168.2.20    local.clipcontact.dev

    Rufe ich im Browser nun local.clipcontact.dev auf, erscheint ein:

    Code:
    404 Not Found
    
    The requested URL /drupal/ was not found on this server.
    Ein Blick in die error.log bringt:


    Code:
    [error] [client 127.0.0.1] File does not exist: /tmp/drupal/
    Warum versucht der Apache denn im /tmp Verzeichnis nach der Installation zu suchen und nicht unter

    Code:
    /Library/WebServer/Documents/drupal
    ???


    Gruß


    Bossy
     
  2. oneOeight

    oneOeight Mitglied

    Beiträge:
    50.251
    Zustimmungen:
    4.563
    Mitglied seit:
    23.11.2004
    wohin zeigt denn /Library/WebServer/Documents/drupal?
     
  3. bossy22

    bossy22 Thread Starter Mitglied

    Beiträge:
    59
    Zustimmungen:
    0
    Mitglied seit:
    28.07.2005
    Wie meinst du das?
     
  4. oneOeight

    oneOeight Mitglied

    Beiträge:
    50.251
    Zustimmungen:
    4.563
    Mitglied seit:
    23.11.2004
    ist das ein richtiger ordner oder nur ein alias...
    irgendwo steht aber noch /tmp/drupal also such mal ;)
     
  5. bossy22

    bossy22 Thread Starter Mitglied

    Beiträge:
    59
    Zustimmungen:
    0
    Mitglied seit:
    28.07.2005

    Die Meldung im error.log ist nun:

    Code:
    client denied by server configuration: /tmp
    Das einzige was dazu in der httpd.conf steht ist:

    Code:
    #ServerName www.example.com
    Port 9010
    Listen 9010
    DocumentRoot "/tmp"
    ErrorLog "/var/log/httpd/error_log"
    <Directory "/tmp">
            Order Deny,Allow
            Deny from All
            Allow from 127.0.0.1
    </Directory>
    <Location /server-status>
            SetHandler server-status
            Order deny,allow
            Deny from all
            Allow from 127.0.0.1
    </Location>
    
    Das merkwürdige ist, das ich gestern noch über

    http://localhost/drupal

    auf die Website zugreifen konnte.

    erst nach Anlegen des vhosts gings nicht mehr.

    Ich versuch jetzt mal über ServerAdmin

    alles zurückzusetzen und en vhost dort anzulegen..

    Gruß

    Bossy

    P.S.: Und ja:

    Es war ein richtiges Verzeichnes und kein Symlink oder so
     
Die Seite wird geladen...

MacUser.de weiterempfehlen

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Akzeptieren Weitere Informationen...