Thunderbolt Display an M1 Macbook Pro

developr

Mitglied
Thread Starter
Dabei seit
08.06.2020
Beiträge
10
Reaktionspunkte
1
Hallo Zusammen,

... ich bin am verzweifeln und hoffe, dass ich hier Hilfe finde.

Ich habe seit Jahren ein Macbook Pro 2015 Mid an einem Thunderbolt Display betrieben. Was mich schon immer genervt hatte, war dass sobald ich das Macbook an den TBD angeschlossen habe, die Lüfter wild gedreht haben und das Macbook deutlich langsamer wurde.

Nun habe ich mir aus diesem speziellen Grund ein neues Macbook M1 Pro gekauft und wollte es mit dem Thunderbolt2-3 Adapter am TBD anschließen. Das Display bleibt schwarz, sprich es wird nicht erkannt. Erst als ich die Bildwiederholungsrate von ProMotion auf 60Hz runtergestellt habe, habe ich ca. 15 Sekunden später ein Bild bekommen. Nach etwa 2 Minuten wird das Bild jedoch wieder schwarz. Es hilft nur ein Neustart, aber auch nicht immer... als wäre es Zufall.

Wenn ich das TBD an meinem alten Macbook 2015 Retina anschließe, funktioniert es jedoch einwandfrei. Deshalb würde ich ein Defekt des Displays eigentlich ausschließen.

Hat jemand Erfahrungen?
 
Das ist ein bekannter Fehler seitens Apple und betrifft alle M1/2 Rechner. Die Grafikkarte unterstützt nicht vollständig die Übertragungsprotokolle. Da diese Displays von Apple mittlerweile als Vintage eingestuft sind, erwarte keinerlei Unterstützung und Softwarekorrekturen von Apple.

Aktueller Monitorsupport auf der M Plattform ist einfach von Apple schlecht umgesetzt. Monitore, die mit beliebigen PCs und sogar Tablets und billigen Kabeln tadellos in allen Modi funktionieren, zicken bei den M1/2 Macs meist gar fürchterlich. Der Fehler liegt eindeutig bei Apple, icht bei den Kabel- oder Monitorherstellern. Das ist unsere Erfahrung.

Versuche mal folgendes: Deaktiviere den StandBy Modus, HDR und Promotion unbedingt dauerhaft. Wähle auch keine skalierte Auflösung sondern die Auswahl "Standard".
 
Habe bei meinem Chef diese Kombination lauffähig gesehen... Ich frag mal nach.

Edit: Bei ihm lief es sofort ohne Probleme
 
Das ist ein bekannter Fehler seitens Apple und betrifft alle M1/2 Rechner...

Das "alle" kann ich bei mir nicht bestätigen. Ich habe mein MBA M1 an zwei TBDs mit originalen Adaptern von Apple (Thunderbolt 3 (USB‑C) auf Thunderbolt 2 Adapter) problemlos und störungsfrei am Laufen (zwei unterschiedliche Arbeitsplätze). Vorher war es ein Intel Macbook, dito ohne Probleme.

Hilft jetzt wahrscheinlich nicht wirklich, aber vllt. mal den Adapter prüfen?
 
Der Fehler liegt eindeutig bei Apple, icht bei den Kabel- oder Monitorherstellern.

ich habe eine andere Erfahrung gemacht. So eindeutig wie du tust ist es eben nicht.

Mein BenQ PD2720U hat zu Anfang am M1 Mini u.a. nur 30 Hz via TB wieder gegeben. BenQ hat mir dann ein Firmware-Update angeboten mit kostenloser Abholung und Ersatzgerät.

Ergebnis: Ab da lief der Monitor perfekt mit dem M1
 
Vielleicht liegt es auch am Adapter, welches ist es denn?
 
Mein BenQ PD2720U hat zu Anfang am M1 Mini u.a. nur 30 Hz via TB wieder gegeben.
wie misst man denn den Hz-Wert? Ich gehe mal davon aus, dass mit mba m2 mittels TB3<->TB2-Adapter auf einem TB-Display 60Hz liefert in 1440er-Auflösung. Aber "stehen" tut das nirgendwo... :kopfkratz:
 
Nein, wenn Android Tablets, Desktop PCs und Laptops verschiedenen Alters, sogar Mobiltelefone via Adapter problemlos sich mit Monitoren und Kabeln verbunden, an denen ein M1 Mac zickt, dann liegt es an der Mac Hardware/Software und nicht an den anderen Geräten. Diese Problematik findest du so an vielen Stellen im Netz wieder und es fällt auf, dass die Kompatibilität zu Standards bei Apple immer stärker abnimmt.

Ähnliches gilt für die Thunderbolt 4/USB C Ports bei M1 Macs, die kein USB v3.1 Gen 2 unterstützen und bei 10GBit drosseln.

Apple verschweigt seit einiger bewusst die eindeutigen und vollständigen Spezifikationen ihrer Ports und das sorgt für viel Frust und Ärger auf Benutzerseite.
 
Oh jetzt bin ich mal gespannt was darauf kommt;)
 
Aber "stehen" tut das nirgendwo... :kopfkratz:

... doch klar. zumindest mein Monitor zeigt es im Menu an, mit welche Frequenz er darstellt. Machen meines Wissen auch alle Monitore. Und mittlerweil wird ja auch in den Systemeinstellungen bei Display die Bildwiederholrate angezeigt.

Zudem sieht man den Unterschied zwischen 60 und 30 Hz durch nicht so flüssige Animationen wie z.B. dem Ein- und Ausblenden des Docks. Stichwort Mikroruckler.
 
Ähnliches gilt für die Thunderbolt 4/USB C Ports bei M1 Macs, die kein USB v3.1 Gen 2 unterstützen und bei 10GBit drosseln.
Falsche Version 😉
3.1 Gen 2 beherrschen die.
Die 20 GBit-Stufe 3.2 Gen 2x2 geht nicht, hier wird auf 10 GBit gedrosselt.
 
Nein, wenn Android Tablets, Desktop PCs und Laptops verschiedenen Alters, sogar Mobiltelefone via Adapter problemlos sich mit Monitoren und Kabeln verbunden, an denen ein M1 Mac zickt, dann liegt es an der Mac Hardware/Software und nicht an den anderen Geräten.

Und warum hat dann bei mir ein Firmwareupdate die Probleme behoben, obwohl sich die macOS-Version nicht verändert hat?

Du redest halt von "ausschließlich Apple". Ich sage, dass es auch andere Gründe haben kann und bei mir auch hatte. Also eben nichts mit "ausschließlich Apple".

Aber ich weiß, es schreibt sich leichter in Foren, wenn man über Apple herzieht, als wenn man versucht auch positive Erfahrungen mit einfließen zu lassen. Man will ja den gut informierten und kritischen User geben.... Interessanterweise leugen ja öfters die "Kritiker", dass es auch andere Fehlerquellen und Mängel, jenseits von Apple, gibt.

Apropos Kabel:

Erst vor kurzem war mal wieder ein Thread hier, in welchem seitenlang geschrieben wird, wie shice doch Apple ist und nicht mal eine per USB-C angeschlossenen SSD stabil erkennt. Angeblich wurde allso x mal geprüft und daher festgestellt, dass es eindeutig und ausschließlich an Apple läge. Tja, dann kam heraus, dass ein ehr günstiges, reines Ladekabel verwendet wurde. Also ein reguläres USB-C Datenkabel gekauft und verwendet wurde... oh Wunder, da leif die SSD problemlos.

Soviel zu "Apple ist eindeutig schuld" und "findest du an vielen Stellen im Netz"

Und beovr du mir nun rrgendwas unterstellst: ich rede nicht davon, dass Apple nie Schuld sei. Mit keiner Silbe steht das wo. Ich spreche davon, dass es auch andere Fehlerquellen gibt, die nicht durch Apple verursacht werden und dass dein "alleinig Apple" nicht passt.
 
Die 20 GBit-Stufe 3.2 Gen 2x2 geht nicht, hier wird auf 10 GBit gedrosselt.
Wieso wird da gedrosselt? Die Macs können das schlicht und ergreifend nicht.

Ich hatte bei mir den Fall zum Testen leider nur anders herum, als ich meinen Mac Pro 2013 mit dem Thunderbolt 2 auf Thunderbolt 3 Adapter an meinem jetzigen Thunderbolt 3 Monitor betrieben habe. Vorher hatte ich einen Thunderbolt 2 Monitor aber der hat das zeitliche gesegnet bevor der Mac mini M1 ins Haus kam. Mit dem Thunderbolt 3 Monitor verträgt er sich völlig problemlos mit 144Hz, 10bit und auch im Ruhezustand (bis darauf, das die Fenster immer im Ruehzustand verkleinert werden).
 
Ich bin heute noch mal 70km zum nächsten Apple Reseller gefahren und habe mir einen weiteren Apple TB2/3 Adapter (55€) und ebenfalls ein Apple TB/TB-Kabel (45€) gekauft, um einen Defekt des Kabels und des Adapters auszuschließen.

Der 2. Adapter hatte keine Veränderung gebracht, schwarzer Bildschirm.

Ein Downgrade auf Monterey hatte ebenfalls nichts gebracht.

Das TB-Kabel war aber die Lösung gewesen! Ich habe nun das TB-Kabel in den freien Slot im TBD gesteckt, dann auf den TB2-USB-C Adapter und ins MacBook.

Zudem muss auch die Bildwiederholungsrate vom Mac nicht geändert werden und kann auf ProMotion stehen bleiben.

Das TB-Kabel vom TBD hat ja am alten MacBook Pro einwandfrei funktioniert. Wieso das gleiche Kabel am M1 Macbook nicht funktioniert, kann ich nicht sagen.
 
Ich vermute mal, dass es an Apple liegt. Dass der Bildschirm nicht erkannt wird, scheint damit zusammenzuhängen, dass dieser nicht aufgeweckt wird. Wo der Unterschied am "festen" und "optionalen" Kabel liegt, weiß ich nicht.

Ich habe Zuhause noch 2 TBD stehen und werde das Anfang Januar noch mal mit diesen testen, ob das Fehlerbild vorhanden ist und wenn ja, ob es sich ebenso lösen lässt.
 
... doch klar. zumindest mein Monitor zeigt es im Menu an, mit welche Frequenz er darstellt. Machen meines Wissen auch alle Monitore. Und mittlerweil wird ja auch in den Systemeinstellungen bei Display die Bildwiederholrate angezeigt.

Zudem sieht man den Unterschied zwischen 60 und 30 Hz durch nicht so flüssige Animationen wie z.B. dem Ein- und Ausblenden des Docks. Stichwort Mikroruckler.

bei mir (12.6.2) offenbar nicht
1671219000310.png


1671219032572.png
 
Mit BetterDisplay (ehem. DisplayDummy) oder SwitchResX kannst du die bildwiederholungsrate einstellen bzw. freischalten. Macht ja aber eigentlich kein Sinn. Das TBD läuft auf 60Hz. Das XDR Display... keine Ahnung, was ProMotion kann. 120Hz?
 
Zurück
Oben Unten