Benutzerdefinierte Suche

ssh ohne passwort

  1. eloso

    eloso Thread StarterMacUser Mitglied

    Mitglied seit:
    30.11.2003
    Beiträge:
    154
    Zustimmungen:
    3
    Hallo allerseits,

    ich hab den sshd unter Tiger laufen und möchte verhindern, dass man sich mit Passwort anmelden kann. Also man soll sich nur noch über rsa/dsa anmelden können. Ich hab dazu
    Code:
    PasswordAuthentication no
    in der sshd_config eingetragen. Aber ich kann mich trotzdem noch mit Passwort anmelden. Irgendwelche Ideen?

    Gruß
    eloso
     
    eloso, 18.08.2005
  2. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.178
    Zustimmungen:
    3.895
    hast du nach dem ändern der config auch den server restartet oder neu gebootet?
    auch AuthorizedKeysFile gesetzt?
     
    oneOeight, 18.08.2005
  3. eloso

    eloso Thread StarterMacUser Mitglied

    Mitglied seit:
    30.11.2003
    Beiträge:
    154
    Zustimmungen:
    3
    ja, obwohl der sshd ja erst geladen wird, wenn ich mich verbinden will. Und andere Optionen, wie z.B. "UseDNS no" hat er auch sofort übernommen. Aber ich hab trotzdem nochmal den Rechner neu gestartet.

    AuthorizedKeysFile hatte ich zwar nicht gesetzt, aber das hat auch nicht geholfen. Ich kann mich ja auch mit rsa anmelden. Nur von einem Rechner, der keinen key hat komme ich immernoch mit Passwort rein.

    Irgendwie ist das schon seltsam. Gibt es vielleicht noch eine andere Option, die login per Passwort wieder zulässt?
     
    eloso, 18.08.2005
  4. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.178
    Zustimmungen:
    3.895
    ChallengeResponseAuthentication no
    muss wohl auch noch gesetzt werden
     
    oneOeight, 18.08.2005
  5. cilly

    cilly

    Das reicht allein nicht, du musst auch PAM disablen:

    UsePAM no
     
    cilly, 18.08.2005
  6. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.178
    Zustimmungen:
    3.895
    UsePAM ist doch per default auf no...
    und die standardconfig ändert es nicht
     
    oneOeight, 18.08.2005
  7. cilly

    cilly

    Mag schon sein, das ist aber meist der häufigste Fehler, warum Password-Authentication noch geht, obwohl auf no gestellt ist.
     
    cilly, 19.08.2005
  8. eloso

    eloso Thread StarterMacUser Mitglied

    Mitglied seit:
    30.11.2003
    Beiträge:
    154
    Zustimmungen:
    3
    ja, das wars! Vielen Dank!

    Da könnte ja in der man-page unter PasswordAuthentication auch ruhig noch mal ein Hinweis stehen... Naja, wenn ich die man-page mal komplett gelesen hätte, wäre ich vielleicht auch so drauf gekommen.

    Gruß
    eloso
     
    eloso, 19.08.2005
Die Seite wird geladen...
Ähnliche Themen - ssh passwort
  1. bschra
    Antworten:
    28
    Aufrufe:
    2.631
  2. Babaganoush
    Antworten:
    5
    Aufrufe:
    932
  3. Wanderfalke
    Antworten:
    6
    Aufrufe:
    1.373
    Wanderfalke
    31.10.2012
  4. mahed
    Antworten:
    3
    Aufrufe:
    1.684
  5. nitrol
    Antworten:
    7
    Aufrufe:
    7.204