SSH Login ohne Passworteingabe

Diskutiere das Thema SSH Login ohne Passworteingabe im Forum Mac OS - Unix & Terminal

  1. CottonIJoe

    CottonIJoe Thread Starter Mitglied

    Beiträge:
    132
    Medien:
    3
    Zustimmungen:
    15
    Mitglied seit:
    23.01.2005
    Ich habe mir per rsync ein paar nette Backupskripts gebastelt, die ich jetzt gerne automatisiert laufen lassen würde.

    Damit nicht jeder Skript-Aufruf nach dem Passwort zu meinem SSH-Server fragt, habe ich diese Anleitung befolgt, um einen Public Key auf dem Remote-Rechner zu hinterlegen.

    Angeblich soll jetzt KEINE Passwortabfrage mehr kommen wenn ich mich anmelde - das ist aber leider nicht der Fall! sowohl bei rsync als auch wenn ich mich direkt mit "ssh username@meinserver" anmelde fragt dat Ding unverändert nach dem Passwort.

    Hab ich was falsch gemacht? was fehlt?
    Noch zur Info über mein System:
    Lokal: iMac G5, Mac OS 10.4, User: johannes
    Remote: irgendein Debian, User: jbgibbon
    (liegts vielleicht daran dass ich lokal und remote verschiedene Namen benutze? Das lässt sich aber nicht vermeiden!)
     
  2. oneOeight

    oneOeight Mitglied

    Beiträge:
    50.706
    Zustimmungen:
    4.791
    Mitglied seit:
    23.11.2004
    nein an verschiedenen namen liegt es nicht, du gibst den usernamen ja mit an...
    rsa keys sind aber glaube ich nur für das SSH 1 protokoll und nicht für 2...
    da musst du dsa keys nehmen...
     
  3. CottonIJoe

    CottonIJoe Thread Starter Mitglied

    Beiträge:
    132
    Medien:
    3
    Zustimmungen:
    15
    Mitglied seit:
    23.01.2005
    ist das die selbe prozedur?
     
  4. CottonIJoe

    CottonIJoe Thread Starter Mitglied

    Beiträge:
    132
    Medien:
    3
    Zustimmungen:
    15
    Mitglied seit:
    23.01.2005
    Habs mal mit ssh-keygen -v -t dsa probiert, mit dem selben (keinem) Effekt :(
     
  5. tschloss

    tschloss Mitglied

    Beiträge:
    1.246
    Zustimmungen:
    51
    Mitglied seit:
    14.04.2007
    Sag doch mal genau, welche Befehle (ssh -i ... ?) du nutzt. Wie lautet die Paswwortabfrage genau?

    Hast Du bei der Erstellung der Identität auch zweimal ein leeres Passwort (für den private Key) eingegeben?

    Ist der SSH-Server überhaupt so eingerichtet, dass er dieses Anmeldeverfahren akzeptiert?

    Thomas
     
  6. oneOeight

    oneOeight Mitglied

    Beiträge:
    50.706
    Zustimmungen:
    4.791
    Mitglied seit:
    23.11.2004
    versuch mal ein ssh -vvvv um zu sehen, warum der den key nicht annimmt...
     
  7. ruerueka

    ruerueka Mitglied

    Beiträge:
    1.185
    Zustimmungen:
    124
    Mitglied seit:
    04.04.2004
    Falls der Server richtig konfiguriert ist, liegt das Problem in der Regel an falschen Rechten der Datei ~/.ssh/authorized_keys auf dem Server. Die Rechte sollten meines Wissens auf 400 stehen.
     
  8. CottonIJoe

    CottonIJoe Thread Starter Mitglied

    Beiträge:
    132
    Medien:
    3
    Zustimmungen:
    15
    Mitglied seit:
    23.01.2005
    Vielen Dank für eure vielen Tipps und Hinweise!

    @tschloss: ja, ich habe ein leeres Passwort eingegeben! Wie stelle ich fest ob mein Server das Anmeldeverfahren akzeptiert? Meine genauen Befehle siehe unten.

    @ruerueka: gesetzt war 644, was ja wohl auch nicht direkt _schaden_ dürfte, habs jetzt aber mal auf 400 gesetzt. Kein Unterschied :(


    @oneOeight: Hier mal eine stinknormale Verbindung mit "ssh -vvvv meinname@meinserver":

    Code:
    localhost:~ johannes$ ssh -vvvv jbgibbon@meinremoteserver
    OpenSSH_4.7p1, OpenSSL 0.9.7l 28 Sep 2006
    debug1: Reading configuration data /etc/ssh_config
    debug2: ssh_connect: needpriv 0
    debug1: Connecting to gibbonweb.net [67.205.14.72] port 22.
    debug1: Connection established.
    debug1: identity file /Users/johannes/.ssh/identity type -1
    debug3: Not a RSA1 key file /Users/johannes/.ssh/id_rsa.
    debug2: key_type_from_name: unknown key type '-----BEGIN'
    debug3: key_read: missing keytype
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug2: key_type_from_name: unknown key type '-----END'
    debug3: key_read: missing keytype
    debug1: identity file /Users/johannes/.ssh/id_rsa type 1
    debug3: Not a RSA1 key file /Users/johannes/.ssh/id_dsa.
    debug2: key_type_from_name: unknown key type '-----BEGIN'
    debug3: key_read: missing keytype
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug3: key_read: missing whitespace
    debug2: key_type_from_name: unknown key type '-----END'
    debug3: key_read: missing keytype
    debug1: identity file /Users/johannes/.ssh/id_dsa type 2
    debug1: Remote protocol version 2.0, remote software version OpenSSH_3.8.1p1 Debian-8.sarge.6
    debug1: match: OpenSSH_3.8.1p1 Debian-8.sarge.6 pat OpenSSH_3.*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_4.7
    debug2: fd 3 setting O_NONBLOCK
    debug1: Miscellaneous failure
    No credentials cache found
    
    debug1: Miscellaneous failure
    No credentials cache found
    
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
    debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
    debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: first_kex_follows 0 
    debug2: kex_parse_kexinit: reserved 0 
    debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha1,diffie-hellman-group1-sha1
    debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: none,zlib
    debug2: kex_parse_kexinit: none,zlib
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: 
    debug2: kex_parse_kexinit: first_kex_follows 0 
    debug2: kex_parse_kexinit: reserved 0 
    debug2: mac_setup: found hmac-md5
    debug1: kex: server->client aes128-cbc hmac-md5 none
    debug2: mac_setup: found hmac-md5
    debug1: kex: client->server aes128-cbc hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug2: dh_gen_key: priv key bits set: 131/256
    debug2: bits set: 516/1024
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug3: check_host_in_hostfile: filename /Users/johannes/.ssh/known_hosts
    debug3: check_host_in_hostfile: match line 2
    debug3: check_host_in_hostfile: filename /Users/johannes/.ssh/known_hosts
    debug3: check_host_in_hostfile: match line 3
    debug1: Host 'gibbonweb.net' is known and matches the RSA host key.
    debug1: Found key in /Users/johannes/.ssh/known_hosts:2
    debug2: bits set: 488/1024
    debug1: ssh_rsa_verify: signature correct
    debug2: kex_derive_keys
    debug2: set_newkeys: mode 1
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug2: set_newkeys: mode 0
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug2: service_accept: ssh-userauth
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug2: key: /Users/johannes/.ssh/identity (0x0)
    debug2: key: /Users/johannes/.ssh/id_rsa (0x3076e0)
    debug2: key: /Users/johannes/.ssh/id_dsa (0x3076b0)
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug3: start over, passed a different list publickey,password,keyboard-interactive
    debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password
    debug3: authmethod_lookup publickey
    debug3: remaining preferred: keyboard-interactive,password
    debug3: authmethod_is_enabled publickey
    debug1: Next authentication method: publickey
    debug1: Trying private key: /Users/johannes/.ssh/identity
    debug3: no such identity: /Users/johannes/.ssh/identity
    debug1: Offering public key: /Users/johannes/.ssh/id_rsa
    debug3: send_pubkey_test
    debug2: we sent a publickey packet, wait for reply
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: Offering public key: /Users/johannes/.ssh/id_dsa
    debug3: send_pubkey_test
    debug2: we sent a publickey packet, wait for reply
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug2: we did not send a packet, disable method
    debug3: authmethod_lookup keyboard-interactive
    debug3: remaining preferred: password
    debug3: authmethod_is_enabled keyboard-interactive
    debug1: Next authentication method: keyboard-interactive
    debug2: userauth_kbdint
    debug2: we sent a keyboard-interactive packet, wait for reply
    debug2: input_userauth_info_req
    debug2: input_userauth_info_req: num_prompts 1
    Password: 
    
    :(

    Code:
    debug1: identity file /Users/johannes/.ssh/id_dsa type 2
    scheint ja zu funktionieren bis zu dem Punkt
    Code:
    debug1: Miscellaneous failure
    No credentials cache found
    Liegt da vielleicht der Hund begraben?
     
  9. oneOeight

    oneOeight Mitglied

    Beiträge:
    50.706
    Zustimmungen:
    4.791
    Mitglied seit:
    23.11.2004
    der sshd auf dem debian scheint nicht für pubkey eingestellt zu sein...
    kannst du mal in der sshd_config gucken, ob "PubkeyAuthentication yes" gesetzt ist?
     
  10. CottonIJoe

    CottonIJoe Thread Starter Mitglied

    Beiträge:
    132
    Medien:
    3
    Zustimmungen:
    15
    Mitglied seit:
    23.01.2005
    Komm ich da ran? (Zur Info: Der Remote Server ist mein Dreamhost-Webspace. Also kein Root-Server!)
    Wo ist denn die sshd_config?
     
Die Seite wird geladen...
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Akzeptieren Weitere Informationen...