SSD zeigt keine Partiton mehr an

Roman78

Aktives Mitglied
Thread Starter
Registriert
02.10.2006
Beiträge
4.700
Ich habe hier eine SSD von der ich seit heute nicht mehr Starten kann. Installiert ist Hieg Sierra, das ist so eine SSD die ich zum testen immer überall rein stecke... :o ehhhh die ich zum testen in diversen Geräte mal anschließe :iD:. Gestern noch am iMac 2011 und lieft. Abgestöbselt und heute kam nur noch ein Ordner mit Fragezeichen. Nun habe ich die Platte mal per USB abgeschlossen und das Festplattendienstprogramm sagt mir die Platte sei unformatiert.

Diskutil sagt mir aber, dass immer noch was drauf ist.

Bildschirmfoto 2021-03-11 um 10.40.26.png


Nun gibt es eine Möglichkeit das wieder hin zu bekommen ohne neu zu installieren/formatieren?
 

Roman78

Aktives Mitglied
Thread Starter
Registriert
02.10.2006
Beiträge
4.700
Da sagt er mir, es wäre kein APFS container.

Bildschirmfoto 2021-03-11 um 12.10.50.png
 

dg2rbf

Aktives Mitglied
Registriert
08.05.2010
Beiträge
7.756
Hi,
Da hats dir die Partitionstabelle beschädigt, würde dieses System neu Installieren, bzw von einem Backup zurück holen.
Franz
 

Roman78

Aktives Mitglied
Thread Starter
Registriert
02.10.2006
Beiträge
4.700
Hi,
Da hats dir die Partitionstabelle beschädigt, würde dieses System neu Installieren, bzw von einem Backup zurück holen.
Franz

Das kann ja jeder. Hmmm und ich glaube ich hatte da noch was drauf was ich noch nicht gesichtert hatte....

wie geht das mit Gptfdisk?
 

oneOeight

Aktives Mitglied
Registriert
23.11.2004
Beiträge
57.481
Könntest auch ein gpt recover probieren, um den Backup GPT zu nutzen. Vielleicht steht da noch das Richtige drin.
gpt musst du nicht extra installieren.
 

Roman78

Aktives Mitglied
Thread Starter
Registriert
02.10.2006
Beiträge
4.700
ach ja.. gpt ist schon da, gptfdisk scheinbar nicht. Dann probiere ich das mal mit gpt.
 

Roman78

Aktives Mitglied
Thread Starter
Registriert
02.10.2006
Beiträge
4.700
whahaha... wie lustig.... Ich wollte mal gptfdisk installieren nach dieser Anleitung: http://macappstore.org/gptfdisk/

Ohne sudo sagt er: Need sudo access on macOS (e.g. the user roman needs to be an Administrator)!
und mit sudo: Don't run this as root!

ja was denn nu???
 

Roman78

Aktives Mitglied
Thread Starter
Registriert
02.10.2006
Beiträge
4.700
So, die GPT-Tabelle scheint in ordnung zu sein. Ich habe das hier mal gemacht: https://www.transscendsurvival.org/2019/02/27/mac-osx-fixing-gpt-and-pmbr-tables/

Ich denke, dass der APFS-Container defekt ist.

sh-3.2# mount_apfs /dev/disk2s2 /Users/
mount_apfs: volume could not be mounted: Inappropriate file type or format

sh-3.2# diskutil verifyVolume /dev/disk2s2
Started file system verification on disk2s2
Error: -69564: Unable to find an APFS Container Reference

Und diskutil apfs list ueigt nur die interne Platte.

Diskutil info zeigt: No Filesystem

Code:
sh-3.2# diskutil info /dev/disk2
   Device Identifier:         disk2
   Device Node:               /dev/disk2
   Whole:                     Yes
   Part of Whole:             disk2
   Device / Media Name:       2115

   Volume Name:               Not applicable (no file system)
   Mounted:                   Not applicable (no file system)
   File System:               None

   Content (IOContent):       GUID_partition_scheme
   OS Can Be Installed:       No
   Media Type:                Generic
   Protocol:                  USB
   SMART Status:              Not Supported

   Disk Size:                 240.1 GB (240057409536 Bytes) (exactly 468862128 512-Byte-Units)
   Device Block Size:         512 Bytes

   Read-Only Media:           No
   Read-Only Volume:          Not applicable (no file system)

   Device Location:           External
   Removable Media:           Fixed

   Solid State:               Info not available
   Virtual:                   No
 
Zuletzt bearbeitet:

Roman78

Aktives Mitglied
Thread Starter
Registriert
02.10.2006
Beiträge
4.700
Ich habe jetzt einfach mal ein Recovery Programm laufen lasen, und das findet in der tat Daten in einem APFS Container.
 

oneOeight

Aktives Mitglied
Registriert
23.11.2004
Beiträge
57.481
Warum war denn in dem HexDump HFSJ zu lesen?
Das geht ja nicht im APFS Container.
Operation auf APFS übrigens immer auf rdisk statt disk.
 

Roman78

Aktives Mitglied
Thread Starter
Registriert
02.10.2006
Beiträge
4.700
Das wundert mich auch. Beim Scannen habe ich jedenfalls eine APFS als auch eine HFS+ gefunden. Ich weiß nicht mehr wie ich High Sierra installiert habe und ob da vorher noch etwas anderes drauf war. Es kann sein, dass dort vorher Sierra oder El Capitan drauf war. Hmmmm obwohl ich eigentlich sicher bin, dass ich die Platte neu gekauft hatte und direkt HS installiert hatte. Aber bei dem Wust an Festplatten hier bin ich mir da nicht sicher. Jedenfalls ist dort noch ein Backup drauf von meinem Mini, das habe ich mit ErasueUs gefunden, allerdings konnte der die Daten nicht wieder herstellen.

Ich mache gerade ein Image von der Partition mit dd, mal sehen was daraus kommt. Nur das dauert mit USB 2. Irgendwie funktioniert mein ThunderBold USB Adapter nicht auf einem MBP 2010 mit Catalina. Und auf dem 2011er ist gerade mein Sohn Peppa Wutz am gucken.
 

WeDoTheRest

Aktives Mitglied
Registriert
19.10.2012
Beiträge
6.685
Meiner geht auch nur an MBPs zuverlässig (die blöderweise selbst USB3 haben.
Gedacht war er für meinen 2011er iMac. Da tat er mal kurz und seitdem nie wieder.......
 

Roman78

Aktives Mitglied
Thread Starter
Registriert
02.10.2006
Beiträge
4.700
Hmmm am iMac 2011 und MBP 2011 läuft das Ding ohne Probleme.
 

WeDoTheRest

Aktives Mitglied
Registriert
19.10.2012
Beiträge
6.685
Bei mir leider nicht. Hab alles durch. Anderes OSX usw. Er wird zwar im Systemprofiler erkannt, funktioniert aber nicht. Weder mit HDDs noch mit Sticks (USB 2+3).
An unseren 2012er MBPs...... zack... geht.
 
Oben