Soylatte PPC

naderda

Registriert
Thread Starter
Mitglied seit
23.05.2011
Beiträge
4
Hallo Liebes Forum,

ich scheitere grade an dem Vorhaben Soylatte auf meinem PPC G5 ,it Mac OS X 10.5.8 zum Laufen zu bringen.

Ich habe die Anleitungen in den anderen Posts gelesen und habe es auch geschafft soylatte zu installieren und die nötigen Eintragungen in der PATH Variable vorzunehmen, so dass wenn ich im Terminal bin die richtigen Einstellungen geladen werden

which java
/Applications/openjdk7/bin/java

java -version
openjdk version "1.7.0-internal"
OpenJDK Runtime Environment (build 1.7.0-internal-landonf_2009_12_16_12_54-b00)
OpenJDK Zero VM (build 17.0-b05, interpreted mode)

Das Problem ist leider, dass folgende Fehlermeldung erscheint, wenn ich Serviio starte, das Programm aufgrund dessen ich JAVA6 benötige:
"No compatible version of Java 1.6+ is available"
Dort kann ich die Java Preferences öffnen, doch stehen hier nur die alten Versionen zur Verfügung.
J2SE 5.0
J2SE 1.4.2

Nicht jedoch die neu installierte Version, die im Terminal erkannt wird.

Was fehlt? Was mach ich falsch?

Vielen Dank für Eure Hilfe bereits im voraus!

naderda
 

naderda

Registriert
Thread Starter
Mitglied seit
23.05.2011
Beiträge
4
Soylatte verweigert sich noch immer

Hallo Liebe Experten,

ohne Ungeduld an den Tag legen zu wollen, frage ich einfach nochmals nach, da ich das Problem trotz Recherche noch immer nicht beheben konnte.

Danke im voraus!
Grüße
naderda
 

MattMacs

Mitglied
Mitglied seit
18.11.2004
Beiträge
499
Korrigiert mich bitte falls ich falsch liege, aber wenn Java 6 benötigt wird, dann solltest du auch Java 6 installieren und nicht Java 7.

(OT: klasse Uhrzeit :D)
 

naderda

Registriert
Thread Starter
Mitglied seit
23.05.2011
Beiträge
4
Danke für Deine Antwort.
An sich würde ich davon ausgehen, dass die Versionen aufwärtskompatibel sind. Also sollte ein Programm, das 1.6 benötigt auch mit 1.7 laufen. Die Angeben sind doch Mindestangaben, oder?

Aber davon unabhängig ist ja mein Problem, dass die neue Version im Terminla erkannt wird, in den Java-Preferences jedoch nichtmal auftaucht.
Wie kann ich das lösen?

Grüße
naderda
 
Zuletzt bearbeitet:

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
55.725
normal sind die aufwärts kompatibel...
wie startest du denn das programm?
im terminal mit
java -jar programm.jar
?

um die installierte 7 zu nutzen, musst du es schon im terminal darüber starten...
das wird auch X11 nutzen statt aqua, eventuell musst du es daher im X11 xterm starten.
 

naderda

Registriert
Thread Starter
Mitglied seit
23.05.2011
Beiträge
4
Also, hatte es bisher nur über das normale Terminal versucht und heute nun den Test mit xterm gestartet.
Da es sich um eine datei.app handelt, habe ich es im xterm mit "open datei" versucht. Programm startet und weist dann daraufhin, dass nicht die richtige Java-Version installiert ist und bietet an die Java-Preferences zu öffnen. Also alles wie gewohnt.

Danke für Deinen Vorschlag und Deine Mühe.
Hast Du ielleicht noch einen?

Danke im voraus und beste Grüße
naderda
 
Oben