Benutzerdefinierte Suche

Service-Administration vom Terminal aus

  1. Heine

    Heine Thread Starter MacUser Mitglied

    Mitglied seit:
    26.10.2005
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo.

    Ich weiß nicht, ob ich hier überhaupt richtig bin, aber ich habe da eine Frage.
    ich habe auf einem 10.4 Server die /etc/snmpd.conf geändert. Damit der Dienst die Änderungen auch mitbekommt, muss ich ihn ja neu starten. Kann ich das auch ohne den ganzen Server durhczubooten machen?

    Vielen Dank schon jetzt,

    Heine
     
    Heine, 27.10.2005
    #1
  2. maceis

    maceis MacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Die übliche Methode zum Neueinlesen der Konfiguration ist
    Code:
    sudo killall -HUP snmpd
    Ob der Dienst snmpd irgendwelche Besonderheiten aufweist, weiss ich nicht, aber ein Versuch kann wohl nicht schaden ;).
     
    maceis, 27.10.2005
    #2
  3. Heine

    Heine Thread Starter MacUser Mitglied

    Mitglied seit:
    26.10.2005
    Beiträge:
    5
    Zustimmungen:
    0
    Hm, den Versuch habe ich gestartet mit dem "Erfolg", dass der snmpd wirklich weg ist. Über das Interface habe ich ihn dann wieder gestartet und von außen eine Anfrage gemacht, woraufhin er dann wieder terminiert.
    Täusche ich mich, oder ist das ein Fehlverhalten? :(

    Naja, wenn mir wer was dazu sagen kann, dann bitte ich um Hilfe!

    Danke, Heine
     
    Heine, 02.11.2005
    #3
  4. wegus

    wegus MacUser Mitglied

    Mitglied seit:
    13.09.2004
    Beiträge:
    14.984
    Zustimmungen:
    1.546
    das ist meist ein eindeutiges Zeichen einer fehlerhaften Konfiguration. Was sagen denn die Log-Dateien???
     
    wegus, 02.11.2005
    #4
  5. maceis

    maceis MacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Mit -HUP sollte der Diesnt eigentlich nicht "weg" sein, sondern seine Konfiguration neu einlesen.
    Dass er das nicht tut, kann z.B. an einer fehlerhaften Implementierung liegen, was ich aber zunächst nicht vermuten wurde.
    Dass Du den Dienst auch nicht erfolgreich wieder starten kannst, deutet darauf hin, dass möglicherweise die Konfiguration fehlerhaft ist, was auch das Verhalten bei "killall -HUP" erklären würde.

    An Deiner Stelle, würde ich die ursprüngliche "/etc/snmpd.conf" wieder zurückkopieren und testen, wie sich snmpd dann verhält.

    Was ist das übrigens für ein "Interface", von dem Du da sprichst?

    [edit]Das kommt davon, wenn man ein Fenster so lange offen hat - Morgen wegus ;).[/edit]
     
    maceis, 02.11.2005
    #5
Die Seite wird geladen...
Ähnliche Themen - Service Administration vom
  1. mds
    Antworten:
    0
    Aufrufe:
    144
  2. g4user
    Antworten:
    0
    Aufrufe:
    530
    g4user
    04.03.2015
  3. akumetsu
    Antworten:
    10
    Aufrufe:
    1.484
    akumetsu
    21.11.2014
  4. Lumimac
    Antworten:
    2
    Aufrufe:
    6.742
    Lumimac
    03.10.2014
  5. Lyn
    Antworten:
    0
    Aufrufe:
    282