Seit neuer Festplatte Chaos bei Zugriffsrechten, auch nach Neuinstallation?

XQC

Mitglied
Thread Starter
Mitglied seit
29.01.2005
Beiträge
266
Ich habe vor etwa drei Wochen von einer WD 1TB auf die WD 750GB mit 7200rpm (WD7500BPKT) gewechselt, da es mit der 1TB Platte sehr langsam beim Arbeiten war.

Seitdem aber macht OSX ziemlich Probleme... es fängt damit an, dass der Bootvorgang sehr oft beim drehenden Kreisel stehen bleibt. Verbose Boot mit CMD+V bringt auch keine weiteren Erkenntnisse, da es ab irgendeiner Zeile einfach nicht mehr weitergeht.

Ist der Bootvorgang jedoch erfolgreich, meckert etwa die Hälfte der Programme über fehlende Zugriffsrechte und dass Fortschritte nicht gespeichert werden können. Neue Programme lassen sich auch nicht mehr installieren, es quittiert immer mit "Fehler bei Installation, Dateien konnten nicht geschrieben werden"

Das ist aber auch nicht IMMER so. Ab und zu schafft es das Macbook es zu booten und nach Login meckern keine Programme. Dann kann man den Rechner tagelang durchlaufen lassen, ohne das Probleme auftreten.

Jedoch ist mir auch aufgefallen, dass z.B. die Installation von refit überhaupt nicht mehr klappt.

Was ich bisher dagegen versucht habe:
- Zugriffsrechte und Volume gefühlt 50mal über Snow Leopard-DVD repariert
- Archive and Install
- Alles formatiert und von einem funktionierenden Time Machine Backup alles wieder draufgespielt

Aber selbst dann sind die Fehler nicht verschwunden. Also sah ich es als letzte Möglichkeit wirklich alles zu formatieren, OSX neu zu installieren und nochmal von Grund auf zu konfigurieren, da ich dachte, bei meinem Benutzerprofil muss irgendwo der Wurm drin sein...
ABER auch nach frischer Neuinstallation habe ich das Problem mit den Zugriffsrechten immer noch...!

Somit denke ich dass es eigentlich nur an der neuen Festplatte liegen kann, da die alten keine Probleme in der Hinsicht machten.
Allerdings finde ich auch das verwunderlich, weil z.B. das Arbeiten mit Windows über Boot Camp keinerlei Probleme macht. Smart Status und diverse Festplattenchecks haben auch keine Probleme festgestellt. Und wie gesagt, sollte mal ein Bootvorgang bei OSX erfolgreich sein und meckert kein Programm nach dem Login, könnte man mit dem Rechner wenn man es nur im Standby-Modus hält 10 Tage lang ohne Probleme durcharbeiten (was auch einmal der Fall war).

Hat noch irgendjemand Ideen...? Google hilft mir auch nicht mehr weiter...

Edit:
Es handelt sich übrigens um ein Macbook Pro 13 mit C2D (Mitte 2009)
 
Zuletzt bearbeitet:

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
55.725
das FPDP meldet ständig irgendwelche sachen bei zugriffsrechten, das ist normal und kein fehler...
daran werden deine probleme also nicht liegen.

windows beschädigt aber wohl öfters die mac partition, wie man hier in einigen threads liest...
 

XQC

Mitglied
Thread Starter
Mitglied seit
29.01.2005
Beiträge
266
das FPDP meldet ständig irgendwelche sachen bei zugriffsrechten, das ist normal und kein fehler...
daran werden deine probleme also nicht liegen.

windows beschädigt aber wohl öfters die mac partition, wie man hier in einigen threads liest...
Nach der kompletten Neuinstallation habe ich übrigens auch kein Windows mehr auf der Festplatte...
 

bjoern07

Aktives Mitglied
Mitglied seit
05.02.2007
Beiträge
5.311
Du hast die neue Festplatte nicht zufällig mit Mac OS Extended (Groß- und Kleinschreibung) formatiert?
 

XQC

Mitglied
Thread Starter
Mitglied seit
29.01.2005
Beiträge
266
Nein, ganz normal mit Mac OS Extended (Journaled)
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
55.725
vielleicht liefert die konsole mehr details zu dem problem...
so ist schwer abzuschätzen warum da irgendwelche rechte nicht stimmen sollte, so dass sich programme darüber beschweren.
hast du eventuell getrennten admin und user?
oder beim wiederherstellen aus dem TM backup unterschiedliche usernamen bzw nummern?
 

XQC

Mitglied
Thread Starter
Mitglied seit
29.01.2005
Beiträge
266
Time Machine kann man jetzt ausklammern.
Ich habe die Platte gestern komplett gelöscht und formatiert und jetzt ist nur noch eine Partition mit einem frischen OSX ohne Altlasten vorhanden. Ansonsten auch kein Windows oder weiterer Schnickschnack.

Es gibt nur einen Adminuser (mich)

Die Konsole spuckt auch nur Fehlermeldungen wie diese aus:

22.04.11 14:24:11 /Applications/Microsoft Office 2011/Microsoft Outlook.app/Contents/MacOS/Microsoft Outlook[202] MDS Error: unable to create user DBs in /var/folders/vS/vSWLN8l8Hku+fmpCeK8FdE+++TI/-Caches-//mds

23.04.11 11:11:46 /Applications/iTunes.app/Contents/MacOS/iTunes[182] MDS Error: unable to create user DBs in /var/folders/vS/vSWLN8l8Hku+fmpCeK8FdE+++TI/-Caches-//mds

23.04.11 10:09:23 MagicPrefs[142] Failed to copy preferences pane (/Applications/MagicPrefs.app/Contents/Resources/MagicPrefs.prefPane to /Users/xxx/Library/PreferencePanes/MagicPrefs.prefPane).
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
55.725
vielleicht solltest du mal gucken was mit dem ordner da nicht stimmt:
ls -l /var/folders/vS/vSWLN8l8Hku+fmpCeK8FdE+++TI/
die ordner dort sollten dann deinem user gehören...
 

XQC

Mitglied
Thread Starter
Mitglied seit
29.01.2005
Beiträge
266
Ja, tun sie auch...

(Ich): Lesen & Schreiben
staff: Nur Lesen
everyone: Nur Lesen

Könnte ja überlegen, ob man dem Ordner var nicht einfach 777 gibt, aber dann wäre das so eine Sache mit der Sicherheit...
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
55.725
var ist ja nicht das problem, sondern nur der mds oder -Caches-
 
Oben