Radeon PCI und X11

  1. tolstoi

    tolstoi Thread Starter

    Hallo,
    habe ein wohl bekanntes Problem mit meiner Radeon 7000 PCI. X-Windows hat Probleme ein GUI zu starten und bricht immer ab.
    Bei der Installation habe ich mehrere ATI Optionen zur Verfügung stehen und auch eine Radeon Option. Damit sind aber wohl nur die AGP Versionen gemeint, so wie ich das verstanden habe.
    Welche Optionen kann ich BootX für die Installation mitgeben?
    Die Radeon scheint der einzige Stolperstein bei der Installation von Linux bei mir zu sein - probiere gerade Debian und Mandrake aus.

    Für Tips wäre ich echt dankbar....

    Grüsse

    Tolstoi
     
    tolstoi, 20.01.2004
  2. heiner geissler

    heiner geisslerMacUser Mitglied

    Mitglied seit:
    24.10.2003
    Beiträge:
    12
    Zustimmungen:
    0
    Debian

    Hallo.
    Habe mit der 7500er ähnliche Probleme beim installieren eines Debian gehabt.
    Habs aber nur einmal probiert und dann sein gelassen und Yellowdog genommen.
     
    heiner geissler, 17.02.2004
  3. jay

    jayMacUser Mitglied

    Mitglied seit:
    12.08.2003
    Beiträge:
    154
    Zustimmungen:
    0
    hallo!

    welche Fehlermeldung wird beim Abbruch ausgegeben? Ansonsten gib mal

    lspci | grep VGA

    ein. dann müsste dir deine grafikkarte mit der zugehörigen bus-id (zB.: 02:00.0) angezeigt werden. diese trägst du dann in /etc/X11/XF86Config unter "Section Device" ein (zB BusID "PCI:2:0:0"). Dannach müsste es mit deinem Xserver auch klappen.

    hth, jay

    btw. Welche Version des XServer hast du denn installiert? Normalerweise müsste diese Version der Karte ohne Probleme unterstützt werden. Wenn es noch immer nicht funktionieren sollte, kopiere mal die Errormessages die der XServer auswirft und meld dich noch mal.
     
  4. tolstoi

    tolstoi Thread Starter

    Hi,
    erstmal danke für die Tips.
    Als ich anfing Yellow Dog zu installieren, ging alles problemlos vor sich. Konnte meine gewünschte Einstellung von 832x624 mit Grafikbeschleunigung vornehmen.
    Nach mehreren Installationen (wie man das halt so macht - als Neuling - verschiedene Konfigurationen ausprobieren, und so ;) ), brach der Installer immer irgendwann während der Installation ab. Dann ershien eine ziemlich lange "Gtk critical ...." Fehlermeldung.
    Habe dann irgendwann meinen Rechner total auseinandergenommen und wieder zusammengebaut, mit dem Effekt, das der Insaller jetzt die Installation zumindest beendete. Dann, genau in dem Augenblick, wo ich auf den Button "Weiter", zum Neustart des frisch installierten Systems drücke, erscheint wieder diese "Gtk" Meldung.
    Nach einiger Zeit habe ich mir gedacht, wenn die Installation abgeschlossen ist, könnte diese Fehlermeldung eigentlich nichts mehr anrichten. Habe dann gebootet und festgestellt, das ich also tatsächlich die Installation geschafft habe. Das ist der Punkt an dem ich jetzt stehe. Wenn ich installiere, weiß ich also, das ich zum Schluß eine Fehlermeldung kriege und die Installation aber geglückt ist. Verstehe aber immer noch nicht warum das früher geklappt hat.

    Auf der XFree86 Seite ( http://www.xfree86.org/~dawes/pre-4.4/radeon.4.html) steht ausdrücklich, das der "radeon" Treiber von XFree auch die PCI Version unterstützt. Mittlerweile konfiguriere ich XF86Config nachträglich manuell.
    Erschwerend kommt wohl noch dazu, das ich einen ganz alten 14er MultipleScan habe, der durch den VGA-Adapter vom System nicht als solcher erkannt wird.
    Das einzige was ich nicht hinbekomme im Augenblick ist 3D Grafikbeschleunigung. Und ich bin noch auf der Suche nach Modelines für ältere Monitore (Apple), wenn es sowas überhaupt gibt, oder es überhaupt nötig ist.

    Grüsse

    tolstoi
     
    tolstoi, 17.02.2004
  5. jay

    jayMacUser Mitglied

    Mitglied seit:
    12.08.2003
    Beiträge:
    154
    Zustimmungen:
    0
    hallo!

    mit diesen daten

    http://docs.info.apple.com/article.html?artnum=112536

    dürfte es mit deinem monitor auch klappen. Für die DRI-Unterstützung musst den Kernel mit DRI unterstützung neu kompilieren und der XF86Config die Optionen

    LOAD "dri"
    LOAD "GLCore"
    LOAD "glx"

    in der Section Module hinzufügen. Und am Ende des Files, wenn kommentiert, die Section DRI "dekommentieren". Dann müsste es funktionieren. (Berichtigt mich wenn ich hier falsche Informationen von mir gebe :D). Ansonsten findest du unter

    http://dri.sourceforge.net/cgi-bin/moin.cgi/

    weitere Informationen!! Viel Spaß!

    hth,
    jay
     
Die Seite wird geladen...
Ähnliche Themen - Radeon PCI X11
  1. EnGL
    Antworten:
    4
    Aufrufe:
    421
  2. HJOrtmann
    Antworten:
    1
    Aufrufe:
    266
    HJOrtmann
    12.08.2016
  3. Ezekeel
    Antworten:
    33
    Aufrufe:
    5.593
    1Valla7Foldum4A
    29.08.2014
  4. PowermacG4
    Antworten:
    2
    Aufrufe:
    2.198
    eismeervogel
    15.04.2009
  5. McOdysseus
    Antworten:
    5
    Aufrufe:
    628
    McOdysseus
    16.08.2006