1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Prolog, XPCE und andere, hässliche Gestalten ...

Dieses Thema im Forum "Andere" wurde erstellt von [BliZZarD], 18.01.2004.

  1. [BliZZarD]

    [BliZZarD] Thread Starter MacUser Mitglied

    Mitglied seit:
    19.09.2003
    Beiträge:
    93
    Zustimmungen:
    0
    Prolog, XPCE und X11 ...

    Morgen allerseits.

    Leider muss ich - rechtzeitig zum lösen eventueller Hausfaufgaben - folgendes Problem feststellen: ich möchte mit Prolog/XPCE eine Grafik zeichnen lassen, rekursiv. Der Quellcode stimmt, läuft mit Windows. Soweit so gut.

    Wenn ich das Prolog-Script allerdings auf meinem kleinen PowerBook (12", Panther, X11 & Prolog installiert) ablaufen lassen möchte, erhalte ich folgenden Fehler:
    Mein Ablauf - der zu diesem Fehler führt - ist folgender:
    X11 starten, das automatisch aufpoppende xterm schließen
    Terminal.app starten
    'prolog' eingeben, Enter ... Prolog startet (.bash_profile-Alias)
    consult('/Pfad/Zur/Datei)., Rückgabe: Yes.
    start. (Sorgt für den Programmablauf)

    Was genau ist da kaputt? Fehlen irgendwelche Rechte auf X11? Variablen? Oder einfach nur Futter?
     
  2. [BliZZarD]

    [BliZZarD] Thread Starter MacUser Mitglied

    Mitglied seit:
    19.09.2003
    Beiträge:
    93
    Zustimmungen:
    0
    Ok, Problem gelöst ... ich Pfosten hab' Prolog aus Terminal.app und nicht aus dem xterm gestartet .... jetzt klappt's ... :D
     
Die Seite wird geladen...

Diese Seite empfehlen