Prolog, XPCE und andere, hässliche Gestalten ...

  1. [BliZZarD]

    [BliZZarD] Thread StarterMacUser Mitglied

    Mitglied seit:
    19.09.2003
    Beiträge:
    93
    Zustimmungen:
    0
    Prolog, XPCE und X11 ...

    Morgen allerseits.

    Leider muss ich - rechtzeitig zum lösen eventueller Hausfaufgaben - folgendes Problem feststellen: ich möchte mit Prolog/XPCE eine Grafik zeichnen lassen, rekursiv. Der Quellcode stimmt, läuft mit Windows. Soweit so gut.

    Wenn ich das Prolog-Script allerdings auf meinem kleinen PowerBook (12", Panther, X11 & Prolog installiert) ablaufen lassen möchte, erhalte ich folgenden Fehler:
    Mein Ablauf - der zu diesem Fehler führt - ist folgender:
    X11 starten, das automatisch aufpoppende xterm schließen
    Terminal.app starten
    'prolog' eingeben, Enter ... Prolog startet (.bash_profile-Alias)
    consult('/Pfad/Zur/Datei)., Rückgabe: Yes.
    start. (Sorgt für den Programmablauf)

    Was genau ist da kaputt? Fehlen irgendwelche Rechte auf X11? Variablen? Oder einfach nur Futter?
     
    [BliZZarD], 18.01.2004
  2. [BliZZarD]

    [BliZZarD] Thread StarterMacUser Mitglied

    Mitglied seit:
    19.09.2003
    Beiträge:
    93
    Zustimmungen:
    0
    Ok, Problem gelöst ... ich Pfosten hab' Prolog aus Terminal.app und nicht aus dem xterm gestartet .... jetzt klappt's ... :D
     
    [BliZZarD], 18.01.2004
Die Seite wird geladen...
Ähnliche Themen - Prolog XPCE andere
  1. maggie2
    Antworten:
    3
    Aufrufe:
    89
    maggie2
    12.07.2017
  2. bogues
    Antworten:
    12
    Aufrufe:
    888
    mreball
    23.06.2014
  3. b25
    Antworten:
    25
    Aufrufe:
    3.310
    sevenofnine
    23.08.2014
  4. Violettus
    Antworten:
    6
    Aufrufe:
    711
    Violettus
    28.05.2012
  5. Malcolm

    SWI Prolog + GUI

    Malcolm, 10.07.2004, im Forum: Andere
    Antworten:
    7
    Aufrufe:
    4.526
    Miesnik
    03.10.2005