Probleme mit Umlauten auf Linux-Server.

  1. bassman.kh

    bassman.kh Thread StarterMacUser Mitglied

    Mitglied seit:
    12.03.2005
    Beiträge:
    377
    Zustimmungen:
    0
    Hallo, habe mir auf einem alten Rechner Linux-Ubuntu installiert. Dann habe ich eine Homepage mit "Rapid Weaver" gestalltet und Sie auf meinem Server geladen. Nun habe ich ein großes Problem. Wenn ich die Page auf meinem Server anschaue, dann werden alle Umlaute bei Safari als Fragezeichen dargestellt! Bei Firefox ist das genauso. Ach ja, ich habe die Page in einen Ordner exportieren lassen (beim kontrollieren aus dem Ordner war noch alles klar!), dann habe ich den Ordner auf meinen Server kopiert. Von da an habe ich Probleme mit den Umlauten!!!
    Kann mir hier einer Helfen???

    PS: Auf dem Ubuntu-Server läuft das aktuelle Apache2.
     
    bassman.kh, 21.03.2006
  2. Incoming1983

    Incoming1983MacUser Mitglied

    Mitglied seit:
    23.07.2005
    Beiträge:
    7.545
    Zustimmungen:
    1
    Dein Character Encoding ist falsch. Entweder fixen, oder named entities benutzen (ist sowieso anzuraten).
     
    Incoming1983, 21.03.2006
  3. 2nd

    2ndMacUser Mitglied

    Mitglied seit:
    25.07.2004
    Beiträge:
    8.901
    Zustimmungen:
    242
  4. bassman.kh

    bassman.kh Thread StarterMacUser Mitglied

    Mitglied seit:
    12.03.2005
    Beiträge:
    377
    Zustimmungen:
    0
    ???

    Wie fixe ich den meinen Character Encoding?

    Warum ist die Page den in Rapid Weaver den o.k.? Ich meine ich habe Sie probehalber auf meinen 1und1 Web-Server hoch geladen und siehe da, sieht doch Top aus. Nur halt nicht auf meinem Server zuhause!
     
    bassman.kh, 21.03.2006
  5. bassman.kh

    bassman.kh Thread StarterMacUser Mitglied

    Mitglied seit:
    12.03.2005
    Beiträge:
    377
    Zustimmungen:
    0
    Heißt das, ich muss alle Umlaute per Hand ändern?

    Liegt das Problem nun an meinem Apache2-Server?
     
    bassman.kh, 21.03.2006
  6. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.168
    Zustimmungen:
    3.887
    nein, das problem liegt wohl eher an dem
    <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
    oder was immer du charset stehen hast...

    kann sein, dass dein ftp client das ganze konvertiert hat beim hochladen auf den 1&1 server....
     
    oneOeight, 21.03.2006
  7. bassman.kh

    bassman.kh Thread StarterMacUser Mitglied

    Mitglied seit:
    12.03.2005
    Beiträge:
    377
    Zustimmungen:
    0
    Und wie kann ich das auf meinem Linux-Server ändern?
    Könnte mir einer eine kleine Anleitung schreiben?
     
    bassman.kh, 21.03.2006
  8. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.168
    Zustimmungen:
    3.887
    das ändert man nicht auf dem server, sondern auf der html seite...
     
    oneOeight, 21.03.2006
  9. Incoming1983

    Incoming1983MacUser Mitglied

    Mitglied seit:
    23.07.2005
    Beiträge:
    7.545
    Zustimmungen:
    1
    Man kanns sowohl am Server als auch an der Seite ändern.
    Das Encoding kann im http Header übergeben werden, oder auch im Dokument selber.
    Es sollte aber nicht zweimal übergeben werden.

    Um Probleme zu vermeiden sollte man ohnehin nur mit named entities arbeiten (&uml; &gt etc. pp), dann braucht man sich keine Gedanken darum zu machen.
     
    Incoming1983, 21.03.2006
  10. bassman.kh

    bassman.kh Thread StarterMacUser Mitglied

    Mitglied seit:
    12.03.2005
    Beiträge:
    377
    Zustimmungen:
    0
    ok ok, ich oute mich jetzt als absuluter Laie was dies betrifft. Ich habe die Page mit Rapid Weaver gemacht. Kann ich dort irgendwo ein Häkchen setzten das es funktioniert oder so?
    Oder könnte mir jemand ein HowTo schreiben das es klappt, sei es am Server oder am Rapid Weaver???
    Wäre euch sehr dankbar.
     
    bassman.kh, 21.03.2006
Die Seite wird geladen...
Ähnliche Themen - Probleme Umlauten auf
  1. rockyV
    Antworten:
    5
    Aufrufe:
    564
    MacMaitre
    02.04.2017
  2. Barons
    Antworten:
    6
    Aufrufe:
    676
  3. weblehrling
    Antworten:
    3
    Aufrufe:
    372
    Bert H.
    23.07.2016
  4. bigB
    Antworten:
    15
    Aufrufe:
    1.184
    oneOeight
    19.01.2009
  5. chell
    Antworten:
    14
    Aufrufe:
    1.278