Probleme mit Eclipse mit C#, Mono und XSP aufm MAC

Dieses Thema im Forum "Mac OS X Entwickler, Programmierer" wurde erstellt von rincel, 11.07.2005.

  1. rincel

    rincel Thread Starter MacUser Mitglied

    Beiträge:
    11
    Zustimmungen:
    0
    MacUser seit:
    05.06.2005
    Hallo Leute,

    Ich bin geradezu am verzweifeln. Ich versuche schon den ganzen Tag Eclipse mit dem improve C#-Plugin zu verheiraten. Es klappt einfach nicht.

    ---

    Ich möchte gern mit Mono/.Net aufm Mac entwickeln. Hier schien mir nach längerem Suchen Eclipse die ideale Lösung zu sein, da ich Konsole-, aber auch Web-Anwendungen entwickeln kann.

    Was am Anfang perfekt zu sein schien, entpuppt sich nun als Horrorszenario.
    Die Installation klappt eigentlich ganz gut, doch das Zusammenspiel bekomme ich nicht hin. Ich schaffe es einfach nicht C# unter Eclipse zu kompilieren. Auf der Kommandozeile geht es ohne Probleme. Auch starten kann ich die Programme. Doch die Integration ins IDE krieg ich nicht gebacken.

    Ausserdem bekomme ich mod_mono einfach nicht installiert. Die Installation über Darwinports steigt immer mit ner Fehlermeldung beim Kompilieren des XSP aus. Hier komm ich einfach nicht weiter, da ich mit der Meldung nichts anfangen kann.

    ---

    Hat jemand vielleicht ne Step-By-Step-Anleitung wie ich Mono und mod_mono mit Eclipse aufm Mac zum laufen kriege? Ich weiss einfach nicht mehr weiter.



    Meine Schritte:
    1. Ich habe Eclipse heruntergeladen und installiert/kopiert.

    2. Ich habe Mono als Pkg installiert (heruntergeladen von Go-Mono) und danach auch über Drawin-Ports (weiss nicht, wie ich das PKG deinstallieren kann). Hab jetzt also 2x Mono drauf. einmal unter Library/Framework und einmal opt/local.

    3. Über die Eclipse-SoftwareUpdates habe ich das improve-C#-plugin ohne Probleme installiert. Unter New/Files habe ich jetzt C#-File. Hier kann ich - leider ohne Intellisense - editieren. Nur wie sag ich Eclipse, wie und womit er kompilieren soll? Auf der Improve-Seite klingt es so, als ob es automatisch funktioniert. Tut es aber nicht.

    4. Ich habe ausserdem versucht mod_mono über Darwin-Ports zu installieren. Hier bekomme ich beim Kompilieren des XSP einen Fehler und der Vorgang bricht ab. scheint nen Bug zu sein, der noch nicht behoben wurde (bugzilla.darwinports.org). Hat da jemand vielleicht nen Work-Around?

    ---

    Bitte helft mir... Ich weiss einfach nicht mehr weiter. Hat jemand ähnliche Erfahrungen gemacht und konnte einzelne Probleme lösen?

    Ich bin für jegliche Tipps die mir weiterhelfen könnten dankbar.


    lg
    rincel
     
Die Seite wird geladen...

Diese Seite empfehlen