Benutzerdefinierte Suche

<? Probleme beim Löschen des Alt-Textes eines Bildes ?>

  1. mactrisha

    mactrisha Thread StarterMacUser Mitglied

    Mitglied seit:
    27.11.2003
    Beiträge:
    683
    Medien:
    3
    Zustimmungen:
    4
    Probleme beim Löschen des Alt-Textes eines Bildes

    Hi all,

    ich habe Bilder in eine Tabelle eingefügt. GoLive6.0 fügt diesen Bilder dann selbstständig einen Alt-Text hinzu:

    Code:
    alt=  height=122
    und zwar immer die jeweilige Höhe des Bildes. Dieser Alt-Text macht aber in Explorer unschöne Bemerkungen, die ich nicht haben will. Lösche ich diesen Alt-Text einfach, dann verschieben sich meine Tabellenzellen komplett. Oder GoLive fügt dann die Breite als alt width ein. Wenn ich den Quellcode editiere, ist beim nächsten Öffnen der Seite entweder wieder ein alt drin oder die Tabelle verschoben, obwohl sie feste Größen für die Zellen hat. Habe ich da eine Voreinstellung übersehen, die diese Alt-Texte automatisch setzt oder was mache ich falsch. In html kann man das alt doch weglassen, oder?

    Salü,
    mactrisha.
     
    mactrisha, 04.08.2004
  2. ThaHammer

    ThaHammerMacUser Mitglied

    Mitglied seit:
    01.06.2004
    Beiträge:
    3.277
    Zustimmungen:
    13
    schreibe statt nur alt= mal das: alt=""

    so kenne ich das jedenfalls! :D
     
    ThaHammer, 09.08.2004
  3. aligde

    aligdeMacUser Mitglied

    Mitglied seit:
    24.10.2003
    Beiträge:
    87
    Zustimmungen:
    0
    Benutze Homesite 5 von Macromedia!

    so kenne ich das jedenfalls! :p
     
    aligde, 09.08.2004
  4. Katrin

    KatrinMacUser Mitglied

    Mitglied seit:
    12.07.2002
    Beiträge:
    326
    Zustimmungen:
    3
    Hallo mactrisha,

    um möglichst W3C-konformes HTML zu erzeugen, sollten Attribute stets in Anführungszeichen geschrieben werden. Schau doch mal nach, ob du unter "Goive" > "Web-Einstellungen" die Option "Attribute in Anführungszeichen" auf "Immer" gestellt hast. Notfalls kannst du das alt leer lassen (alt=""), es empfiehlt sich aber aus Usabilitygründen für Textbrowser, Screenreader und sehbehinderte Menschen.

    Gruß Katrin
     
    Katrin, 09.08.2004
  5. Ochi

    OchiMacUser Mitglied

    Mitglied seit:
    03.11.2003
    Beiträge:
    462
    Zustimmungen:
    4
    1/2 OT:
    Wer kann dank des "<" und ">" das Thema auf der Startseite ebenfalls nicht lesen?
    (Ist einfach "unsichtbar".)
     
    Ochi, 09.08.2004
  6. cschirmbeck

    cschirmbeckMacUser Mitglied

    Mitglied seit:
    07.02.2004
    Beiträge:
    941
    Zustimmungen:
    0
    Ich auch nicht... das wird wohl bei allen so sein :eek:
     
    cschirmbeck, 09.08.2004
  7. mactrisha

    mactrisha Thread StarterMacUser Mitglied

    Mitglied seit:
    27.11.2003
    Beiträge:
    683
    Medien:
    3
    Zustimmungen:
    4
    Hi Leute,

    Danke, ich habe es dann auch gefunden, die Anführungszeichen fehlen wegen der "Goive" > "Web-Einstellungen" die Option "Attribute in Anführungszeichen" Einstellung, wie Katrin erwähnte. Das mit den < und > im Betreff war ein Flüchtigkeitsfehler beim einkopieren meines vorgeschriebenen Beitragstextes, sorry.

    Salü,
    mactrisha.
     
    mactrisha, 09.08.2004
Die Seite wird geladen...
Ähnliche Themen - Probleme beim Löschen
  1. Barons
    Antworten:
    6
    Aufrufe:
    689
  2. phönö
    Antworten:
    4
    Aufrufe:
    4.420
    falkgottschalk
    20.05.2011
  3. Apfelchristof
    Antworten:
    9
    Aufrufe:
    961
    Atarimaster
    11.01.2010
  4. conmigo
    Antworten:
    1
    Aufrufe:
    709
    JacenTalon
    14.09.2011
  5. MaxxxX
    Antworten:
    4
    Aufrufe:
    525