Benutzerdefinierte Suche

Probleme beim FTP Upload

  1. Poldibert

    Poldibert Thread StarterMacUser Mitglied

    Mitglied seit:
    14.05.2005
    Beiträge:
    184
    Zustimmungen:
    0
    Hallo,

    eben wollte ich auf unserem Wohnheimsserver per FTP aus der Konsole ein File hochladen, aber mein lokales File wird nicht gefunden. Dieses existiert aber definitiv, ich habe es nicht mal komplett eingetippt, da die Konsole ja automatisch Dateinamen vervollständigt. An der Firewall liegt es auch nicht (habe sie auch mal ausgeschaltet) und der passive Modus ist in den Netzwerkeinstellungen aktiviert.

    Ach ja ich habe 10.4.2 und im Finder schaffe ich es auch nicht.

    Hier noch der Log der Konsole:

    Code:
    230 User poldi logged in.
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp> cd public_html/iBook
    250 CWD command successful
    ftp> put ~/Desktop/iBook-Screenshot.png 
    local: /Users/poldi/Desktop/iBook-Screenshot.png remote: /Users/poldi/Desktop/iBook-Screenshot.png
    229 Entering Extended Passive Mode (|||57311|)
    550 /Users/poldi/Desktop/iBook-Screenshot.png: No such file or directory
    Jemand ne Idee?
    Poldibert
     
    Poldibert, 21.10.2005
  2. Poldibert

    Poldibert Thread StarterMacUser Mitglied

    Mitglied seit:
    14.05.2005
    Beiträge:
    184
    Zustimmungen:
    0
    ich kann die Syntax nicht...

    So einfach ist die Lösung:

    Code:
    ftp> put ~/Desktop/iBook-Screenshot.png ./Screenshot.png
    local: /Users/poldi/Desktop/iBook-Screenshot.png remote: ./Screenshot.png
    229 Entering Extended Passive Mode (|||57335|)
    150 Opening BINARY mode data connection for ./Screenshot.png
    100% |*************************************|   357 KB    1.16 MB/s    00:00    
    226 Transfer complete.
    365698 bytes sent in 00:00 (1.01 MB/s)
    
    put braucht zwingend ein Ziel-File. Ich dachte nicht. Asche über mein Haupt. :D
     
    Poldibert, 21.10.2005
Die Seite wird geladen...