1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Adobe Flash problem von visibility

Dieses Thema im Forum "Web-Design und Web-Programmierung" wurde erstellt von vinaverita, 13.02.2003.

  1. vinaverita

    vinaverita Thread Starter MacUser Mitglied

    Mitglied seit:
    16.01.2003
    Beiträge:
    1.887
    Zustimmungen:
    12
    hallo,
    habe ein problem, das eventuell ein bug sein könnte.
    deswegen weiß ich auch nicht weiter.

    richtig dargestellt wird es als swf-datei und als exe datei bei windows.
    jedoch als macintosh projektor nicht.

    folgendes: ich habe ein auswahlmenü bestehend aus
    den punkten: langsam, mittel, schnell.
    zu beginn soll langsam aktiv angezeigt werden, da es so
    voreingestellt ist.
    als macintosh projektor zeigt er mir aber bereits zu beginn
    alle drei unterpunkte aktiv an.
    programmiert wurde es mit folgenden code:
    speed_active1._visible = true;
    speed_active2._visible = false;
    speed_active3._visible = false;
     
  2. vinaverita

    vinaverita Thread Starter MacUser Mitglied

    Mitglied seit:
    16.01.2003
    Beiträge:
    1.887
    Zustimmungen:
    12
    huch...hälfte wurde nicht mitabgesendet

    ...speed_active1 ist der instanzname für langsam und somit auf sichtbar gestellt (true).
    der rest auf false.

    warum wird es nur als macintosh projektor falsch gemacht?
    hat jemand einen vorschlag wie ichdas problem lösen kann?

    besten dank
    vina
     
  3. vinaverita

    vinaverita Thread Starter MacUser Mitglied

    Mitglied seit:
    16.01.2003
    Beiträge:
    1.887
    Zustimmungen:
    12
    problem gelöst

    hallo,
    habe mein problem gelöst und wollte es mal mitteilen,
    falls jemand auch mal ein ähnliches problem hat.

    mein skript wurde als swf datei und als .exe datei
    richtig ausgeführt, nur nicht als macintosh projektor.

    die gründe dafür lagen darin, dass ich die ebenen wo die scripte
    drauf lagen verschieben musste und zwar auf die unterste ebene.
    also lag kein programmierfehler vor..sondern einfach nur
    eine falsche ebenenreihenfolge damit die skripte in der
    richtigen reihenfolge ausgeführt werden können.

    gruß vina
     
Die Seite wird geladen...

Diese Seite empfehlen