Benutzerdefinierte Suche

PHP-4.3.4 (entropy.ch) wird trotz Eintrag in httpd.conf nicht ausgeführt

  1. SirJoker

    SirJoker Thread Starter MacUser Mitglied

    Mitglied seit:
    29.10.2004
    Beiträge:
    422
    Zustimmungen:
    0
    Moinsen,

    ich habe mal wieder (hoffentlich) kleine Probleme mit meiner lokalen Php-Installation.

    Ich benötige die gd-lib für eine eingerichtete Bilder-Datenbank. Nun habe ich mir die PHP-Version 4.3.4 von entropy.ch besorgt und installiert. In der httpd.conf wird das Modul wohl auch richtig aktiviert.

    Hier mal das Ende der httpd.conf:

    # begin entropy.ch PHP module activation
    Include /usr/local/php/httpd.conf.php
    # end entropy.ch PHP module activation

    # begin entropy.ch PHP module activation
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps
    DirectoryIndex index.html index.php
    # end entropy.ch PHP module activation

    Nur zeigt mir phpinfo() immer noch die Version 4.3.10 an.

    Eine erneute Installation der entropy-Version bringt leider auch nix.

    Hat jemand ne Ahnung, wie oder was ich da noch tun muss/kann?
     
    SirJoker, 11.09.2006
    #1
  2. wegus

    wegus MacUser Mitglied

    Mitglied seit:
    13.09.2004
    Beiträge:
    14.984
    Zustimmungen:
    1.546
    Läuft der Mac OS Apache 1.x ?
    Ist /etc/httpt/httpd.conf die korrekte conf-Datei?
    Ist ggf. eine frühere PHP-Version noch aktiv in der conf?
    Kommt bei "apachectl start" sowas wie "Module PHP already loaded" ?
    Hast Du Apache nach dem ändern der httpd.conf neugestartet?
     
    wegus, 11.09.2006
    #2
  3. SirJoker

    SirJoker Thread Starter MacUser Mitglied

    Mitglied seit:
    29.10.2004
    Beiträge:
    422
    Zustimmungen:
    0
    Apache 1.3 läuft

    Ob /etc/httpt/httpd.conf die korrekte ist, weiß ich nicht. Ich hab das früher jedenfalls schon mal so gemacht. Also einfach die entropy version drübergebügelt und gut is. (Steht ja auch so wuf Seite von entropy.) Wie krieg ich denn raus ob das die richtige ist? (Sorry, wenn ich hier blöde Fragen stelle. Ich bin auch (gelernter) System-Admin. Ich möchte eigentlich mich eigentlich "nur" bisschen in php, mysql austoben.)

    Bei "apachectl start" kommt:
    [Mon Sep 11 12:10:06 2006] [warn] module php4_module is already loaded, skipping
    [Mon Sep 11 12:10:06 2006] [warn] module mod_php4.c is already added, skipping
    fopen: Permission denied
    httpd: could not open error log file /private/var/log/httpd/error_log.
    /usr/sbin/apachectl start: httpd could not be started

    Wie gesagt es lief ja auch schon alles bei mir. Nun habe ich letzte Woche ne neue Platte einbauen müssen und dabei gleich ein frisches System aufgesetzt.
     
    SirJoker, 11.09.2006
    #3
  4. oneOeight

    oneOeight MacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.189
    Zustimmungen:
    3.900
    such mal nach dieser zeile
    LoadModule php4_module libexec/httpd/libphp4.so
    und kommentier die wieder aus...

    p.s.
    gibt es auf centropy keine neuere als 4.3.4?
    4.3.4 hat massig lücken...
     
    oneOeight, 11.09.2006
    #4
  5. SirJoker

    SirJoker Thread Starter MacUser Mitglied

    Mitglied seit:
    29.10.2004
    Beiträge:
    422
    Zustimmungen:
    0
    LoadModule php4_module libexec/httpd/libphp4.so
    und auch der dazugehörige
    AddModule mod_php4.c
    Ist drin (Du meinst das # vorne raus – richtig?)

    4.3.4 ist die letzte für das System 10.2.8. welches ich hier einsetze.
     
    SirJoker, 11.09.2006
    #5
  6. oneOeight

    oneOeight MacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.189
    Zustimmungen:
    3.900
    nein, du sollst das raus nehmen, das ist das original php von apple...
    also schön das # vor die beiden zeilen setzen, damit das von centropy lädt...
     
    oneOeight, 11.09.2006
    #6
  7. SirJoker

    SirJoker Thread Starter MacUser Mitglied

    Mitglied seit:
    29.10.2004
    Beiträge:
    422
    Zustimmungen:
    0
    Alles klar, danke. Daran konnte ich mich nicht mehr erinnern. Läuft.
     
    SirJoker, 11.09.2006
    #7
Die Seite wird geladen...
Ähnliche Themen - PHP (entropy ch)
  1. mampfi
    Antworten:
    7
    Aufrufe:
    298
    mampfi
    04.07.2017
  2. simusch
    Antworten:
    2
    Aufrufe:
    188
    simusch
    04.05.2017
  3. der_Kay
    Antworten:
    0
    Aufrufe:
    442
    der_Kay
    27.12.2006
  4. echt0711
    Antworten:
    2
    Aufrufe:
    624
    echt0711
    10.01.2006
  5. starbuxx
    Antworten:
    9
    Aufrufe:
    938
    wegus
    18.05.2005