Benutzerdefinierte Suche

Personal Websharing lässt sich nicht mehr aktivieren

  1. SirJoker

    SirJoker Thread StarterMacUser Mitglied

    Mitglied seit:
    29.10.2004
    Beiträge:
    422
    Zustimmungen:
    0
    Hi,

    mein Personal Websharing lässt sich nicht mehr aktivieren.

    Ich habe bisher folgendes gemacht: MySQL installiert (läuft), php in der Datei httpd.conf aktiviert.

    Ich habe daraufhin PHPmyAdmin installiert, aber das klappt natürlich nicht.

    Wenn ich jetzt Personal Websharing aktivieren will passiert nix mehr, bzw es steht endlos lange "aktivieren...", aber es passiert nix.

    Woran kann das liegen?
     
    SirJoker, 18.02.2005
  2. Moogul

    MoogulMacUser Mitglied

    Mitglied seit:
    03.06.2004
    Beiträge:
    85
    Zustimmungen:
    0
    Du hast Dir sehr sicher deine httpd Konfigurationsdatei zerschossen.
    Etwas falsches auskommentiert oder beim reinschreiben etwas falsch geschrieben.
    Es gibt im Verzeichnis /etc/httpd/ eine Datei httpd.conf.default. Wenn du die kopierst und im gleichen Verzeichnis in httpd.conf umbenennst, dann müsste alles wieder beim alten sein.
    Schau halt mal, wo der Wurm in deiner neuen Konfiguration ist.

    Gruß Sascha
     
    Moogul, 18.02.2005
  3. SirJoker

    SirJoker Thread StarterMacUser Mitglied

    Mitglied seit:
    29.10.2004
    Beiträge:
    422
    Zustimmungen:
    0
    Hi Moogul,

    also du meinst ich setze root-Rechte für den zugriff auf httpd.conf, lade mir dann die httpd.conf.default und ersetze die httpd.conf mit dieser "frischen"? Aber womit: it Textedit geht es ja wohl nicht. Die Original httpd.conf habe ich gestern mit Pico modifiziert.

    Verstehe ich Dich da richtig? Sorry, aber ich kann nicht riskieren hier irgendwas wirklich "dummes" zui machen, und bei Rott-Rechten und überschreiben von Systemdateien frage ich lieber zweimal nach.
     
    SirJoker, 18.02.2005
  4. wegus

    wegusMacUser Mitglied

    Mitglied seit:
    13.09.2004
    Beiträge:
    14.982
    Zustimmungen:
    1.545
    Moogul hat vermutlich recht! Wenn apache startet, liest er die httpd.conf. Stimmen die Angaben dort nicht, so kann Apache nie ganz fertig werden. Zum prüfen kannst Du mal folgendes im terminal eingeben:

    tail -n10 /var/log/httpd/error_log

    Die Ausgabe sind die letzten 10 Zeilen des Apache-Fehlerprotokolls. Poste die mal hier. Wenn Apache irgendein Modul nicht starten kann, kannst Du die von Dir "beschädigte Datei" durch die datei ersetzen, die quasi dem Lieferzusatnd entspricht:

    cd /etc/httpd

    sudo cp httpd.conf.default httpd.conf

    Dann sollte Apache wieder laufen, Allerdings nat. wieder ohne PHP ;)
     
    wegus, 18.02.2005
  5. SirJoker

    SirJoker Thread StarterMacUser Mitglied

    Mitglied seit:
    29.10.2004
    Beiträge:
    422
    Zustimmungen:
    0
    Danke Moogul und wegus,

    habe die Datei ersetzt und Apache läuft wieder.

    Ich liiiebe dieses Forum :)
     
    SirJoker, 18.02.2005
  6. ThaHammer

    ThaHammerMacUser Mitglied

    Mitglied seit:
    01.06.2004
    Beiträge:
    3.277
    Zustimmungen:
    13
    Probiere mal den Befehl: apachectl configtest
     
    ThaHammer, 20.02.2005
Die Seite wird geladen...
Ähnliche Themen - Personal Websharing lässt
  1. R.Carlos
    Antworten:
    10
    Aufrufe:
    629
    R.Carlos
    02.11.2007
  2. WolfgangK
    Antworten:
    1
    Aufrufe:
    496
  3. xantam
    Antworten:
    2
    Aufrufe:
    588
    rakader
    13.01.2007
  4. Augustiner
    Antworten:
    12
    Aufrufe:
    988
  5. Gruni
    Antworten:
    1
    Aufrufe:
    460
    fungusmungus49
    28.07.2006