OSX11 SMB-Freigabe aktivieren

rudcomb

Neues Mitglied
Thread Starter
Mitglied seit
07.11.2020
Beiträge
5
Guten Tag in die Runde

Mein neuer HP MFP M636 Scanner lässt sich nicht mit dem Ordner zB:"User/Public/Scan" auf meinem iMac OSX11.01 verbinden. Jeder Win10 PC geht einwandfrei. Die UNC Pfade und User Anmeldung nach Win10 funktionieren, zu OSX11 aber unmöglich. Via Apple untereinander konnte ich auch auf den erwähnten auch Ordner zugreifen. Die Rechte sind demnach einwandfrei. HP verlangt für die SMB Verbindung einen User, "Gast" war daher keine Option.

Ich denke OSX11 lässt nur SMB3 zu, konnte nicht herausfinden, ob HP das auch unterstützt. Sind Zertifikate ein Weg? Jemand eine Ahnung oder ein Lösungsansatz?
 

walfreiheit

Aktives Mitglied
Mitglied seit
06.06.2004
Beiträge
29.391
Die neueren macOS können kein SMB1 mehr. Da ist bei solchen Geräten Schluss.
 

Rudi453

unregistriert
Mitglied seit
18.10.2020
Beiträge
387
Wenn der Zugriff mit Windows10 funktioniert, dann ist das mindestens SMB2, denn SMB1 lässt auch Windows nicht mehr zu.
Die Implementierung unter macOS ist bekanntermassen für den SMB Zugriff eher ... "sparsam" um es mal nett auszudrücken.

Du hast die Freigabe über die Systemeinstellung "Dateifreigabe" mit Option "SMB" und "aktiviertem Windows-User" eingerichtet und auch daran gedacht unter der Systemeinstellung "Netzwerk" die WINS Einstellungen entsprechende der Bedürfnisse des HP korrekt zu machen (Achtung, wenn du die Sprache umgestellt hast, muss u.U. auch die Arbeitsgruppe umbenannt werden - Windows 10 ignoriert die Arbeitsgruppe schon lange, aber so weit ist Apple noch nicht)?
 

rudcomb

Neues Mitglied
Thread Starter
Mitglied seit
07.11.2020
Beiträge
5
Danke für euere Zeilen

Denke da bei mir noch Luft nach oben zum forschen....dachte schon steh da alleine im Regen mit HP und Apple Problemen

"Dateifreigabe" mit Option "SMB" | yep, habe ich gemacht
"und aktiviertem Windows-User" | sagt mir grad nichts, wo zu finden?
"Netzwerk" die WINS Einstellungen" | habe ich nichts eingetragen, habe keine Info dazu
"Arbeitsgruppe umbenannt" | ja, hier habe ich mit und ohne versuche gemacht

Eigentlich habe ich mir vorgestellt, ein Zertifikat zu installieren und dann sei alles gelöst. Denkste. Habe nichts gefunden zu meinem Problem.

Kennt sich den jemand mit den "Validate Negotiate"-Anfragen aus? Sind nur für SMB3 gedacht, wie ich das verstehe.
"validate_neg_off=no" scheint per Default scheint per default in der "snmb.conf" eingetragen zu sein.
"ProtocolVersionMap" wäre möglich SMB2 freizuschalten? Könnte damit dann mal testen.
Mal von den Nachteilen der Sicherheit abgesehen.

🖨
 
Oben