• Wenn du alle Inhalte sehen, oder selber eine Frage erstellen möchtest, kannst du dir in wenigen Sekunden ein Konto erstellen. Die Registrierung ist kostenlos, als Mitglied siehst du keine Werbung!

Numbers Formelfehler ?

michael m.

Mitglied
Thread Starter
Registriert
29.12.2006
Beiträge
407
Hallo ich möchte gerne eine Tabelle mit Fintessdaten errechnen lassen und habe folgendes Problem:
Es wird der BMI (Body Mass Index) Berechnet, was ganz gut klappt.
Ich hätte aber gerne das wenn der DMI einen Wert überschreitet oder Unterschreitet auch ausgibt ob Untergewicht, Normal, oder Übergewicht vorhanden ist.

Formel Info:

unter 18,5 Untergewicht
18,5 bis 25,0 Normalgewicht
25,0 bis 30,0 leichtes Übergewicht
über 30 ,0 Übergewicht

Formel in Numbers:
=WENN(B16<18,5;"Untergewicht"; WENN(B16>18,5; WENN (UND (B16<25); "Normalgewicht"; WENN(B16>25; WENN (UND(B16)<30; "leichtes Übergewicht"; WENN (B16>30; "Übergewicht"))))))

Das ganze klappt mit Untergewicht und Normalgewicht.
Aber ab der Grenze 25 erhalte ich eine Fehlermeldung:
"Einen Boolschen Wert kann nicht mit einer Zahl verglichen werden, da sie verschiedene Datentypen aufweisen."

Es wäre sehr nett, wenn mir jemand helfen könnte.
Mit Numbers und formeln arbeite ich noch nicht lange.

Vielen Dank
M.
 

michael m.

Mitglied
Thread Starter
Registriert
29.12.2006
Beiträge
407
Welche Abfragebefehle wären dann korrekt?
Müssten die Sonst einefach " " sein?
 

Christian1313

Mitglied
Registriert
17.06.2009
Beiträge
623
Versuch mal:

=IF(B16<18,"Untergewicht",IF(B16<25,"Normalgewicht",IF(B16<30,"leichtes Übergewicht","Übergewicht")))

oder auf deutsch

=WENN(B16<18,"Untergewicht",WENN(B16<25,"Normalgewicht",WENN(B16<30,"leichtes Übergewicht","Übergewicht")))
 

TEXnician

unregistriert
Registriert
14.02.2013
Beiträge
1.585
Zuerst einmal, ich verwende kein Numbers (dafür bin ich in der Mathematik bewandert und kann Dokumentationen/Handbücher lesen), aber Seite 170 und 171 im Dokument http://manuals.info.apple.com/MANUALS/0/MA665/de_DE/Formeln_und_Funktionen_Benutzerhandbuch.pdf verrät mir, wie man in Numbers das boolsche "Und" verwendet. Dein Befehl müsste also ungefähr so lauten (Syntaxfehler darfst du selbst verbessern):

Code:
WENN(B16<18,5;"Untergewicht";WENN(UND(B16>18,5;B16<25);"Normalgewicht";WENN(UND(B16>25;B16<30);"leichtes Übergewicht";"Übergewicht")))

Edit: Christian1313s Formel ist natürlich eleganter, da du in deiner Formel aber offensichtlich "UND" falsch verwendet hast, habe ich deine Formel korrigiert und hoffe, dass du daraus etwas lernst.
 

michael m.

Mitglied
Thread Starter
Registriert
29.12.2006
Beiträge
407
Vielen Dank,
ich habe etwas daraus gelernt.
Ich hatte die Funktion Wenn, Dann, sonst falsch angewandt und mit weiteren abfragen verschachtelt, was völlig falsch war.
Danke für die Hilfe, werde es weiter üben und verstehen.

Viele Grüsse
Michael
 
Oben