Netzwerkreihenfolge - Ethernet vor WLAN funktioniert nicht

apfelcash

Mitglied
Thread Starter
Registriert
16.06.2015
Beiträge
756
Hallo,

ich habe meinen Macbook (Big Sur) über das WLAN wie auch über Ethernet mit dem Netz verbunden. Solange WLAN aktiv ist, gelingt es mir nicht, das Ethernet als erste Netzwerkbindung zu aktivieren. So schaltet sich bis zum Abschalten von WLAN grundsätzlich diese Netzwerkverbindung vor das Ethernet. Die Netzwerkreihenfolge habe ich entsprechend abgeändert, leider greift diese Einstellung jedoch nicht.

Kann mir vielleicht jemand sagen, ob es hier eine Lösung gibt?

VG
Bildschirmfoto 2021-05-04 um 19.57.00.png Bildschirmfoto 2021-05-04 um 19.56.32.png
 

KOJOTE

Aktives Mitglied
Registriert
06.11.2004
Beiträge
7.648
Ist bei mir in Big Sur auch so und war schon unter High Sierra und Mojave so.
Ist die Reihenfolge der Netzwerke in Systemeinstellungen > Netzwerk, denn überhaupt relevant?
 

noodyn

Aktives Mitglied
Registriert
16.08.2008
Beiträge
13.380
Also ich habe da kein Problem, es scheint also kein generelles Big Sur Problem zu sein. Natürlich ist die Reihenfolge relevant.

Bildschirmfoto 2021-05-05 um 07.35.19.png
Bildschirmfoto 2021-05-05 um 07.33.32.png
 

Carmageddon

Aktives Mitglied
Registriert
18.02.2005
Beiträge
1.563
Ist bei mir in Big Sur auch so und war schon unter High Sierra und Mojave so.
Ist die Reihenfolge der Netzwerke in Systemeinstellungen > Netzwerk, denn überhaupt relevant?
War bei mir noch unter keinem System so. Und natürlich ist die Reihenfolge wichtig. Wenn ich an meinem festen Arbeitsplatz mit Ethernet-Verbindung sitze, will ich schliesslich nicht über das langsamere WLAN verbunden werden.
 

herberthuber

Mitglied
Registriert
04.11.2018
Beiträge
983
@apfelcash:
Was mir in Deinen Screenshots auffält ist, dass Du das LAN anscheinend über einen USB-Adapter betreibst.
Vielleicht "priorisiert" Apple USB generell niedriger als fest "verbaute" Komponenten.
 

tigion

Aktives Mitglied
Registriert
21.06.2006
Beiträge
1.358
Schaue im Terminal (Terminal.app) mal mit route get default | grep interface welches Netzwerkinterface aktuell genommen wird.

Ich habe bspw. WLAN (en0) und Ethernet (en3) mit Ethernet über WLAN priorisiert und es bringt aktuell die Ausgabe en3. Alternativ verschiedene Umgebungen für nur WLAN oder nur Ethernet anlegen.
 

SignoreRossi

Aktives Mitglied
Registriert
11.06.2008
Beiträge
3.341
@apfelcash:
Was mir in Deinen Screenshots auffält ist, dass Du das LAN anscheinend über einen USB-Adapter betreibst.
Vielleicht "priorisiert" Apple USB generell niedriger als fest "verbaute" Komponenten.
Ich hab ein TB3 Dock an meinem MacPro 6.1 mit Adapter auf USB A angeschlossen, Ethernet wird bevorzugt.

Viele Grüße!
 

Anhänge

  • Bildschirmfoto 2021-05-05 um 11.08.25.png
    Bildschirmfoto 2021-05-05 um 11.08.25.png
    204,1 KB · Aufrufe: 19

picollo

Mitglied
Registriert
01.05.2020
Beiträge
471
Hallo,

ich habe meinen Macbook (Big Sur) über das WLAN wie auch über Ethernet mit dem Netz verbunden. Solange WLAN aktiv ist, gelingt es mir nicht, das Ethernet als erste Netzwerkbindung zu aktivieren. So schaltet sich bis zum Abschalten von WLAN grundsätzlich diese Netzwerkverbindung vor das Ethernet. Die Netzwerkreihenfolge habe ich entsprechend abgeändert, leider greift diese Einstellung jedoch nicht.

Kann mir vielleicht jemand sagen, ob es hier eine Lösung gibt?

VG
Bei mir geht das in den Systemeinstellungen für das Netzwerk zu ändern (Reihenfolge der Dienste ändern), aber nur mit Admin-Rechten.
 

KOJOTE

Aktives Mitglied
Registriert
06.11.2004
Beiträge
7.648
Bei mir geht das in den Systemeinstellungen für das Netzwerk zu ändern (Reihenfolge der Dienste ändern), aber nur mit Admin-Rechten.
Was ja soweit schon klar ist, nur eben nicht funktionierte, bzw. nicht dauerhaft, zumindest beim TE.

Ich korrigiere meinen Beitrag unter #2, denn aktuell unter Big Sur steht die Reihenfolge der Netzwerke wie sie soll.
 

apfelcash

Mitglied
Thread Starter
Registriert
16.06.2015
Beiträge
756
Besten Dank Euch allen für die tolle Unterstützung! Leider bin ich erst jetzt wieder am Mac. Ich konnte das Problem noch gestern Abend wie folgt lösen. Ich habe WLAN von der 2. Stelle an die 3. Stelle und den "Thunderbolt Ethernet Steckplatz" (nicht aktiv) an die 2. Stelle gesetzt. Nach dem Setzen dieser Reihenfolge wurde plötzlich der Ethernet Anschluss verwendet. Nachdem ich nun heute Abend den Rechner neu gestartet habe und das LAN Kabel an meinem TS3 Dock noch einmal abgezogen und erneut angesteckt habe, scheint nun alles zu passen. Das heißt, der Thunderbolt Ethernet Steckplatz steht ohne weiteres Zutun nun an erster Stelle.

VG

Bildschirmfoto 2021-05-05 um 20.56.59.png
 
Oben Unten