MySQL Tabelle nicht gefunden!?

  1. RaGGi

    RaGGi Thread StarterMacUser Mitglied

    Mitglied seit:
    06.02.2004
    Beiträge:
    127
    Zustimmungen:
    0
    Hallo zusammen! Ich habe es immer noch nicht ganz geschafft meinen Webserver zum Laufen zu bringen, bzw. MySQL macht noch Probleme. Dachte immer der MySQL Server startet beim Booten automatisch (stand da jedenfalls immer), aber anscheinend doch nicht. Wenn ich PHPmyAdmin aufrufen will, erhalte ich folgende Fehlermeldung:

    #2002 - Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)


    Wenn ich versuche die mysqld zu starten, bekomme ich folgendes:

    Last login: Mon May 17 12:56:39 on ttyp1
    Welcome to Darwin!
    /Library/MySQL/libexec/mysqld; exit
    iBook:~ RaGGi$ /Library/MySQL/libexec/mysqld; exit
    040517 13:04:26 InnoDB: Started
    040517 13:04:26 Fatal error: Can't open privilege tables: Table 'mysql.host' doesn't exist
    040517 13:04:26 Aborting

    040517 13:04:26 InnoDB: Starting shutdown...
    040517 13:04:28 InnoDB: Shutdown completed
    040517 13:04:28 /Library/MySQL/libexec/mysqld: Shutdown Complete

    logout
    [Prozess beendet]


    Hab schon viel gegoogelt, aber noch nicht die richtige Lösung für mein Problem gefunden. Wurde MySQL vielleicht nicht richtig installiert? "Can't open privilege tables" soll ja heißen, dass die Tabelle "mysql" nicht gefunden wurde. Ich kann die allerdings nicht gelöscht haben, wenn ich gar nicht ins phpmyadmin komme, also was mache ich da jetzt? :(

    Hoffe ihr könnt mir helfen, brauche die Datenbank dringend!
     
    RaGGi, 17.05.2004
  2. Thommy

    ThommyMacUser Mitglied

    Mitglied seit:
    23.06.2003
    Beiträge:
    1.831
    Zustimmungen:
    0
    hmm... versuch doch mal das mysql paket von serverlogistics zu installieren!
    http://www.serverlogistics.com/mysql.php

    Installieren, PrefPane für die Systemsteuerung installieren, und dort bequem mysql an/aus schalten. Deine bestehende mysql installation wird dann ja überschrieben und somit alle fehler beseitigt.
     
    Thommy, 17.05.2004
  3. mrwho

    mrwhoMacUser Mitglied

    Mitglied seit:
    20.07.2003
    Beiträge:
    2.526
    Zustimmungen:
    79
    Da scheint bei der Installation etwas schiefgegangen zu sein "mysql.host" gehört jedenfalls zu den Systemtabellen von mysql und wenn es die schon nicht findet... :confused:

    Würde jedenfalls auch die Lösung vom Thommy ausprobieren, mal sehen was da rauskommt.
     
    mrwho, 17.05.2004
  4. RaGGi

    RaGGi Thread StarterMacUser Mitglied

    Mitglied seit:
    06.02.2004
    Beiträge:
    127
    Zustimmungen:
    0
    Wow super, dieses PrefPane war die Lösung :)
    Hatte ja von Serverlogistics auch die MySQL Version damals runtergeladen, aber ich vestehe nicht warum das nicht mit der ersten Installation funktioniert hat. Jetzt scheint alles super zu laufen, sogar besser als auf meinem Windows-Rechner damals :D

    Danke euch vielmals! Wenn ich jetzt noch das Problem mit meinem Drucker lösen könnte :/ Aber das kommt morgen dran *g*
     
    RaGGi, 17.05.2004
  5. HAL

    HAL

    Hm, wenn ich mich recht entsinne, ist da bei deinem letzten
    Posting auch mehrfach darauf hingewiesen worden, respektive
    es ist auch in dem MySQL-Diskimage vorhanden.

    Tipp: Ab und zu mal die ReadMe aufrufen...

    ;)
     
Die Seite wird geladen...
Ähnliche Themen - MySQL Tabelle gefunden
  1. Waldfee123
    Antworten:
    2
    Aufrufe:
    1.228
    rm -r *
    01.12.2010
  2. DanLDSkal
    Antworten:
    5
    Aufrufe:
    2.878
  3. emmy
    Antworten:
    15
    Aufrufe:
    4.618
    FreeGroup
    28.05.2009
  4. Aakadasch
    Antworten:
    5
    Aufrufe:
    722
    timbajr
    31.10.2007
  5. Bastian
    Antworten:
    2
    Aufrufe:
    733
    Bastian
    27.06.2007