Benutzerdefinierte Suche

mutt/pine

  1. MacSwitch

    MacSwitch Thread StarterMacUser Mitglied

    Mitglied seit:
    02.10.2003
    Beiträge:
    26
    Zustimmungen:
    0
    Guten Abend zusammen,

    ich bilde mir gerade ein mit mutt oder pine einen gmx Account abzudecken. Nur komme ich mit der Konfiguration von fetch- und sendmail nicht recht klar. Kann mir da wer weiterhelfen?
    MacSwitch
     
    MacSwitch, 14.03.2005
  2. Captain Grogful

    Captain GrogfulMacUser Mitglied

    Mitglied seit:
    04.01.2005
    Beiträge:
    435
    Zustimmungen:
    9
    Hi,
    erstmal Glückwunsch, gute Entscheidung. Ich habe exakt das gleiche Setup hier (Mutt, fetchmail, Procmail, Postfix (statt sendmail), GMX-Account).

    Welche Version von Mac OS X hast du? Soweit ich weiss (hab ich auch neulich hier gelernt) ist bei der aktuellen Version Postfix standardmaessig als MTA dabei und kein Sendmail mehr.

    Bei Sendmail kann ich dir leider nicht weiterhelfen.

    Schreib doch mal genau wo's hakt.
     
    Captain Grogful, 15.03.2005
  3. MacSwitch

    MacSwitch Thread StarterMacUser Mitglied

    Mitglied seit:
    02.10.2003
    Beiträge:
    26
    Zustimmungen:
    0
    Hallo rikski,
    ich habe da den Haken, daß ich nicht genau weiß wo und wie ich anfagen soll. Mit pine kann ich mitlerweile empfangen und verschicken, nur klappt das nicht richtig, die mails werden immer wieder neu geholt und erscheinen dann als ungelesen...
    Am besten bräuchte ich ein kleines Workaround von vorne bis hinten ;-)
    Ich habe hier die OS X Version 10.3.8.
    Postfix ist dabei, fetchmail, procmail auch. mutt müsste ich noch dazu tun.
    Danke schonmal.
     
    MacSwitch, 16.03.2005
  4. ratpoison

    ratpoisonMacUser Mitglied

    Mitglied seit:
    17.08.2004
    Beiträge:
    1.961
    Zustimmungen:
    0
    Wenn du einen lokalen Mailserver laufen haben willst und mutt/pine nutzen möchtest, dann empfehle ich:

    DIE MANPAGES ;)

    man mutt
    man pine
    man fetchmail
    man sendmail

    ;)

    Oder schau mal hier, ist anpassbar:

    http://www.dcoul.de/infos/mailhandling.html

    Get "fetched"

    Gruß,

    Thorsten
     
    ratpoison, 16.03.2005
  5. Captain Grogful

    Captain GrogfulMacUser Mitglied

    Mitglied seit:
    04.01.2005
    Beiträge:
    435
    Zustimmungen:
    9
    Hi MacSwitch,

    also von vorne bis hinten erklaeren ist etwas schwierig, denn so ein Setup ist immer ein bisschen individuell. Also ich versuch's einfach mal:

    1. Wenn du deine Mails mit Pine lesen willst, dann brauchst du kein mutt, denn mutt ist auch nur ein anderer MUA.
    2. Der Link den ratpoison gepostet hat enthaelt eigentlich alles wesentliche. Nur muss das fuer Postfix angepasst werden. Ich kann meine config gerade nicht anschauen aber es sind nur ein paar Zeilen.
      • Postfix sagen, dass es Procmail verwenden soll, geht auch irgendwie mit "mailbox_command = /usr/bin/procmail" in /etc/postfix/main.cf, bin aber nicht ganz sicher. Das brauchst du aber nur dann, wenn fetchmail die ankommenden Mails nicht selbst schon in deine Mailbox schiebt (das geht auch mit einer Zeile in .fetchmailrc, siehe man fetchmail)
      • Die Absender Adressen müssen umgeschrieben werden (Ich gehe davon aus, dass du an einem Dialup-System bist). Dazu muss man Postfix mitteilen, dass Mail die von User "foo" gesendet wird mit der Adresse "foo@bar.com" versehen wird. Dazu muss, wenn ich mich nicht täusche (wie gesagt kann meine files gerade nicht einsehen), eine textdatei mit der Zuordnung user zu adresse angelegt werden. Diese Datei, nennen wir sie /etc/postfix/sender_canonical, sieht so aus:
        Code:
        foo foo@bar.com
        Jetzt muss noch ein
        Code:
        # postmap /etc/sender_canonical
        ausgeführt werden. In /etc/postfix sollte sich nun eine Datei sender_canonical.db befinden. Jetzt muss in /etc/postfix/main.cf noch "sender_canonical_maps = hash:/etc/postfix/sender_canonical" eingetragen werden und Postfix mittels "/usr/sbin/postfix reload" neu geladen werden.
    3. Wenn die Mails immer wieder abgeholt werden, dann sieht das nach einem Fehler in der .fetchmailrc aus. Hast du irgendwo die Option "-k" verwendet, das steht naemlich fuer "keep".

    HTH,
    rickski
     
    Captain Grogful, 17.03.2005
  6. MacSwitch

    MacSwitch Thread StarterMacUser Mitglied

    Mitglied seit:
    02.10.2003
    Beiträge:
    26
    Zustimmungen:
    0
    Danke für die Hilfe.
    Mitlerweile läuft es hier ganz gut. Für fetchmail bräucht es noch einen cronjob. Ich kann mich noch nicht für einen Editor entscheiden. vi oder emacs. Mal schauen.
    Postfix habe ich dann aber nicht mehr von Hand gemacht sondern mit dem PostfixEnabler. Für dden ersten Einstieg und ohne Frustatration hilft das schonmal. :)
    Herzlichen Dank
     
    MacSwitch, 18.03.2005
  7. MacSwitch

    MacSwitch Thread StarterMacUser Mitglied

    Mitglied seit:
    02.10.2003
    Beiträge:
    26
    Zustimmungen:
    0
    Läuft doch noch nicht. Ich bekomme meine Mails nicht weg obwohl mutt das so meint.
    In /var/log/mail.log steht dann z.B. Folgendes:
    "4ACCB13EB11: to=<foo@gmx.li>, relay=mx0.gmx.net[213.165.64.100], delay=12, status=sent (250 2.6.0 {mx001} Message accepted)"
     
    MacSwitch, 18.03.2005
  8. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Könnte ein Mailrouting Problem sein.
    Wenn Dein Mailserver vom Internet her nicht erreichbar ist (mit gültigem Domainnamen) kannst Du keine "MAILER-DAEMON" Nachrichten erhalten.
    Das ist schlecht, weil Du dann nicht erfahren kannst, warum etwas nicht klappt.

    Das Problem mit Tools wie dem Postfix-Enabler sehe ich persönlich darin, dass man hinterher nicht wirklich weiss, was eigentlich gemacht wurde.

    Als ersten Anhaltspunkt könntest Du mal prüfen, ob Du in der Lage bist, mit Deinem Postfix Emails aus dem Internet zu empfangen (z. B. von Deinem gmx-Account aus.)
     
    maceis, 19.03.2005
  9. MacSwitch

    MacSwitch Thread StarterMacUser Mitglied

    Mitglied seit:
    02.10.2003
    Beiträge:
    26
    Zustimmungen:
    0
    Läuft doch.
    Ich bin nur im gmx Spameimer gelandet, wohl weil die Mail direkt verschickt wird.
    Danke an alle.
    Eins bleibt aber immer noch. Wie habt ihr mutt angepaßt, daß es etwas übersichtlicher wird?
     
    MacSwitch, 19.03.2005
  10. Captain Grogful

    Captain GrogfulMacUser Mitglied

    Mitglied seit:
    04.01.2005
    Beiträge:
    435
    Zustimmungen:
    9
    Hi MacSwitch,
    also ich persoenlich finde es besser die Mails nicht direkt zu verschicken sondern ueber einen "Smarthost", in deinem Fall waere das mail.gmx.net. Es gibt einige Mailserver die Mails von Dial-up Hosts nicht aktzeptieren. Der Nachteil wenn man den GMX SMTP-Server verwendet ist, ist dass man _nur_ seine GMX-Adresse als Absender verwenden kann. Ich habe das so geloest, dass ich als Smarthost den 1&1 Mailserver verwende, das setzt natuerlich einen Account dort voraus. Wenn ich mich richtig erinnere, dann kann man den Smarthost auch in Postfix-enabler konfigurieren.

    Zum Thema mutt anpassen:
    Von mutt.org gibt es links zu vielen Beispiel .muttrc's ... da kann man sich einiges abschauen. So eine gute .muttrc entsteht aber so mit der Zeit. Mit mutt ist so gut wie _alles_ irgendwie moeglich. Ich habe die meisten Features erst so mit der Zeit entdeckt. Mutt ist einfach geil! :)
     
    Captain Grogful, 19.03.2005
Die Seite wird geladen...
Ähnliche Themen - mutt pine
  1. wurzelriese
    Antworten:
    0
    Aufrufe:
    1.040
    wurzelriese
    17.02.2014
  2. aspirin
    Antworten:
    1
    Aufrufe:
    974
    aspirin
    12.11.2011
  3. aspirin
    Antworten:
    6
    Aufrufe:
    1.376
    aspirin
    17.08.2009
  4. danielf
    Antworten:
    2
    Aufrufe:
    594
    danielf
    08.06.2006
  5. polyesterday
    Antworten:
    1
    Aufrufe:
    728