ML und Xcode,Paraview,Macports,Fortran, Peripherie

redbird

Mitglied
Thread Starter
Mitglied seit
20.09.2007
Beiträge
433
Hallo Zusammen,
da ich mir nächste Woche einen neuen Mac kaufen möchte und diese nun mit ML ausgelifert werden habe ich noch ein paar kurze Fragen.
Ich benutzte Macports um mir ein paar Fortran Compiler zu installieren z.b g95.

1.Xcode:
Zur Zeit habe ich 10.6 und xcode 3.x.
Wenn ich es recht weiß hat sich xcode seit Lion etwas verändert, bei der installation.
Dies hier habe ich z.B. gefunden. http://blog.emeidi.com/2012/02/19/macports-unter-lion/
gilt dies nach wie vor? oder gibt es eine bessere Anleitung?

2.Macports:
Die Installation und funktion von Macports sollte ja ganz normal weiterhin funktionieren.
Vielleicht kann der ein oder andere kurz sagen ob es Probleme zurzeit gibt, oder ob alles Problemlos geht.

3.Fortran:
wenn Macports funzt sollte das installieren der Compiler und das verwenden auch weiterhin gehen.
Auch hier wäre ich über ein kurze "funktioniert" dankbar.

4.Paraview:
Sollte ja eh funktionieren da Binary oder ?

5.Meine Sonstige Peripherie:
Dell U2311h, Espson SX 515 und Logitech MX 400.
gibts hier vielleicht kurze Erfahrungen.
Besonders das Drucken und Scannen über Wlan?

Vielen Dank für eure Hilfe und Mühe :)
Gruß
Redbird
 
Zuletzt bearbeitet:

Andy.321

Aktives Mitglied
Mitglied seit
13.02.2007
Beiträge
1.635
Ich habe in einem englischen Blog gelesen, dass libxml2 Probleme macht (es hat was mit der locale zu tun). Das könnte aber mittlerweile behoben sein...

Xcode ist mittlerweile 4.4 und ja, das Beschriebene gilt weiterhin... aber lies doch bei macports nach, da steht doch sicherlich wie es mit ML zu installieren ist...
 

redbird

Mitglied
Thread Starter
Mitglied seit
20.09.2007
Beiträge
433
Ich habe in einem englischen Blog gelesen, dass libxml2 Probleme macht (es hat was mit der locale zu tun). Das könnte aber mittlerweile behoben sein...

Xcode ist mittlerweile 4.4 und ja, das Beschriebene gilt weiterhin... aber lies doch bei macports nach, da steht doch sicherlich wie es mit ML zu installieren ist...
für was benötige ich denn libxml2?
leider steht auf der macports seite nur dass man Xcode installieren muss aber nicht wie.
edit: Wenn ich es richtig verstanden habe funktioniert bei ML ja nur Xcode 4.4 oder geht auch eine ältere Version?

ich benutzte entweder den gcc oder g95
folgendes steht unter Macports:

gcc47 4.7.1The GNU compiler collection
Maintained by: mww openmaintainer
Categories: lang
Platforms: darwin
Dependencies: cctools cloog gcc_select gmp ld64 libiconv libmpc mpfr ppl
Variants: universal​

gcc42 4.2.4The GNU compiler collection
Maintained by: mww openmaintainer
Categories: lang
Platforms: darwin
Dependencies: cctools gcc_select gmp ld64 libiconv mpfr​

g95 0.92Another GNU Fortran 95 compiler
Maintained by: takeshi
Categories: lang
Platforms: darwin
Dependencies: libiconv libtool
Variants: gcc42​

Wenn ich es richtig sehe betrifft mich libxml2 eher nicht da es unter Dependencies nicht auftaucht oder?

@Andy.321 hast du vielleicht noch den Link?
 
Zuletzt bearbeitet:

Andy.321

Aktives Mitglied
Mitglied seit
13.02.2007
Beiträge
1.635
Zuletzt bearbeitet:

redbird

Mitglied
Thread Starter
Mitglied seit
20.09.2007
Beiträge
433
libxml2 könnte von einem Port benötigt werden, der oben als Dependance steht, also zum Beispiel libmpc...
Ist es denn zur Zeit bei dir installiert?
also ich hab mal bei Macports alle Ports durchgeklickt die für gcc oder g95 verwendet werden. gefunden habe ich keinen libxml2. allerdings ist das keine sichere Methode..
ja leider es ist bei mir installiert allerdings habe in auch viel zu viel installiert was ich garnicht benötige ;)
 

MaxKnall

Neues Mitglied
Mitglied seit
17.03.2012
Beiträge
5
Ich habe gestern von Lion auf ML upgegradet. Macports läuft bei mir weiterhin.
Reihenfolge wie oben in den Links beschrieben:

  1. Xcode 4.4 über den App Store installieren
  2. In Xcode die Command Line Tools installieren
  3. .pkg von Macports installieren
Die Probleme mit libxml2 scheinen behoben - bei mir läuft es wie auch schon bei Lion nachdem ich mit selfupdate und upgrade outdatet alles auf den neuesten Stand gebracht habe (da war auch libxml2 als Dependency dabei).
 

redbird

Mitglied
Thread Starter
Mitglied seit
20.09.2007
Beiträge
433
Die Probleme mit libxml2 scheinen behoben - bei mir läuft es wie auch schon bei Lion nachdem ich mit selfupdate und upgrade outdatet alles auf den neuesten Stand gebracht habe (da war auch libxml2 als Dependency dabei).
das klingt ja sehr gut :)
hat denn jemand auch Paraview in Verwendung und kann was dazu sagen?
 

redbird

Mitglied
Thread Starter
Mitglied seit
20.09.2007
Beiträge
433
eine Sache ist noch wichtig.

folgendes muss man noch nach dem installieren von xcode ins Terminal schreiben:
"sudo xcodebuild -license"
dann bis ende scrollen
und "agree"

sonst lassen sich manche Ports nicht installieren
ging mir grad so beim gcc47