"Mit Server verbinden" braucht mehrere Anläufe

Dieses Thema im Forum "Netzwerk-Hardware" wurde erstellt von Authorist, 09.03.2008.

  1. Authorist

    Authorist Thread Starter Mitglied

    Beiträge:
    214
    Zustimmungen:
    2
    Mitglied seit:
    05.12.2006
    Hallo,

    auf allen unseren Macs sind diverse Serververbindungen hinterlegt, die mit Apfel-K im Finder zu finden sind. Zum einen sind es Freigaben auf Macs, zum anderen SMB-Freigaben auf Windows Rechnern.

    Fast immer kommt beim ersten Verbindungsversuch eine Fehlermeldung: "Der Finder konnte den Vorgang nicht abschliessen, weil einige Daten (...) nicht gelesen oder geschrieben werden konnten (Fehler -36)."

    Beharre ich auf der Apfel-K variante, und klicke mehrfach auf "Erneut versuchen", wird die Verbindung in 99% der Fälle irgendwann hergestellt. Es kommt aber auch vor, dass der Verbindungsversuch endlos weiter läuft und das Fenster nicht mehr zu geht. Erst das Abmelden des Benutzers hilft dann weiter, manchmal nur der Knopf.

    Wenn ich in so einem Fall, also wenn die Verbindung nicht zustande kommt, den konventionellen Weg gehe, also Finder -> Netzwerk -> Server -> Verbinden etc., kommt die Meldung "Der Alias (...) konnte nicht geöffnet werden, da das Original nicht gefunden wurde."

    Was ist das für ein Mist? Diese Problematik taucht wie gesagt nicht nur mit SMB-Freigaben auf, sondern auch mit Macs, und sie taucht auch nicht nur auf einem Mac auf, sondern auf allen, noch dazu in verschiedenen Netzen. Ist die Verbindung erstmal hergestellt, ist alles wunderbar. Es nervt halt fürchterlich.

    Wer weiss Rat?

    A.
     
  2. maceis

    maceis Mitglied

    Beiträge:
    16.719
    Zustimmungen:
    603
    Mitglied seit:
    24.09.2003
    Könnte möglicherweise an einem fehlerhaften physikalischen Aufbau des Netzwerks, schlechten/falschen/defekten Steckern und/oder Kabeln, zu engen Biegeradien, Störquellen (z.B. zu dicht neben den Netzwerkkabeln verlegten Elektrokabeln, zu nahen Leuchtstoffröhren etc.) o.ä. liegen.
    Wenn Du das überprüfen möchtest, kannst Du das Netz von einem Profi(!) durchmessen lassen.

    Eine andere Ursache könnte ein ungünstiger logische Netzwerkaufbau sein. Stichwort Broadcaststürme u.ä.
     
  3. Authorist

    Authorist Thread Starter Mitglied

    Beiträge:
    214
    Zustimmungen:
    2
    Mitglied seit:
    05.12.2006
    Wie gesagt, es taucht in mehreren Netzen auf, die nicht das geringste miteinander zu tun haben. Das passiert sogar bei mir zu Hause, wenn ich die Windows-Freigabe von meinem Macbook aus anspreche, da gibt es grad mal einen kleinen Router und 1 PC, Cat.7 vom Profi verkabelt (Neubau).

    Darüber hinaus machen alle Windows-Rechner keinerlei Probleme, die Macs ja soweit auch nicht, nur bei der Verbindungsherstellung. Die Transferraten sind mit 150-200 GByte/h absolut traumhaft, wir spielen uncompressed SD Video ruckelfrei übers Netz ab, ich bin so frei und schliesse das mal aus.

    A.
     
  4. AcidReign

    AcidReign Mitglied

    Beiträge:
    1.189
    Zustimmungen:
    17
    Mitglied seit:
    15.03.2005
    Habe das Problem auch.
    Leider völlig willkürlich und nicht reproduzierbar.

    Mal kann mein MacPro sich sofort mit meinem Linux-File-Server verbinden. Mal nach dem 10 Versuch. Der MacMini schafft es meißtens ohne Probleme. 1-2 Problemchen gabs aber da auch.

    Ich habe das Gefühl, dass das ganze seit 10.5.2 schlimmer geworden ist.
     
  5. Authorist

    Authorist Thread Starter Mitglied

    Beiträge:
    214
    Zustimmungen:
    2
    Mitglied seit:
    05.12.2006
    Aha. Endlich mal noch wer. Noch jemand?
     
  6. Authorist

    Authorist Thread Starter Mitglied

    Beiträge:
    214
    Zustimmungen:
    2
    Mitglied seit:
    05.12.2006
    Weiss denn keiner eine Lösung? Hallo????
     
  7. starbuckzero

    starbuckzero Mitglied

    Beiträge:
    987
    Zustimmungen:
    121
    Mitglied seit:
    15.01.2006
    Lösung kann ich nicht bieten, nur bestätigen, dass sowas häufig vorkommt. Bei mir äußert es sich so:

    - Mac geht mit aktiver SMB-Verbindung in Standby => in 30-50% der Fälle nach dem Standby keine neue SMB-Verbindung möglich, meistens Fehler -36, manchmal auch nur Beachball und Findercrash
    - Workaround wäre vor dem Standby die SMB-Verbinding zu trennen, nur leider lässt diese sich des öfteren nicht auswerfen, da angeblich in Benutzung. Passiert selbst, wenn der Host gar nicht mehr läuft.
    - Bestehende SMB-Verbindung über Ethernet tut nicht (siehe oben), lustigerweise kann man über WLAN die gleichen Shares noch mounten. Bis zum nächsten Standby, dann geht meistens beides nicht mehr.
    - Die einzige Lösung ist ein Neustart, dabei hängt OS X zwischen 2 Minuten und unendlich, zu sehen ist nur das Hintergrundbild und der rotierende Kreis, alle anderen Prozesse wurden beendet. Manchmal klappts von alleine mit dem Neustart, meistens hilft nur Powerknopf.

    Leopard ist in Sachen gemischte Netzwerke genausowenig zu gebrauchen wie Tiger, auch wenn es nicht mehr ganz so unzuverlässig funktioniert. Die Windows- und Linuxsysteme bei mir zicken in Sachen Netzwerk bei weitem nicht so rum.
     
  8. Encounter

    Encounter Mitglied

    Beiträge:
    507
    Zustimmungen:
    31
    Mitglied seit:
    24.02.2005
    Ähnliches Problem mit AFP...

    Habe ein ähnlicher Problem mit Leopard 10.5.2 (Insgesamt 4 Rechner) bei dem Zugriff über AFP auf einen OSX Tiger Server 10.4.11. Dauert auch Ewigkeiten (2-3 Minuten) bis sich was tut. Und zwar noch jedem Neustart erneut oder wenn man das Volume sich erneut "holen" will. Die Tiger-Arbeitsplätze habe damit kein Problem. Dort geht es sofort. Es kann also nur an den Leopard-Clients liegen :(. Habe aus einigen Quellen schon mir sagen lassen, dass die Dateifreigabe und die Netzwerkdienste unter Leopard (noch) nicht das Gelbe vom Ei sind. Bleibt in meinem Fall abzuwarten ob es sich mit 10.5.3 erledigt hat. Achso was merkwürdigerweise noch dazu kommt. Mit einem zu Testzwecken eingerichteten Leopard Server 10.5.2 kommunizieren die Leopard-Clients wunderbar. Habe nur das Problem das sich das Eingeben von Benutzeridentifikationen sehr komisch und fehlerhaft verhält :(
    Alles nicht gerade zufriedenstellend...
     

Diese Seite empfehlen

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.