streghetta

Neues Mitglied
Thread Starter
Dabei seit
14.05.2014
Beiträge
42
Punkte Reaktionen
0
Hallo in die Runde,
nachdem ich vor kurzem mein System (10.9.4) komplett neu aufsetzen musste und eine automatische Migration meiner Daten nicht möglich war, kämpfe ich immer noch mit Problemen beim manuellen Kopieren.
Da wäre einmal ein immer noch ungelöstes Problem mit iTunes (s. entsprechendes Unterforum, falls jemandem dazu etwas einfällt) –
fast noch schlimmer ist aber die Situation mit Mail.
Und zwar habe ich zuerst ganz unbedarft Mail einfach mal gestartet und meine alten Mails (über "Postfächer importieren) importiert. Das Ergebnis war aber nicht zufriedenstellend; v.a. die >3000 gesendeten Mails waren nicht am richtigen Ort, konnten nicht alle gleichzeitig in den Gesendet-Ordner verschoben werden, und jede Teilportion brauchte Eeeeeeeeewigkeiten. Außerdem war eine unüberschaubare Anzahl von Mails doppelt, und sowas hasse ich – davon abgesehen, dass es wertvollen Speicherplatz braucht!
Ich hab also mal gegoogelt, wie man normalerweise die Mails migriert, und bin auf folgende Anleitung gestoßen: http://macs.about.com/od/usingyourmac/ss/moving-apple-mail.htm.
Ich habe alles gemacht wie angegeben: Keychains und Mail-Ordner rüberkopiert; com.apple.mail.plist war in den Preferences aber nicht vorhanden. Mail neu gestartet und importieren lassen und festgestellt, dass es nicht funktioniert.
Da ich das Ganze inzwischen schon gefühlte 10x probiert habe (inkl. Neustarts zwischendurch), kann ich nicht genau sagen, ob von Anfang an alle Probleme schon da waren oder erst jetzt. Jedenfalls stimmt Folgendes nicht:
1. Manche Mails sind leer (nur Betreffzeile vorhanden, nicht lesbar, aber im Finder korrekt gespeichert; bei Wiederherstellen des Postfachs verschwinden sie). Bekanntes Problem; aber den Envelope Index und Envelope Index-shm zu löschen führte beim nächsten Öffnen zu Fehlermeldung, Absturz, und bei Neustart zu erneutem Importieren.
2. Wenn ich die entsprechenden Mails einfach neu importieren will (über die Importfunktion), werden nicht alle importiert. Es sind trotzem MEHR als im ursprünglichen System (ich hab mal die Zahlen vom Mai aus dem alten System aufgeschrieben), allerdings weiß ich nicht, ob da bei den Konversationen auch die gesendeten Mails mitgezählt werden. Die gesendeten Mails aus dem einen Account (Gmx) sind auch weg und lassen sich auch nicht einfach importieren.
3. Am schlimmsten: bei jeder Neuindizierung verdoppelt sich die Datenmenge! Und zwar sind im Backup die Mails in ~/Library/Mail/V2/Mailboxes/Postfachname/AA2CE19C-7476-4E89-8EEA-5D150C9C0360 gespeichert und dort in Data, 10 nummerierten Unterordnern (0-9) sowie einem Ordner namens Messages. (Ich verstehe nicht, wieso manche Mails direkt in "Messages" sitzen und manche in der Baumstruktur). Selbige Ordner werden also kopiert. ABER: Wenn Mail wieder Mails "importiert", entsteht neben AA2CE19C-7476-4E89-8EEA-5D150C9C0360 ein neuer Ordner mit bei jeder Indizierung wechselnden Namen (aktuell z.B. 149A8D75-9FD5-4D76-A72D-3989B3F28436), in dem sich /Data/Messages und darin alle Mails (Anzahl kommt hin) mit neuen Namen (von 1 anfangend) befinden. Das gleiche passiert in allen Postfächern sowie untergeordneten Postfächern. Ich habe schon mal versucht, entweder die alten oder die neuen Ordner zu löschen, aber davon ändert sich auch nichts an den leeren Mails, und bei Neuindizierung passiert wieder das gleiche. Und ob ich jetzt 4 oder 8 GB an Mails habe, macht schon einen Unterschied...!
4. Weiß nicht, ob es damit zu tun hat oder wo das herkommt, aber die VIP-Postfächer funktionieren nicht mehr korrekt: Es sind zwar die Mails von VIP-Personen automatisch darin, aber zusätzlich auch viele, viele Mails, die überhaupt nichts damit zu tun haben, von verschiedenen Absendern und aus verschiedensten Postfächern (zumindest Eingang, Werbung und Papierkorb).
Bitte bitte helft mir, ich werde hier noch ganz verrückt... :eek:
 

Rul

Aktives Mitglied
Dabei seit
16.10.2009
Beiträge
12.016
Punkte Reaktionen
2.813
Der Mailordner, der wichtig ist, ist folgender: "V2"
Den findest du am Mac hier: file:///Users/Username/Library/Mail/

Den suchst du dir im Backup und ersetzt den am Mac damit. Mail öffnen, Kennwort für das Postfach eingeben. Fertig. Simples Drag & Drop.

Also folgende Vorgehensweise:
Mail schließen.
Den Ordner V2 im Backup suchen.
Den Ordner mit dem Ordner am Mac ersetzen.
Mail starten.

Funktioniert bei mir mit etwa 10 Mailadressen, zig intelligenten Ordnern seit Lion ohne Probleme.
 

streghetta

Neues Mitglied
Thread Starter
Dabei seit
14.05.2014
Beiträge
42
Punkte Reaktionen
0
Ja, genau den hab ich genommen, bzw. ich hab mal einzelne mbox rüberkopiert, mal den ganzen V2 und mal den ganzen Mail-Ordner. Funktioniert nicht. :(
 

Rul

Aktives Mitglied
Dabei seit
16.10.2009
Beiträge
12.016
Punkte Reaktionen
2.813
Lösche die ganzen Sachen mal aus dem aktuellen Mail (also im Programm selbst.).
Lösche auch die ganzen Accounts nochmals, dass du ein leeres Mail hast. (Accounts, Postfächer usw.)
Dann nimmst du den unberührten Ordner V2 aus dem Backup und ersetzt den am Mac befindlichen Ordner V2 damit.
Dann startest du Mail nochmals und schaust ob es funktioniert.
 

streghetta

Neues Mitglied
Thread Starter
Dabei seit
14.05.2014
Beiträge
42
Punkte Reaktionen
0
Danke für den Tipp. Hat aber leider auch nichts genützt :( Leere Mails zuhauf, im Finder alles doppelt und Chaos auch mit den VIPs.
Wenn ich wenigstens sicher wäre, ob ich einen von den Ordnern mit den verrückten Namen einfach löschen kann bzw. welchen, dann würde ich vielleicht die fehlenden Mails doch einfach importieren...
 
Oben Unten