Mac Pc Linux Netzwerk Problem

milez4

Mitglied
Thread Starter
Mitglied seit
01.05.2003
Beiträge
13
Hallo Forum,
Wir haben folgende Konfiguration in unserem Büro:

1Server/Router: Debian mit Samba
2 Macs 10.3
Diverse PCs Winxp, Win98

und folgendes Problem:

Der File Transfer vom Server zum Mac und anders herum ist extrem! langsam.
Arbeiten vom Mac auf dem Server ist nicht möglich, aufgrund des sehr langsamen Zugriffs.

Wenn ich über den Pc vom Server auf den Mac kopiere, ist die Geschwindigkeit normal.

Kennt jemand dieses Problem?

Gruß
Jan
 

cpeyer

Mitglied
Mitglied seit
02.12.2004
Beiträge
63
milez4 schrieb:
Der File Transfer vom Server zum Mac und anders herum ist extrem! langsam.
Arbeiten vom Mac auf dem Server ist nicht möglich, aufgrund des sehr langsamen Zugriffs.

Wenn ich über den Pc vom Server auf den Mac kopiere, ist die Geschwindigkeit normal.
kann dir zwar nicht helfen, habe aber das gleiche problem mit redhat server und mac zugriffen. alles andere funktioniert super. scheint sich sonst hier niemand damit rumzuschlagen. habe schon ipv6 deaktiviert, bringt aber auch nix.
greets chris
 

schuecke

Mitglied
Mitglied seit
10.01.2004
Beiträge
285
Ich würd mal die entsprechenden Pakete fü samba/ftp/sshd usw. updaten, so als ersten Ansatz. Ansonsten mal auf dem Server tcpdump laufen lassen und gucken was da so passiert während eines Mac-Zugriffs.
 

ThunderGOD

Mitglied
Mitglied seit
26.05.2004
Beiträge
172
bei mir läuft ein Suse 8.2 als Fileserver, das einzige wo ich langsamen zugriff erkennt ist wenn der Finder Order auslesen muss wo sich sehr viele Daten befinden. da dauert es schon ein Weilchen bis man was sieht ... und er lät dann immer noch Daten nach d.h.. springt er bei mir schon mal ein paar Seiten hin und her ... naja der smb zugriff ist noch nicht so richtig ausgereift ... mal schauen was Tiger bringt ....
 

MrFX

Mitglied
Mitglied seit
26.09.2003
Beiträge
7.355
Moin!

Als Alternative NFS (v3) benutzen...

Das smb-Protokoll von Apple ist ziemlich langsam :D

MfG
MrFX
 

fromrussia

Mitglied
Mitglied seit
01.01.2004
Beiträge
533
Gut das im Vorneherein zu wissen, wir planen auch ein Netz mit mehreren WIN XP PCs und einem Mac. In diesem Zusammenhang die frage kann man auf dem Server NFS und SAMBA gleichzeitig laufen lasen? NFS für den Mac, Samba für WIN XP?
 

MrFX

Mitglied
Mitglied seit
26.09.2003
Beiträge
7.355
Moin!

Aber klar doch...

Rein theoretisch kannst du für den Mac aber auch (zusätzlich) netatalk (AppleShare) aufsetzen. Ist aber schwieriger zu konfigurieren als NFS.

MfG
MrFX
 

schuecke

Mitglied
Mitglied seit
10.01.2004
Beiträge
285
Ich hab hier keine Probleme damit - 2 10.3.7-Systeme und ein RH9-Fileserver.
Kann mich über langsame Verbindungen nicht beklagen.
 

hr.hartwig

Mitglied
Mitglied seit
19.01.2005
Beiträge
8
Hallo!
Habe das selbe Problem mit Mac und Linux. Aber nur in eine Richtung.
Mac upload auf Linux = schnell
Mac download von Linux gegen Null
Mit Netatalk beide Richtungen sehr schnell.
Bei einem Bekannten genau dasselbe.
Neulich bin ich mal mit dem Mac auf meinen Linux "Arbeitsrechner" gegangen.
Und, hoppla!! beide Richtungen schnell! Nanu, wie ist nun los?
Nach grübeln viel mir auf, daß die Rechner, die ich als Server benutze
alle einen AMD-Prozessor haben. Mein "Arbeitsrechner" hat einen Pentium PIII.
Nun habe ich leider nicht mehrere Pentium-Rechner um das zu bestätigen.
Ob es wirklich daran liegt weiß ich nicht, -ich wüßte auch gar nicht, warum-
es fiel mir halt so auf. Was benutzt Ihr denn für Prozessoren im Server?
Gruß, Horst-Rainer
 

cpeyer

Mitglied
Mitglied seit
02.12.2004
Beiträge
63
hr.hartwig schrieb:
Hallo!
...
Nun habe ich leider nicht mehrere Pentium-Rechner um das zu bestätigen.
Ob es wirklich daran liegt weiß ich nicht, -ich wüßte auch gar nicht, warum-
es fiel mir halt so auf. Was benutzt Ihr denn für Prozessoren im Server?
Gruß, Horst-Rainer
mein server ist ein p2 450 mhz. da drauf läuft rh9.
lg
chris
 

schuecke

Mitglied
Mitglied seit
10.01.2004
Beiträge
285
Intel P3 450 mit Intel BX-Chipsatz und Intel Pro 100 Netzwerkkarte.
Da drauf läuft dann RH9. Am Prozessor würde ich das weniger festmachen, aber der verwendete Chipsatz wäre da vielleicht interessant.
 

cpeyer

Mitglied
Mitglied seit
02.12.2004
Beiträge
63
schuecke schrieb:
Intel P3 450 mit Intel BX-Chipsatz und Intel Pro 100 Netzwerkkarte.
Da drauf läuft dann RH9. Am Prozessor würde ich das weniger festmachen, aber der verwendete Chipsatz wäre da vielleicht interessant.
was immer du sagst. kenne mich mit den pc-teilen nicht so aus. wie find ich denn den chipsatz raus?
 

Kryptaesthesie

Mitglied
Mitglied seit
17.05.2004
Beiträge
576
hr.hartwig schrieb:
Mit Netatalk beide Richtungen sehr schnell.
Hast du da zufällig eine gute Beschreibung, wie ich das einrichte?
Danke schon mal



MrFX schrieb:
Moin!

Als Alternative NFS (v3) benutzen...

Das smb-Protokoll von Apple ist ziemlich langsam :D

MfG
MrFX

Gute Idee, nur was macht man dann mit Dateien, die Umlaute enthalten? Bei wird aus dem Namen "Böser Ordner" einfach "B_"...

MfG Kryp
 
Zuletzt bearbeitet:

schuecke

Mitglied
Mitglied seit
10.01.2004
Beiträge
285
"cat /var/log/dmesg" zeigt dir eigentlich alle wichtigen Infos zur Hardware an (so wie sie beim Systemstart erkannt werden).
"cat /proc/cpuinfo" gibt dir genaue Auskunft über deinen Prozessor.
Unter /proc/ide befindet sich bei mir eine Datei "piix", vielleicht hast du ja da etwas entsprechendes - darin steht der Chipsatz auch nochmal.

Gerade bei älteren AMDs könnte das gut der Chipsatz sein - da gab es schon echt grottige Hardware (VIA KT-133 z.b.) die alles war, nur nicht stabil.
 

hr.hartwig

Mitglied
Mitglied seit
19.01.2005
Beiträge
8
Hallo!
Am Prozessor liegt es tatsächlich nicht.
Dann habe ich mal die Netzwerkkarten ausgetauscht Intel Pro 100 gegen Realtek.
Mit einer SuSE-Distribution ging es plötzlich sehr schnell. Mit Debian nicht.
(Wie oben beschrieben).
Als ich am nächsten Tag die Rechner wieder einschaltete, war es wieder langsam, wie oben beschrieben. Ich krieg noch 'ne Kriese...
Wenn ich auf dem Server FreeBSD starte, geht es wunderbar,
gal welche Netzwerkkarte... (auch mit Samba!).
Ich schätze, man muß irgendwelche Netzwerkkarten-Parameter einstellen.
Wenn ich mehr weiß, melde ich mich.

PS.: So langsam finde ich Samba nicht. (wenns denn läuft...)
Aber wie gesagt, Netatalk ist bei mir am schnellsten.
Oben hat mich jemand gefragt, wie ich das konfiguriere.
So schwierig ist es nicht. Einfach Netatalk installieren. In den config-Dateien
steht drinn, was man machen muß. War überrascht, wie leicht das ging...;-)
Gruß, Horst-Rainer
 

schuecke

Mitglied
Mitglied seit
10.01.2004
Beiträge
285
Vielleicht liegts an der Samba-Konfiguration.
Man könnte die ja mal vergleichen.
 

hr.hartwig

Mitglied
Mitglied seit
19.01.2005
Beiträge
8
schuecke schrieb:
Vielleicht liegts an der Samba-Konfiguration.
Man könnte die ja mal vergleichen.
Darauf hin habe ich aus meiner smb.conf einen Zweizeiler gemacht:
.
[homes]
writable = yes
.
Mit einer Realtek oder Winbond Netzwerkkarte keine Chance.
Sehr Interessant:
Mit Realtek im Server:
Upload von Mac auf Server gut, download schlecht (gegen Null)
Bei Winbond im Server genau umgekehrt (!) .
Mit einer Intel Pro 100 im Server geht der Up- und Download richtig gut ab!
Sogar der W2k-Klient legt bei den Transferraten noch richtig einen Zahn zu.
Mit Realtek im Server lagen die Up- und Downloadgeschwindigkeiten
bei +- 6Mbit/sec. Jetzt bei fast 8Mbit/sec.
Mich würden mal Eure Erfahrungen interessieren.
Gruß, Horst-Rainer