m1 netstat und keine localhost verbindungen

MOM2006

Mitglied
Thread Starter
Registriert
21.09.2011
Beiträge
944
hallo,
ist es normal das netstat auf einem m1 mac keine verbindungen von localhost anzeigt. der selbe befehl auf einem intel mac liefert localhost verbindungen. bspw. listen auf port 631 für cups. beides big sur 11.2.3
mach ich was falsch oder normales verhalten?
 

MOM2006

Mitglied
Thread Starter
Registriert
21.09.2011
Beiträge
944
Hast du auf dem M1 das CUPS Interface aktiviert?
ehm ich hab das webinterface wieder deaktiviert und mehrfach rebootet. auf beiden macbooks bekommt der browser connection refused.

aber:

m1:
Code:
xxx@macbook-m1 ~ % netstat -an -ptcp | grep LISTEN
tcp6       0      0  *.49868                *.*                    LISTEN     
tcp4       0      0  *.49868                *.*                    LISTEN     

xxx@macbook-m1 ~ % sudo cupsctl
Password:
_debug_logging=0
_remote_admin=0
_remote_any=0
_share_printers=0
_user_cancel_any=0
BrowseLocalProtocols=dnssd
DefaultAuthType=Basic
JobPrivateAccess=default
JobPrivateValues=default
PageLogFormat=
SubscriptionPrivateAccess=default
SubscriptionPrivateValues=default
WebInterface=No

Intel:

Code:
xxx@macbook-intel ~ % netstat -an -ptcp | grep LISTEN
tcp4       0      0  127.0.0.1.631      *.*                    LISTEN
tcp6       0      0  ::1.631                 *.*                    LISTEN    
tcp6       0      0  *.49868                *.*                    LISTEN     
tcp4       0      0  *.49868                *.*                    LISTEN 

xxx@macbook-intel ~ % sudo cupsctl
Password:
_debug_logging=0
_remote_admin=0
_remote_any=0
_share_printers=0
_user_cancel_any=0
BrowseLocalProtocols=dnssd
DefaultAuthType=Basic
JobPrivateAccess=default
JobPrivateValues=default
PageLogFormat=
SubscriptionPrivateAccess=default
SubscriptionPrivateValues=default
WebInterface=No
 

MOM2006

Mitglied
Thread Starter
Registriert
21.09.2011
Beiträge
944
ja. und bei beiden funktioniert mittlerweile das drucken. hatte in einem anderen thread ja geschrieben, dass der intel nicht wollte
 

MOM2006

Mitglied
Thread Starter
Registriert
21.09.2011
Beiträge
944
nein. drucker ist auf keinem der macbooks freigegeben

muss ich nicht verstehen.

sudo cupsctl Webinterface=yes und dann sudo cupsctl Webinterface=no zeigt im netstat plötzlich die verbindungen. selbst nach einem reboot werden sie am m1 jetzt angezeigt. und auf beiden geräten localhost:631 hauptseite aufrufbar. bei jedem anderen link auf der Seite meint er ich soll das webinterface aufdrehen. das scheint mir alles sehr komisch zu sein. denn zuvor konnt ich auf keinem der geräte die localhost:631 aufrufen, auch nicht am intel book wo ein listen war

halleluja das energiemanagement vom m1 schlägt zu.

kommt der bildschirmschoner (bei mir nach 2 minuten) wird der cups localhost:631 einfach gestoppt
 
Zuletzt bearbeitet:

lisanet

Aktives Mitglied
Registriert
05.12.2006
Beiträge
3.404
"webinterface benutzbar" und "webinterface erreichbar" sind unterschiedliche Dinge. Für mich macht es durchaus Sinn, dass solange das Drucksystem läuft, der eingebaute Webserver auch läuft und die Einstiegsseite zeigt. Die weitere Nutzung kann dann durchaus eingeschränkt sein.
 

MOM2006

Mitglied
Thread Starter
Registriert
21.09.2011
Beiträge
944
am m1 läuft das ding nachdem boot solange scheinbar. bis bildschirmschoner und energie management kommt.danach ist der listener komplett weg, wenn das m1 vom bildschirmschoner zurückgeholt wird.

also gibts gar keine probleme, dass localhost listen nicht angezeigt wird, sondern das macbook stoppt die scheinbar beim zurückkommen vom screensaver. wird wohl seine richtigkeit haben
 

MOM2006

Mitglied
Thread Starter
Registriert
21.09.2011
Beiträge
944
gegencheck am intel mbp. kommt der screensaver oder der monitor wird abgedreht übers energie management, dann ist auch der localhost:631 listen nach aufwachen weg

bis zu dem zeitpunkt wenn ich lokal dann ein dokument drucken will, wird cups listen 631 wieder gestartet
 
Oben