Lion Mail.app: Probleme mit reinem Text

tgam

Aktives Mitglied
Thread Starter
Mitglied seit
15.02.2008
Beiträge
1.306
Hallo!

Folgendes Problem beschäftigt mich: Egal, welche Einstellungen ich in der Mail.app unter Lion auch einstelle, html oder reinen Text, die Anzeige im Header ist immer "Content-Type: text/html; charset=us-ascii". Andere Clients wie beispieslweise dagegen Outlook produzieren korrekt "text/plain; charset="iso-8859-1"

Meine Vermutung ist, dass Apple hier die Einstellung seit Lion unveränderbar auf die Kombination html + Text gestellt hat, um mit der Mail.app des iPad gleichzuziehen, in der diese Einstellung auch vorgegeben ist.

In diesem Falle wäre eine konsequente Plain-Text-Einstellung nicht mehr korrekt möglich, sondern lediglich so eine Art Simulation.

Habt ihr damit Erfahrungen oder Erkenntnisse?

Mit besten Grüßen,

Thomas
 

tgam

Aktives Mitglied
Thread Starter
Mitglied seit
15.02.2008
Beiträge
1.306
Ich habe mittlerweile mehrere Tests auf anderen Macs gemacht und überall dasselbe Ergebnis bekommen. Von "kein generelles Problem" kann also nicht die Rede sein. Und von wegen "wie im Thread beschrieben"; du warst der einzige, der mir in dieser Weise geantwortet hat. Da dies offensichtlich ungenügend war, stelle ich die Frage nochmals. Aber abgesehen davon: Wie kommst du eigentlich dazu, mich maßregeln zu wollen?
 

mikrowellenpiet

Aktives Mitglied
Mitglied seit
13.07.2011
Beiträge
2.193
Wenn man ständig neue Threads eröffnet, dann hilft das nicht gerade der Lösungsfindung, da vieles mehrfach gefragt und beantwortet werden muss.

Ungenügend im anderen Thread waren Deine Antworten, das System bzw. Die Mailversion zu nennen ist Mindesvoraussetzung, um Dir bei Deinem Problem helfen zu können.
 

tgam

Aktives Mitglied
Thread Starter
Mitglied seit
15.02.2008
Beiträge
1.306
Sorry, wenn ich gestern daran nicht gedacht habe. Du hast allerdings dann auch verdammt lange gebraucht, um das festzustellen. Ich gebe dir hier insofern recht, als dass ich einfach meinen Thread von gestern hätte fortsetzen können. Aber auch das ist mir eben erst eingefallen. Nur, das hättest du mir auch netter ansagen können. Aber ich entschuldige mich für auch meine harsche Reaktion, das war auch nicht gut.
 

tgam

Aktives Mitglied
Thread Starter
Mitglied seit
15.02.2008
Beiträge
1.306
Noch zwei Zusätze: Gerade habe ich im Header einer Mail von einem Bekannten, der mit der Preview von Mountain Lion arbeitet, gesehen, dass dort die korrekte Einstellung eingetragen ist. Das lässt hoffen. Ausserdem habe ich diesen Hinweis gefunden:

"Mail has a unique feature in which messages are automatically sent in plain text format unless action is taken to format the email with rich text editing options. This aspect of Mail can be misleading because the selected default font for new messages is not what will show up on the recipient's side unless there is a manually formatted RTF aspect to the email." Das könnte erklären, warum die Einstellung wohl bislang immer auf text/plain steht: Weil so eine RTF-Formatierung möglich ist.
 

mikrowellenpiet

Aktives Mitglied
Mitglied seit
13.07.2011
Beiträge
2.193
Das bedeutet, dass Mail als Plaintext verschickt, wenn man nicht manuell formatiert.

Bist Du bei Dir mal ein größere Anzahl von gesendeten Mail mit "alt + cm + u" durchgegangen? Insbesondere auch Mails ohne/mit Signatur und Anhang und mit/ohne Formatierungen?
 

tgam

Aktives Mitglied
Thread Starter
Mitglied seit
15.02.2008
Beiträge
1.306
Guten Morgen; das war ein sehr guter Hinweis! In der Tat kannte ich diesen Befehl noch nicht, sondern habe mir nur den Header angeschaut. Ich habe nun ein paar „Tests“ gemacht und dabei festgestellt, das Apple Mail immer, selbst bei Einstellung „reiner Text“ und beim Weglassen einer wie auch immer gearteten Signatur den Text zwar in „reinem Text“ verfasst, diesen aber wiederum in einen html-Code integriert. Dieser wird wahrscheinlich nicht angezeigt, ist aber wohl der Option geschuldet, mit RTF-Formatierungen versehen werden zu können.
Sieht so aus:

<html><head></head><body class="ApplePlainTextBody" style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">Einfacher Test</body></html>

Outlook beispielsweise dagegen schreibt eine „reine Text“-Mail tatsächlich ausschließlich als „text/plain“ ohne jeglichen Zusatz. Kann aber natürlich auch in html gewechslet werden, allerdings muss das dann manuell aktiviert werden.

Hier sehe ich allerdings einen klaren Vorteil gegenüber Mail, denn allzuoft passiert es, dass durch den unbeabsichtigten Einsatz einer Formatierung die Sendeform gewechselt wird, ohne dass ich das mitbekomme. Beispielsweise sendet Aperture Fotos automatisch als „inline“-Bilder und ändert das Format der Mail, egal, was voreingestellt ist. Man muss es dann sicherheitshalber zusätzlich manuell ans Ende befördern. Im Gegensatz zu Lightroom, dass das Bild von vornherein als Anhang belässt.

Obwohl das Problem vielleicht zu vernachlässigen gewesen wäre hat es mich etwas „gequält“, denn ein Empfänger, zumal wenn es sich um Kunden handelt, kann davon schon unter Umständen irritiert werden.

Also bleibe ich vorerst bei Outlook. Denn immer wieder habe ich sehen müssen, dass bei Kunden meine Mails unerwartet formatiert gezeigt wurden, obwohl Apple Mail ich auf „reinen Text“ festgelegt hatte. Auch sendet Mail nach wie vor, trotz mancher Vorsichtsmaßnahmen, nur Thumbnails statt kompletter Bilder.


Danke nochmals, dein Hinweis hat mir sehr geholfen. Jetzt, meine ich, ist der Thread mit einer Lösung für mein Problem soweit positiv komplett ...:)
 

mikrowellenpiet

Aktives Mitglied
Mitglied seit
13.07.2011
Beiträge
2.193
<html><head></head><body class="ApplePlainTextBody" style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">Einfacher Test</body></html>
Wenn das in der Mail enthalten ist, dann ist es keine reine Plaintext-E-Mail. Bei mir ist bei den Plaintext-E-Mails (z.B. "Content-Type: text/plain; charset=utf-8") kein obiger Code mit enthalten.

Kann es sein, dass Du Dir Entwürfe angesehen hast und nicht versendetet E-Mails?
 

tgam

Aktives Mitglied
Thread Starter
Mitglied seit
15.02.2008
Beiträge
1.306
Du liebe Güte - du hast recht! Jetzt bin ich wirklich überzeugt. Die gesendete Mail enthält diesen Zusatz nicht mehr. Jetzt verstehe ich es noch einmal mehr. Und wahrscheinlich hast du mich doch vor Outlook bewahrt.
 
Oben