libgcrypt - intel mac

Galdo

Galdo

Mitglied
Thread Starter
Dabei seit
29.09.2004
Beiträge
594
Punkte Reaktionen
0
Hi,

ich weiß nicht, ob ich hier richtig bin, aber ich habe mal ne Frage bzgl. der libgcrypt. Und zwar benötige ich genanntes Paket für den vpnc-vpn-client - leider lässt sich aber die Version aus dem CVS bzw. SVN nicht kompilieren.

ein ./autogen.sh funktioniert noch wunderbar, auch das daraufhin erstellte ./configure läuft noch wunderbar durch. Aber bei make erhalte ich dann folgende Fehlermeldung:
if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../src -I/usr/local/include -g -O2 -Wall -Wcast-align -Wshadow -Wstrict-prototypes -MT mpiutil.lo -MD -MP -MF ".deps/mpiutil.Tpo" -c -o mpiutil.lo mpiutil.c; \
then mv -f ".deps/mpiutil.Tpo" ".deps/mpiutil.Plo"; else rm -f ".deps/mpiutil.Tpo"; exit 1; fi
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../src -I/usr/local/include -g -O2 -Wall -Wcast-align -Wshadow -Wstrict-prototypes -MT mpiutil.lo -MD -MP -MF .deps/mpiutil.Tpo -c mpiutil.c -fno-common -DPIC -o .libs/mpiutil.o
mpiutil.c: In function 'gcry_mpi_randomize':
mpiutil.c:415: warning: pointer targets in passing argument 1 of 'gcry_create_nonce' differ in signedness
mpiutil.c:422: warning: pointer targets in passing argument 2 of '_gcry_mpi_set_buffer' differ in signedness
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../src -I/usr/local/include -g -O2 -Wall -Wcast-align -Wshadow -Wstrict-prototypes -MT mpiutil.lo -MD -MP -MF .deps/mpiutil.Tpo -c mpiutil.c -o mpiutil.o >/dev/null 2>&1
gcc -E -I../src -DHAVE_CONFIG_H mpih-add1.S | grep -v '^#' > mpih-add1.s
make[2]: *** [mpih-add1.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Hat jemand ne Ahnung, was das bedeuten soll und was ich dagegen machen kann?

Danke für die Hilfe

GALDO
 
O

oldmangloom

Neues Mitglied
Dabei seit
12.03.2006
Beiträge
13
Punkte Reaktionen
0
Hi,

mach doch mal n 'make | grep error', um zu sehen ob da noch irgendwelche Errors drin sind. Die Warnings scheinen nicht so schlimm zu sein, die Ursache liegt wohl eher bei 'mpih...whatever'.

Viel Erfolg,

G.
 
oneOeight

oneOeight

Aktives Mitglied
Dabei seit
23.11.2004
Beiträge
67.689
Punkte Reaktionen
16.105
ich würde die sourcen noch mal auspacken, das autogen.sh weglassen und nur configure aufrufen...

der fehler bei dir entsteht irgendwo beim compilieren und dem linken von mpih-add1
 
Galdo

Galdo

Mitglied
Thread Starter
Dabei seit
29.09.2004
Beiträge
594
Punkte Reaktionen
0
naja ohne autogen.sh hab ich ja kein configure. Es ruft im wesentlichen ein autoconf auf, was mir das configure erzeugt.

mpicoder.c: In function 'gcry_mpi_scan':
mpicoder.c:387: warning: pointer targets in passing argument 1 of 'mpi_read_from_buffer' differ in signedness
mpicoder.c:440: warning: pointer targets in passing argument 2 of 'mpi_fromstr' differ in signedness
mpicoder.c: In function 'gcry_mpi_print':
mpicoder.c:482: warning: pointer targets in assignment differ in signedness
mpicoder.c:513: warning: pointer targets in assignment differ in signedness
mpicoder.c:534: warning: pointer targets in assignment differ in signedness
mpicoder.c:549: warning: pointer targets in assignment differ in signedness
mpiutil.c: In function 'gcry_mpi_randomize':
mpiutil.c:415: warning: pointer targets in passing argument 1 of 'gcry_create_nonce' differ in signedness
mpiutil.c:422: warning: pointer targets in passing argument 2 of '_gcry_mpi_set_buffer' differ in signedness
make[2]: *** [mpih-add1.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Galdo
 
Y

ybasket

Mitglied
Dabei seit
17.01.2006
Beiträge
327
Punkte Reaktionen
3
probier doch mal die sourcen vom letzten stable release, vielleicht ist die
problematische Funktion seitdem geändert worden und nicht mehr
mac-kompatibel.
Wenn das nichts hilft guck mal in FAQs oder der Documentation.
Viel Glück
 
Galdo

Galdo

Mitglied
Thread Starter
Dabei seit
29.09.2004
Beiträge
594
Punkte Reaktionen
0
Das funktioniert schon, allerdings ergibt sich dann folgendes Problem mit dem vpnc:
dyld: lazy symbol binding failed: Symbol not found: __gcry_mpih_lshift
Referenced from: /usr/local/lib/libgcrypt.11.dylib
Expected in: flat namespace

dyld: Symbol not found: __gcry_mpih_lshift
Referenced from: /usr/local/lib/libgcrypt.11.dylib
Expected in: flat namespace

Trace/BPT trap
und ich vermute mal, dass das problem mit einer nicht intel-kompatiblen Version der libgcrypt zusammenhängt!

Was solls...

trotzdem danke

GALDO
 
oneOeight

oneOeight

Aktives Mitglied
Dabei seit
23.11.2004
Beiträge
67.689
Punkte Reaktionen
16.105
Galdo schrieb:
naja ohne autogen.sh hab ich ja kein configure. Es ruft im wesentlichen ein autoconf auf, was mir das configure erzeugt.

komisch, ich habe vorhin die sourcen von gnu.org gezogen und da war es dabei...

installier doch fink, da ist libgcrypt auch dabei...
(k.a. ob auch beim intel fink)

an intel wird das kompilieren nicht scheitern...
eher an falschen optionen durch autogen und configure oder compiler/link switches...
 

Ähnliche Themen

oldsierra
Antworten
2
Aufrufe
336
oldsierra
oldsierra
N
Antworten
8
Aufrufe
236
Nicolas1965
N
Matschbacke25
Antworten
18
Aufrufe
337
iCeeKay
I
Oben