Kann Programm zum öffnen von Dateien nicht ändern

spice

Mitglied
Thread Starter
Dabei seit
18.03.2005
Beiträge
188
Punkte Reaktionen
1
Hallo,

ich nutze auf meinem Powerbook mit 10.4.2 u.a. den LaTeX-Editor TeXShop zum erstellen von TeX Dokumenten.

Da vor kurzem eine neue Version von TeXShop erschienen ist, habe ich die alte kurzerhand gelöscht (in den Papierkorb gelegt) und die neue Version installiert.

Soweit so gut. Irgendwann habe ich dann mal den Papierkorb mit dem alten TeXShop geleert. Anschließend wusste Tiger dann nicht mehr, mit welchem Programm die *.tex Dateien zu öffnen sind. Alles nicht so schlimm dachte ich, habe kurzerhand wieder den neuen TeXShop ausgewählt. Doch leider ist es nunmehr so, dass Tiger bis auf ein paar Ausnahmen alle *.tex Dateien mit dem Skript-Editor 2.1 öffnen will. Ich hab keine Ahnung warum. Vielleicht hab ich mich mal verklickt oder, ich weiss es echt nicht.

Auch hier dachte ich, halb so schlimm. Mit Apfel+I hab ich mir die Eigenschaften einer tex-Datei anzeigen lassen. Dort ist ja ein Feld zum Ändern des Programms, mit welchem die Datei geöffnet werden soll. Dort habe ich dann TeXShp eingestellt. Leider blieb das Icon der Datei unverändert (Skripteditor). Ein Doppelklick hingegen öffnet TeXShop. Aber nur bis zum nächsten Neustart, dann ist der Skripteditor wieder an der Reihe. Das ganze kann ich jetzt beliebig oft wiederholen. Ich hab keine Ahnung woran das liegt. Ich habe dann auch mal in den Dateieigenschaften alle "Alle ändern" geklickt, nachdem ich erneut TeXShop ausgewählt hatte. Das hat leider auch nicht geholfen. Der Erfolg war, dass nun alle Dateien mit dem Skripteditor (obwohl ich TeXShop ausgewählt habe) geöffnet werden.

Das ist echt komisch und ich habe keine Ahnung, woran das liegt. Ich dachte immer, dass Tiger, ähnlich wie Windows, an der Dateiendung erkennt, um welchen Dateityp es sich handelt. Das stimmt aber wohl nicht, da in den Dateieigenschaften bei "Art" manchmal "tex" und machmal (bei den Dateien, die mit dem Skripteditor geöffnet werden) "Text" steht.

Habt Ihr ne Idee, woran das liegen könnte?

Danke im Vorraus...

spice
 

Lynhirr

Aktives Mitglied
Dabei seit
22.04.2005
Beiträge
11.123
Punkte Reaktionen
352
Ich habe ein solches Problem mal gelöst, indem ich die Systemoptimierung habe laufen lassen. (zB mit der Freeware OnyX)
 
Oben Unten