Java - welche version?

  1. thb

    thb Thread Starter MacUser Mitglied

    Mitglied seit:
    16.10.2004
    Beiträge:
    280
    Zustimmungen:
    13
    vielleicht eine ziemlich dumme Frage - habe aber keine Antwort gefunden.
    WO kann ich sehen, ob Java installiert ist oder nicht?
    WIE kann ich feststellen ob Java funktioniert oder nicht?
    WIE oder WO kann ich die Version erkennen?
    Ursache ist, das ich Probleme mit einer Webseite habe sowohl mit Firefox als auch mit Safari
     
  2. Hunda1b2c3

    Hunda1b2c3 MacUser Mitglied

    Mitglied seit:
    05.03.2004
    Beiträge:
    283
    Zustimmungen:
    2
    Schau unter Dienstprogramme/Java mal nach.
    Gruß
     
  3. thb

    thb Thread Starter MacUser Mitglied

    Mitglied seit:
    16.10.2004
    Beiträge:
    280
    Zustimmungen:
    13
    das habe ich schon gemacht, im Ordner "Java" sind diverse Dateien drin, aber wie, wo, was????
    Eingabemethode-Kurzbefehl.app
    ein Ordner J2SE 5.0 mit Java Cache Viewer und Java Preferences
    1.3.1 und 1.4.2 Plugin-Einstellungen.app
    und
    Java Web Start.app
    wo ist aber Java - das besteht doch nicht etwa nur aus Preferences und Plugin-Einstellungsdateien?

    es bleiben meine Fragen vom Anfang:
    WO kann ich sehen, ob Java installiert ist oder nicht?
    WIE kann ich feststellen ob Java funktioniert oder nicht?
    WIE oder WO kann ich die Version erkennen?
     
  4. Mr. D

    Mr. D MacUser Mitglied

    Mitglied seit:
    24.10.2003
    Beiträge:
    3.384
    Zustimmungen:
    124
    Terminal öffnen und Folgendes eingeben:
    java -version und dann Enter drücken

    Java liegt hier:
    System->Library->Frameworks->JavaVM.framework
     
  5. thb

    thb Thread Starter MacUser Mitglied

    Mitglied seit:
    16.10.2004
    Beiträge:
    280
    Zustimmungen:
    13
    Wunderbar - jetzt bin ich einen Schritt weiter, danke!
    Terminal sagt:
    java version "1.5.0_06"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-112)
    Java HotSpot(TM) Client VM (build 1.5.0_06-64, mixed mode, sharing)
    ist das nun die aktuellste Fassung für mac?
    ich habe unter jaca.com den Java-Test "Test your Java Virtual Machine (JVM)" gemacht und bekomme dann folgende Antwort:
    "You are using an older version of Java ..."
    Wenn ich dann versuche bei apple eine aktuelle version herunterzuladen und zu installieren, heißt es ich hätte die aktuellste version auf dem Rechner und deshalb könne ich keine version installieren ....
    Was ist denn nun die aktuellste version?
     
  6. 1.5.0_06 ist die aktuelle Version für den Mac.

    Für Windows (Linux weiß ich nicht) gibt es schon Version 6 (als Beta glaube ich, bin da aber auch nicht mehr auf dem aktuellen Stand) - vielleicht kommt deshalb die Fehlermeldung...

    Auf einem Mac hinkst Du den aktuellen Java-Versionen eh immer hinterher, weil Sun Java nicht für den Mac bereitstellt und Apple den Kram dann selbst portieren muß...
     
  7. thb

    thb Thread Starter MacUser Mitglied

    Mitglied seit:
    16.10.2004
    Beiträge:
    280
    Zustimmungen:
    13
    neue Verwirrung

    wenn bei mir Laut Terminal die version 1.5.0_06 installiert ist, warum kann dann sowohl safari als auch firefox nur auf ein "Java 1.3.1 Plug-in" zugreifen. Irgendetwas stimmt da doch nicht ... Vielleicht kann ich Java komplett vom Rechner löschen und neu installieren? Wenn ja wie lösche ich wirklich alle Komponeneten?
     
  8. Eisengigant

    Eisengigant MacUser Mitglied

    Mitglied seit:
    22.07.2005
    Beiträge:
    218
    Zustimmungen:
    0
    Vielleicht kennt einer ja nen Workaround oder ne andere Lösung:
    Gut ich weiss nicht wie problematisch das Problem bei anderen usern ist, aber bei der Seite "kiezkollegen.de" z.B. kann man leute anschuaen via eines netten stammbaumes, programmiert in java. das kann man seit ner zeit nich mehr nutzen.
    Oder aber der "routenflug" von map24 klappt beim mac einfach nich und sieht aus als ob man eine langsame maschine hätte.
    Möglicherweise gibt es einen Trick oder sowas....neueste version scheints ja nich zu bringen. 10.4.8 auch nich....na ja.
     
Die Seite wird geladen...